Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Empty Java editors: anyone has this problem?
Empty Java editors: anyone has this problem? [message #52441] Wed, 09 July 2008 10:25 Go to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Hello all!
When I start Eclipse and activate a task on which I was working the day
before, the editors of the files in the context are correctly reopened,
but it often happens that if I switch on one of the open editors which
is not in the foreground, I get an "empty" editor (a grey panel) instead
of the Java editor. The only workaround I found is to close and reopen
the editor (but in this way I remove the file from the context and I
have to reopen it using Ctrl+Shift+T), because switching to another
editor and going back to the empty one does not help, while neither
issuing a refresh on the file helps.

I have been facing this problem for long now, I hoped it were fixed in
Mylyn 3.0 but it is not. Am I the only one to have this problem? It's
quite an intrusive issue, but I cannot find a deterministic way to
reproduce.

Thanks in advance!
Mauro.
Re: Empty Java editors: anyone has this problem? [message #52499 is a reply to message #52441] Wed, 09 July 2008 14:53 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

I just noticed it also happens with the JSP editor...

Mauro.
Re: Empty Java editors: anyone has this problem? [message #52552 is a reply to message #52499] Wed, 09 July 2008 19:33 Go to previous messageGo to next message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 237
Registered: July 2009
Senior Member
Happens to me too since some days. Let us digg out what is causing this.

Greets
Benny

Mauro Molinari wrote:
> I just noticed it also happens with the JSP editor...
>
> Mauro.
Re: Empty Java editors: anyone has this problem? [message #52606 is a reply to message #52441] Thu, 10 July 2008 18:26 Go to previous messageGo to next message
Steffen Pingel is currently offline Steffen PingelFriend
Messages: 706
Registered: July 2009
Senior Member
I also ran into this bug intermittently. I think I have even seen it when no
task was active on startup and the editors had been restored by the
workbench (Mylyn uses the same mechanism).

Mauro, please file a new bug and provide any steps you may have to reproduce
the problem.

Steffen


Mauro Molinari wrote:

> Hello all!
> When I start Eclipse and activate a task on which I was working the day
> before, the editors of the files in the context are correctly reopened,
> but it often happens that if I switch on one of the open editors which
> is not in the foreground, I get an "empty" editor (a grey panel) instead
> of the Java editor. The only workaround I found is to close and reopen
> the editor (but in this way I remove the file from the context and I
> have to reopen it using Ctrl+Shift+T), because switching to another
> editor and going back to the empty one does not help, while neither
> issuing a refresh on the file helps.
>
> I have been facing this problem for long now, I hoped it were fixed in
> Mylyn 3.0 but it is not. Am I the only one to have this problem? It's
> quite an intrusive issue, but I cannot find a deterministic way to
> reproduce.
>
> Thanks in advance!
> Mauro.
Re: Empty Java editors: anyone has this problem? [message #52797 is a reply to message #52606] Mon, 14 July 2008 08:52 Go to previous message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Steffen Pingel ha scritto:
> Mauro, please file a new bug and provide any steps you may have to reproduce
> the problem.

Thank you Steffen, I opened the following bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=240636

Mauro.
Re: Empty Java editors: anyone has this problem? [message #591079 is a reply to message #52441] Wed, 09 July 2008 14:53 Go to previous message
Mauro Molinari is currently offline Mauro MolinariFriend
Messages: 281
Registered: July 2009
Senior Member
I just noticed it also happens with the JSP editor...

Mauro.
Re: Empty Java editors: anyone has this problem? [message #591102 is a reply to message #52499] Wed, 09 July 2008 19:33 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 237
Registered: July 2009
Senior Member
Happens to me too since some days. Let us digg out what is causing this.

Greets
Benny

Mauro Molinari wrote:
> I just noticed it also happens with the JSP editor...
>
> Mauro.
Re: Empty Java editors: anyone has this problem? [message #591127 is a reply to message #52441] Thu, 10 July 2008 18:26 Go to previous message
Steffen Pingel is currently offline Steffen PingelFriend
Messages: 706
Registered: July 2009
Senior Member
I also ran into this bug intermittently. I think I have even seen it when no
task was active on startup and the editors had been restored by the
workbench (Mylyn uses the same mechanism).

Mauro, please file a new bug and provide any steps you may have to reproduce
the problem.

Steffen


Mauro Molinari wrote:

> Hello all!
> When I start Eclipse and activate a task on which I was working the day
> before, the editors of the files in the context are correctly reopened,
> but it often happens that if I switch on one of the open editors which
> is not in the foreground, I get an "empty" editor (a grey panel) instead
> of the Java editor. The only workaround I found is to close and reopen
> the editor (but in this way I remove the file from the context and I
> have to reopen it using Ctrl+Shift+T), because switching to another
> editor and going back to the empty one does not help, while neither
> issuing a refresh on the file helps.
>
> I have been facing this problem for long now, I hoped it were fixed in
> Mylyn 3.0 but it is not. Am I the only one to have this problem? It's
> quite an intrusive issue, but I cannot find a deterministic way to
> reproduce.
>
> Thanks in advance!
> Mauro.
Re: Empty Java editors: anyone has this problem? [message #591228 is a reply to message #52606] Mon, 14 July 2008 08:52 Go to previous message
Mauro Molinari is currently offline Mauro MolinariFriend
Messages: 281
Registered: July 2009
Senior Member
Steffen Pingel ha scritto:
> Mauro, please file a new bug and provide any steps you may have to reproduce
> the problem.

Thank you Steffen, I opened the following bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=240636

Mauro.
Previous Topic:Working Set and Mylyn
Next Topic:editor tabs re-ordered when switching tasks
Goto Forum:
  


Current Time: Sun Dec 21 03:35:43 GMT 2014

Powered by FUDForum. Page generated in 0.01726 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software