Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Problem while exporting RCP
Problem while exporting RCP [message #514061] Fri, 12 February 2010 10:38 Go to next message
Eclipse UserFriend
Originally posted by: rene.hamannt.menten-gmbh.de

Hi,

I have an RCP application created with eclipse 3.1 and now I imported it
into eclipse 3.5.
Everythings seams to be just fine. I can start the RCP application in RUN or
DEBUG mode within my eclipse 3.5, but when I try to export eclipse using the
..product export, I recieve an error arround 80%:
----------------------------
....\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclips e.pde.container.feature\assemble.org.eclipse.pde.container.f eature.p2.xml:38:
The following error occurred while executing this line:
....\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclips e.pde.container.feature\assemble.org.eclipse.pde.container.f eature.p2.xml:139:
Unable to delete file
....\.metadata\.plugins\org.eclipse.pde.core\temp\assemblyLo cation\tmp\p2.branding\org.eclipse.pde.container.feature_roo t.win32.win32.x86\jre\sample\jnlp\jreinstaller\build\solaris \jreinstallers\resources\javaws-1_0_1-j2re-1_4_2-solaris-spa rc.
----------------------------
I have no clue where this comes from and why there might be a problem. Has
anybody a suggestion?
Thanks very much...

Regards,
Rene
Re: Problem while exporting RCP [message #514439 is a reply to message #514061] Mon, 15 February 2010 10:57 Go to previous message
Sabir Mising name is currently offline Sabir Mising nameFriend
Messages: 68
Registered: February 2010
Member
The problem might be with using p2 directory try to remove the p2 directory or install eclipse delta pack 3.5.1 and give a try ..
Re: Problem while exporting RCP [message #514474 is a reply to message #514439] Mon, 15 February 2010 09:00 Go to previous message
Eclipse UserFriend
Originally posted by: rene.hamannt.menten-gmbh.de

Hi Sabir,

thanks for your advice.

But deleting the directory as well as downloading the delta pack and
exporting the RCP again resulted into the following ERROR:
----------------------------------------------------------
An error occurred while collecting items to be installed
- Error reading signed
content:C:\DOKUME...\LOKALE~1\Temp\signatureFile431497152554 2671112.jar
- Problems downloading artifact:
osgi.bundle,ONE_EXTERNAL_JAR_PROJECT_AS_PLUGINs,1.0.0.
- session context was:(profile=profile,
phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.Collect,
operand=, action=).
----------------------------------------------------------

Any possible solutions or things I might try?

Regards,
Rene


"Sabir" <sabirleads@gmail.com> schrieb im Newsbeitrag
news:hlb9ae$lbd$1@build.eclipse.org...
> The problem might be with using p2 directory try to remove the p2
> directory or install eclipse delta pack 3.5.1 and give a try ..
Previous Topic:rcp and junit test
Next Topic:Problem of setFocus not working properly in editor
Goto Forum:
  


Current Time: Wed Nov 26 11:42:46 GMT 2014

Powered by FUDForum. Page generated in 0.02271 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software