Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problem with Eclipse missing /usr/lib/eclipse/startup.jar on Unbuntu
Problem with Eclipse missing /usr/lib/eclipse/startup.jar on Unbuntu [message #512215] Thu, 04 February 2010 12:28 Go to next message
Eclipse User
Originally posted by: nick.cortexcontrollers.com

I apologise if I am posting to the wrong forum. If so, please can someone
tell me which forum is appropriate.

I had Eclipse working satisfactorily on an Ubuntu 8.04 machine after using
"apt-get install eclipse sun-java6-jdk".

I then tried to add extra features but rather foolishly attempted to load
every option. This got very confused so I thought I would start again and
looked up how to remove eclipse. I read that the way to do this was to
remove /usr/lib/eclipse and /usr/local/lib/eclipse. I did this. I realise
now that I should probably have used "apt-get remove eclipse"!

Anyway, I have re-installed eclipse using "apt-get install eclipse" but now
every time I try to run eclipse I get the message "Unable to access jarfile
/usr/lib/eclipse/startup.jar" and Eclipse fails to run. When I look in
"/usr/lib/eclipse" I see that indeed it contains no file called
"startup.jar".

I have looked on the web and see that others have had similar problems but
could not see a solution.

I have tried "apt-get remove eclipse" and "apt-get install eclipse" many
times but have had no success. As I recall, the first time I installed
eclipse it was a fairly lengthy process generating lots of screen output---
it looked as lots of files were being generated. The recent "remove" and
"install" processes are very quick which seems to imply "remove" doesn't
actually remove everything. Is there some way I can force a completely new
"install from scratch"? Or is there some other solution?

Thank you,

Nick Toop
Re: Problem with Eclipse missing /usr/lib/eclipse/startup.jar on Unbuntu [message #512570 is a reply to message #512215] Fri, 05 February 2010 14:13 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You'll have to talk to someone familiar with your distro to figure out
how to clean up and re-install an partially deleted package.

You can get an Eclipse tar you can just untar and use from
http://download.eclipse.org/eclipse/downloads (or pre-packaged ones from
http://www.eclipse.org )

PW



--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Previous Topic:Custom TextEditor, key events and custom encoding
Next Topic:Multiple Different Editors for a Single Resource
Goto Forum:
  


Current Time: Thu Oct 30 18:24:56 GMT 2014

Powered by FUDForum. Page generated in 0.02889 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software