Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse product export missing executable binary
Eclipse product export missing executable binary [message #503535] Mon, 14 December 2009 06:00 Go to next message
M.  is currently offline M.
Messages: 6
Registered: December 2009
Junior Member
Greetings,

I have a problem exporting a small plugin based RCP application using Eclipse 3.5SR2 or 3.6M4. The corresponding delta pack is added to the default target platform and the launcher artifacts are added as a dependency.

When exporting everything seems fine, no error message appears. Unfortunately the exported product is missing its executable.

In the target directories "linux.gtk.x86_64/appname" and "win32.win32.x86_64/appname" are only a single file named "artifacts.xml" and two directories "p2" and "plugins". There is no executable binary and the "plugins" directories are missing the launcher artifacts.

Parallel to them is a directory "repositories/plugins" which does contain the launcher artifacts.

I already exported the application successfully using Eclipse 3.4. some month ago but I can't find the missing point in the current configuration.

Any help is appreciated,
M.
Re: Eclipse product export missing executable binary [message #505136 is a reply to message #503535] Sun, 27 December 2009 10:20 Go to previous messageGo to next message
Wim Jongman is currently offline Wim Jongman
Messages: 418
Registered: July 2009
Senior Member
Hi M.

Yes, this sometimes happens to me too. I can never really duplicate the
situation. I always remove the product and rebuild it again. Is your product
plugin listed in the list of plugins?

--

Best Regards,
Wim Jongman
-- When 900 years old, you reach
Re: Eclipse product export missing executable binary [message #505316 is a reply to message #503535] Tue, 29 December 2009 09:54 Go to previous messageGo to next message
M.  is currently offline M.
Messages: 6
Registered: December 2009
Junior Member
Yes, the product plugin (same as the application plugin) is included in the dependencies.

Do you recreate the default.product file or do you remove and recreate a complete plugin?
Re: Re: Eclipse product export missing executable binary [message #505500 is a reply to message #505316] Thu, 31 December 2009 02:40 Go to previous message
Wim Jongman is currently offline Wim Jongman
Messages: 418
Registered: July 2009
Senior Member
Hi M.

I remove the product file and start over. Also remove all the ...product
extensions in the containing plugin. Why do you call your product "default"?


--

Best Regards,
Wim Jongman
-- R2-D2, you know better than to trust a strange computer.
C-3PO, Star Wars Episode V: The Empire Strikes Back


> Yes, the product plugin (same as the application plugin) is included in the
dependencies.
>
> Do you recreate the default.product file or do you remove and recreate a
complete plugin?
Previous Topic:Javadocs as OSGi Bundle?
Next Topic:Application Menu bar disappears when used OLEControlSite
Goto Forum:
  


Current Time: Sat Jul 26 11:27:26 EDT 2014

Powered by FUDForum. Page generated in 0.02438 seconds