Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPF » Cannot open my Library with EPF anymore!!!
Cannot open my Library with EPF anymore!!! [message #50884] Thu, 12 June 2008 15:07 Go to next message
llauramelie is currently offline llauramelieFriend
Messages: 28
Registered: July 2009
Junior Member
Hi everybody,

I've got a serious problem on my Library.

I recently put my Library under Version Control, and change the name of
the root folder which contains:
- PLUGINS folders
- LIBRARY.XMI file

I could work without any problem since...

- I removed a workproduct that I don't need (let's call it WP_1) directly
from an external text editor in my file PLUGIN.XMI to solve the following
problem:
org.xml.sax.SAXParseException:
Element type "org.eclipse.epf.uma:DeliverableDescription" must be
followed by either attribute specifications, ">" or "/>".

Then, the problem window gave the following message on a error located in
my LIBRARY.XMI file:
"Could not resolve proxy 'uma://_"
referring to the ID of my PLUGIN.

And then several similar errors located in my CONFIGURATIONS files which
begin with:
"Could not find the normalized URI for 'uma://"
or
"Could not resolve proxy 'uma://"
referring to all my Method Packages and Capability Patterns related to the
configuration.

So, these are the actions I undertook to try to solve my errors:
- I checked all my relationships between the different elements (guid, ID,
name of files, etc.) and I didn't found anything anormal.
- I even re-copy the paragraph that I deleted before in PLUGIN.XMI, but
that not solve anything.
- in LIBRARY.XMI, I rename my root folder path URI in:
<org.eclipse.epf.uma:MethodLibrary xmi:id="_sOd5sDFpEd2b4Zuz1BfMUw"
name="EPFC Library"
guid="_sOd5sDFpEd2b4Zuz1BfMUw">
to be consistent with the current name of my root folder. But that didn't
sove anything...

Now, when I try to open my METHOD LIBRARY with EPF, I receive the
following message:
"One or many files of this editor have been removed. The editor is no
longer valid and has to close."

What should I do to continue to work on my Library?


I hope someone have something to propose to me...

Thank you for your attention.


Regards,

Ms.Hampshire
Re: Cannot open my Library with EPF anymore!!! [message #502617 is a reply to message #50884] Wed, 09 December 2009 07:56 Go to previous messageGo to next message
allan_t  is currently offline allan_t Friend
Messages: 2
Registered: December 2009
Junior Member
Hi Ms.Hampshire,

I am experiencing a similar problem.
Were you able to come up with a solution/ workaround?
Hope you can share.

Thanks!
Re: Cannot open my Library with EPF anymore!!! [message #518124 is a reply to message #50884] Wed, 03 March 2010 07:53 Go to previous messageGo to next message
Gerhard Schneider is currently offline Gerhard SchneiderFriend
Messages: 17
Registered: October 2009
Junior Member
do you use SVN?

Regards,
Gerhard

---

innoreq® Gerhard Schneider - Prozesse einfach verbessern.
http://www.innoreq.com
Re: Cannot open my Library with EPF anymore!!! [message #599032 is a reply to message #50884] Wed, 09 December 2009 07:56 Go to previous messageGo to next message
allan_t  is currently offline allan_t Friend
Messages: 2
Registered: December 2009
Junior Member
Hi Ms.Hampshire,

I am experiencing a similar problem.
Were you able to come up with a solution/ workaround?
Hope you can share.

Thanks!
Re: Cannot open my Library with EPF anymore!!! [message #599235 is a reply to message #50884] Wed, 03 March 2010 07:53 Go to previous message
Gerhard Schneider is currently offline Gerhard SchneiderFriend
Messages: 17
Registered: October 2009
Junior Member
do you use SVN?
--
Regards,
Gerhard

---

innoreq® Gerhard Schneider - Prozesse einfach verbessern.
http://www.innoreq.com


Regards,
Gerhard

---

innoreq® Gerhard Schneider - Prozesse einfach verbessern.
http://www.innoreq.com
Previous Topic:Files corrupted?
Next Topic:Lack of Process Overview
Goto Forum:
  


Current Time: Thu Nov 27 00:31:50 GMT 2014

Powered by FUDForum. Page generated in 0.01639 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software