Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » True Multi Module Support?
True Multi Module Support? [message #502128] Sun, 06 December 2009 10:13 Go to next message
Chad La Joie is currently offline Chad La JoieFriend
Messages: 15
Registered: July 2009
Location: Zürich, Switzerland
Junior Member
I was wondering if IAM had good multi-module support.

Specifically my questions are:
- Is there multi-module support such that each module can be its own eclipse project and dependencies are properly handled?
- Is there support for things like dependency and plugin management within the parent POM?
Re: True Multi Module Support? [message #502825 is a reply to message #502128] Wed, 09 December 2009 20:04 Go to previous messageGo to next message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
On 12/6/09 2:13 AM, Chad La Joie wrote:
> I was wondering if IAM had good multi-module support.
> Specifically my questions are:
> - Is there multi-module support such that each module can be its own
> eclipse project and dependencies are properly handled?

yes, that's the default approach

> - Is there support for things like dependency and plugin management
> within the parent POM?

you can import the parent pom project too and pretty much things will work.

The real issue with multimodule projects and eclipse is the lack of
support at the core for nested projects, a long time feature request in
the Eclipse community

https://bugs.eclipse.org/bugs/show_bug.cgi?id=35973
https://bugs.eclipse.org/bugs/show_bug.cgi?id=245412
Re: True Multi Module Support? [message #502869 is a reply to message #502825] Thu, 10 December 2009 06:06 Go to previous messageGo to next message
Chad La Joie is currently offline Chad La JoieFriend
Messages: 15
Registered: July 2009
Location: Zürich, Switzerland
Junior Member
Is there any documentation then for how do this?

I have the parent project in my workspace and then imported each child module as a project and it's definitely not working. In particular no child project seems to be able to see the parent POM so all of the settings there are completely ignored.
Re: True Multi Module Support? [message #503319 is a reply to message #502869] Fri, 11 December 2009 20:04 Go to previous messageGo to next message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
http://code.google.com/p/q4e/wiki/ImportingMultiprojects

but what you talk about is probably because you don't have properly
configured relativePath (by default looks in the parent dir) in your
children poms
http://maven.apache.org/guides/introduction/introduction-to- the-pom.html#Example_2


On 12/9/09 10:07 PM, Chad La Joie wrote:
> Is there any documentation then for how do this?
>
> I have the parent project in my workspace and then imported each child
> module as a project and it's definitely not working. In particular no
> child project seems to be able to see the parent POM so all of the
> settings there are completely ignored.
Re: True Multi Module Support? [message #503409 is a reply to message #503319] Sun, 13 December 2009 06:11 Go to previous messageGo to next message
Chad La Joie is currently offline Chad La JoieFriend
Messages: 15
Registered: July 2009
Location: Zürich, Switzerland
Junior Member
Thanks I got this to work. It wasn't the relative path thing. I was just using the standard filesystem import not the Maven2 importer.
Re: True Multi Module Support? [message #503410 is a reply to message #503409] Sun, 13 December 2009 10:26 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
thanks for your feedback, glad it worked

On 12/12/09 10:11 PM, Chad La Joie wrote:
> Thanks I got this to work. It wasn't the relative path thing. I was
> just using the standard filesystem import not the Maven2 importer.
Re: True Multi Module Support? [message #571552 is a reply to message #502825] Thu, 10 December 2009 06:07 Go to previous message
Chad La Joie is currently offline Chad La JoieFriend
Messages: 15
Registered: July 2009
Location: Zürich, Switzerland
Junior Member
Is there any documentation then for how do this?

I have the parent project in my workspace and then imported each child module as a project and it's definitely not working. In particular no child project seems to be able to see the parent POM so all of the settings there are completely ignored.
Re: True Multi Module Support? [message #571621 is a reply to message #571552] Fri, 11 December 2009 20:04 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
http://code.google.com/p/q4e/wiki/ImportingMultiprojects

but what you talk about is probably because you don't have properly
configured relativePath (by default looks in the parent dir) in your
children poms
http://maven.apache.org/guides/introduction/introduction-to- the-pom.html#Example_2


On 12/9/09 10:07 PM, Chad La Joie wrote:
> Is there any documentation then for how do this?
>
> I have the parent project in my workspace and then imported each child
> module as a project and it's definitely not working. In particular no
> child project seems to be able to see the parent POM so all of the
> settings there are completely ignored.
Re: True Multi Module Support? [message #571671 is a reply to message #503319] Sun, 13 December 2009 06:11 Go to previous message
Chad La Joie is currently offline Chad La JoieFriend
Messages: 15
Registered: July 2009
Location: Zürich, Switzerland
Junior Member
Thanks I got this to work. It wasn't the relative path thing. I was just using the standard filesystem import not the Maven2 importer.
Re: True Multi Module Support? [message #571701 is a reply to message #571671] Sun, 13 December 2009 10:26 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
thanks for your feedback, glad it worked

On 12/12/09 10:11 PM, Chad La Joie wrote:
> Thanks I got this to work. It wasn't the relative path thing. I was
> just using the standard filesystem import not the Maven2 importer.
Previous Topic:True Multi Module Support?
Next Topic:Sources for dependency jars
Goto Forum:
  


Current Time: Fri Dec 19 10:14:54 GMT 2014

Powered by FUDForum. Page generated in 0.02319 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software