Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Synchronize view not up to date
Synchronize view not up to date [message #497084] Thu, 12 November 2009 13:41 Go to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
Hi!

I see this problem since years (from eclipse v3.3 IIRC).
Now I use v3.5.1 with the latest subversive plugin.

Symptom:
- the view in Synchronize (for example Outgoing mode) is not displaying all items
- going to other mode (Incoming) and back "fixes" it: now everything is displayed as it should

Right now I did this:
- start eclipse
- work for a while (change a few versioned files)
- go to Team Synchronizing perspective
- click Populate (view was in Outgoing mode)
Result:
- one of the projects I worked on and had a few files changed is not displayed at all (other projects with changed files are)
- I click on Incoming mode and again on Outgoing and now the missing project with files is there


Is there an open bug on this?

If you know the problem, then switching mode is an easy workaround, but it is still a bit annoying.

Regards,
David
Re: Synchronize view not up to date [message #498194 is a reply to message #497084] Sun, 15 November 2009 19:35 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
Another case:

In Incoming mode it shows for a folder (named "src) that it is new, but when I expand it by clicking in the plus sign, no children are shown to it. Switching between modes, refreshing, resynchronizing does not help.

Then I right click the project and this appears in the console:

*** Update
svn update "F:\ws\pr1\src" -r HEAD --depth infinity --username "davbal"
	  F:/ws/pr1/src/java/at
	  F:/ws/pr1/src/java/com
	  F:/ws/pr1/src/java
	A F:/ws/pr1/src/test
	A F:/ws/pr1/src/test/at
	A F:/ws/pr1/src/test/at/yuna
	A F:/ws/pr1/src/test/at/yuna/sequence
	A F:/ws/pr1/src/test/at/yuna/sequence/SequenceTest.java
	  F:/ws/pr1/src
	  F:/ws/pr1
At revision 919
*** Ok (took 00:01.969)



Subversive is :
Subversive SVN Team Provider (Incubation) 0.7.8.I20090904-1300 org.eclipse.team.svn.feature.group
Re: Synchronize view not up to date [message #498215 is a reply to message #498194] Sun, 15 November 2009 22:29 Go to previous messageGo to next message
Jörg Thönnes is currently offline Jörg ThönnesFriend
Messages: 229
Registered: July 2009
Senior Member
Hi David,

two suggestions:

1. Try again with latest weekly build. There have been a couple of bug fixes since September.
2. File an Eclipse Bugzilla bug for Subversive if the behaviour persists.

Thanks, Jörg

On 11/15/09 20:35, David Bala wrote:
> Another case:
>
> In Incoming mode it shows for a folder (named "src) that it is new, but
> when I expand it by clicking in the plus sign, no children are shown to
> it. Switching between modes, refreshing, resynchronizing does not help.
>
> Then I right click the project and this appears in the console:
>
>
> *** Update
> svn update "F:\ws\pr1\src" -r HEAD --depth infinity --username "davbal"
> F:/ws/pr1/src/java/at
> F:/ws/pr1/src/java/com
> F:/ws/pr1/src/java
> A F:/ws/pr1/src/test
> A F:/ws/pr1/src/test/at
> A F:/ws/pr1/src/test/at/yuna
> A F:/ws/pr1/src/test/at/yuna/sequence
> A F:/ws/pr1/src/test/at/yuna/sequence/SequenceTest.java
> F:/ws/pr1/src
> F:/ws/pr1
> At revision 919
> *** Ok (took 00:01.969)
>
>
>
> Subversive is :
> Subversive SVN Team Provider (Incubation) 0.7.8.I20090904-1300
> org.eclipse.team.svn.feature.group
Re: Synchronize view not up to date [message #498256 is a reply to message #497084] Mon, 16 November 2009 08:48 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
David,

We know that there are situations when Synchronize view content isn't always
correct depending on modes. It seems there's already bug in tracker decribed
by you, please see https://bugs.eclipse.org/bugs/show_bug.cgi?id=266477 (I
even provided a patch to it but it's not yet fixed).

> Hi!
>
> I see this problem since years (from eclipse v3.3 IIRC).
> Now I use v3.5.1 with the latest subversive plugin.
>
> Symptom:
> - the view in Synchronize (for example Outgoing mode) is not displaying
> all items
> - going to other mode (Incoming) and back "fixes" it: now everything is
> displayed as it should
>
> Right now I did this:
> - start eclipse
> - work for a while (change a few versioned files)
> - go to Team Synchronizing perspective
> - click Populate (view was in Outgoing mode)
> Result:
> - one of the projects I worked on and had a few files changed is not
> displayed at all (other projects with changed files are)
> - I click on Incoming mode and again on Outgoing and now the missing
> project with files is there
>
>
> Is there an open bug on this?
>
> If you know the problem, then switching mode is an easy workaround, but it
> is still a bit annoying.
>
> Regards,
> David
Re: Synchronize view not up to date [message #498257 is a reply to message #498194] Mon, 16 November 2009 08:55 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

Do you mean that 'src' folder is incoming addition(somebody added it) or
outgoing addition (you added it)? Please, provide detailed steps how to
reproduce the problem?
> Then I right click the project and this appears in the console:
Did you just righ-click the project without calling Update action and you
have update data in Console?

> Another case:
>
> In Incoming mode it shows for a folder (named "src) that it is new, but
> when I expand it by clicking in the plus sign, no children are shown to
> it. Switching between modes, refreshing, resynchronizing does not help.
>
> Then I right click the project and this appears in the console:
>
>
> *** Update
> svn update "F:\ws\pr1\src" -r HEAD --depth infinity --username "davbal"
> F:/ws/pr1/src/java/at
> F:/ws/pr1/src/java/com
> F:/ws/pr1/src/java
> A F:/ws/pr1/src/test
> A F:/ws/pr1/src/test/at
> A F:/ws/pr1/src/test/at/yuna
> A F:/ws/pr1/src/test/at/yuna/sequence
> A F:/ws/pr1/src/test/at/yuna/sequence/SequenceTest.java
> F:/ws/pr1/src
> F:/ws/pr1
> At revision 919
> *** Ok (took 00:01.969)
>
>
>
> Subversive is :
> Subversive SVN Team Provider (Incubation) 0.7.8.I20090904-1300
> org.eclipse.team.svn.feature.group
Re: Synchronize view not up to date [message #498262 is a reply to message #498257] Mon, 16 November 2009 09:07 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
> Do you mean that 'src' folder is incoming addition(somebody added it) or
> outgoing addition (you added it)? Please, provide detailed steps how to
> reproduce the problem?

It had incoming changes (somebody else commited them to the svn server).

I'm not sure. This happens non-deterministically. I don't know what exactly triggers it.

>> Then I right click the project and this appears in the console:
>Did you just righ-click the project without calling Update action and you
>have update data in Console?

I right clicked on the "src" item in the tree (not the project, as I wrote before,
sorry, that was a mistake from me) and clicked Update in the popoup menu.
After that the update was performed and the lines in the log appeared (the ones
I posted before).

Regards,
David

[Updated on: Mon, 16 November 2009 09:08]

Report message to a moderator

Re: Synchronize view not up to date [message #498487 is a reply to message #498262] Tue, 17 November 2009 08:40 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

Unfortunately, I can't reproduce the problem, but I can suppose that there
are some specific circumstance under which the problem happens.

>> Do you mean that 'src' folder is incoming addition(somebody added it) or
>> outgoing addition (you added it)? Please, provide detailed steps how to
>> reproduce the problem?
>
> It had incoming changes (somebody else commited them to the svn server).
>
> I'm not sure. This happens non-deterministically. I don't know what
> exactly triggers it.
>
>>> Then I right click the project and this appears in the console:
>>Did you just righ-click the project without calling Update action and you
>>have update data in Console?
>
> I right clicked on the "src" item in the tree (not the project, as I wrote
> before,
> sorry, that was a mistake from me) and clicked Update in the popoup menu.
> After that the update was performed and the lines in the log appeard (the
> ones
> I posted before).
>
> Regards,
> David
Re: Synchronize view not up to date [message #500534 is a reply to message #498487] Thu, 26 November 2009 14:38 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
Here is something that happens each time:
- start eclipse
- work a while
- go to Team Sync perspective
( - the Outgoing mode is already selected)
- click Synchronize (it is not populated on start)

Result:
- two projects appear as having local changes

But I know more of them have.
If I switch to Incoming mode and then back to Outgoing, then all projects with local changes are visible.


Another issue 1)
All project in Outgoing mode have a "<" character before their name, except one. What does it mean?
Most project icons have a small red left-right arrow on their icon (conflict?), some have nothing. (a few have a blue left arrow on their icon).
Are this signs and codes documented somewhere?

The one project without the "<" char has the blue arrow. It has no children when expanded. But if I right click it and select "Commit...", the dialog shown that I have two localy changed ("Deleted") files. Why aren't they visible in the Outgoing mode tree?

Another issue 2) Preferences
In the Synchronize view, clicking the small white triangle in the upper right corner gives a menu, where I click the Preferences... item.
- why aren't these preferences in the Eclipse main menu Windows / Preferences ?


Regards,
David
Re: Synchronize view not up to date [message #502007 is a reply to message #497084] Fri, 04 December 2009 17:54 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
Another case:

In Outgoing mode, if I commit a few files from a project, then the project disappears from the list of items, even if it has more outgoing changes.

Again, switching to some other mode and back fixes the display.


Also, I see recently that the Conflicts mode is always empty. Is that maybe due to some preferences or setting?

Regards,
David
Re: Synchronize view not up to date [message #502008 is a reply to message #497084] Fri, 04 December 2009 17:59 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 128
Registered: July 2009
Senior Member
It also happens like this:
- go to Team Sync perspective
- set Outgoing mode
- double-click a locally modified file
- type some chars into the local half of diff
- press ctrl-s to save
Result:
- the entire project disappears from the "Synchronize" view
Re: Synchronize view not up to date [message #502212 is a reply to message #497084] Mon, 07 December 2009 09:22 Go to previous message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

We know that there can be problems in Sync view with Outgoing mode,
unfortunately they're not always reproducible, but they happen on some
specific circumstances. I created bugs for Team component about it
(unfortunately from short inspection I didn't find them), because Sync view
isn't created by Subversive, it's a Team component and they manage modes.
I also saw that you created bugs on Bugzilla, we'll review them.
Thanks.

> Hi!
>
> I see this problem since years (from eclipse v3.3 IIRC).
> Now I use v3.5.1 with the latest subversive plugin.
>
> Symptom:
> - the view in Synchronize (for example Outgoing mode) is not displaying
> all items
> - going to other mode (Incoming) and back "fixes" it: now everything is
> displayed as it should
>
> Right now I did this:
> - start eclipse
> - work for a while (change a few versioned files)
> - go to Team Synchronizing perspective
> - click Populate (view was in Outgoing mode)
> Result:
> - one of the projects I worked on and had a few files changed is not
> displayed at all (other projects with changed files are)
> - I click on Incoming mode and again on Outgoing and now the missing
> project with files is there
>
>
> Is there an open bug on this?
>
> If you know the problem, then switching mode is an easy workaround, but it
> is still a bit annoying.
>
> Regards,
> David
Previous Topic:Uninstall Eclipse
Next Topic:"Compare with Previous State" extremely slow
Goto Forum:
  


Current Time: Thu Dec 18 02:31:11 GMT 2014

Powered by FUDForum. Page generated in 0.02790 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software