Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Unable to run mergeoo example
Unable to run mergeoo example [message #496986] Thu, 12 November 2009 06:06 Go to next message
Goetz Botterweck is currently offline Goetz Botterweck
Messages: 71
Registered: July 2009
Member
PROBLEM

When I run the mergeoo example I get the error message

Line: 5, Column: 4, Reason: mismatched input: 'with'
Line: 4, Column: 19, Reason: mismatched input 'Model' expecting NAME


WHAT I DID

- Eclipse 3.5, clean workspace

- Checked out all examples below
http://dev.eclipse.org/svnroot/modeling/org.eclipse.gmt.epsi lon/trunk/examples

- Registered all *.ecore in org.eclipse.epsilon.examples.metamodels
(right click + Register EPackages)

- In org.eclipse.epsilon.examples.mergeoo
- Right click on MergeOO.launch
- Run as -> MergeOO

- Result: Error message as pasted above


What am I missing? Any hints?

Thanks,
Goetz
Re: Unable to run mergeoo example [message #497017 is a reply to message #496986] Thu, 12 November 2009 09:30 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Goetz,

Many thanks for reporting this! I've tidied up the example and committed
the changes (it was broken as a result of changing the role of "" in
0.8.8 - see
http://www.eclipse.org/gmt/epsilon/doc/articles/eol-syntax-u pdates/ for
more details on this).

Cheers,
Dimitris

Goetz Botterweck wrote:
> PROBLEM
>
> When I run the mergeoo example I get the error message
>
> Line: 5, Column: 4, Reason: mismatched input: 'with'
> Line: 4, Column: 19, Reason: mismatched input 'Model' expecting NAME
>
>
> WHAT I DID
>
> - Eclipse 3.5, clean workspace
>
> - Checked out all examples below
> http://dev.eclipse.org/svnroot/modeling/org.eclipse.gmt.epsi lon/trunk/examples
>
> - Registered all *.ecore in org.eclipse.epsilon.examples.metamodels
> (right click + Register EPackages)
>
> - In org.eclipse.epsilon.examples.mergeoo
> - Right click on MergeOO.launch
> - Run as -> MergeOO
>
> - Result: Error message as pasted above
>
>
> What am I missing? Any hints?
>
> Thanks,
> Goetz
>
>


--
Spread the word: http://www.eclipse.org/gmt/epsilon/spreadtheword
Follow Epsilon on Twitter: http://twitter.com/epsilonews
Re: Unable to run mergeoo example [message #582714 is a reply to message #496986] Thu, 12 November 2009 09:30 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Goetz,

Many thanks for reporting this! I've tidied up the example and committed
the changes (it was broken as a result of changing the role of "" in
0.8.8 - see
http://www.eclipse.org/gmt/epsilon/doc/articles/eol-syntax-u pdates/ for
more details on this).

Cheers,
Dimitris

Goetz Botterweck wrote:
> PROBLEM
>
> When I run the mergeoo example I get the error message
>
> Line: 5, Column: 4, Reason: mismatched input: 'with'
> Line: 4, Column: 19, Reason: mismatched input 'Model' expecting NAME
>
>
> WHAT I DID
>
> - Eclipse 3.5, clean workspace
>
> - Checked out all examples below
> http://dev.eclipse.org/svnroot/modeling/org.eclipse.gmt.epsi lon/trunk/examples
>
> - Registered all *.ecore in org.eclipse.epsilon.examples.metamodels
> (right click + Register EPackages)
>
> - In org.eclipse.epsilon.examples.mergeoo
> - Right click on MergeOO.launch
> - Run as -> MergeOO
>
> - Result: Error message as pasted above
>
>
> What am I missing? Any hints?
>
> Thanks,
> Goetz
>
>


--
Spread the word: http://www.eclipse.org/gmt/epsilon/spreadtheword
Follow Epsilon on Twitter: http://twitter.com/epsilonews
Previous Topic:Unable to run mergeoo example
Next Topic:EAnnotation details
Goto Forum:
  


Current Time: Tue Oct 21 03:50:40 GMT 2014

Powered by FUDForum. Page generated in 0.05683 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software