Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » ATF » ATF plug-ins installation. Problems(To get a working workspace ready for ATF development)
icon5.gif  ATF plug-ins installation. Problems [message #495654] Thu, 05 November 2009 11:08 Go to next message
ruslanrf  is currently offline ruslanrf
Messages: 14
Registered: November 2009
Junior Member
I tried to install ATF project into eclipse IDE (Plig-in Development) 3.5 as it is written in http://wiki.eclipse.org/ATF/Workspace.

Unfortunatelly I have following problem in the parameters of Target Platform:
"Unable to locate installable unit org.eclipse.wst.web_ui.feature.feature.group" at the location http://download.eclipse.org/webtools/updates"

How to resolve this problem?
Re: ATF plug-ins installation. Problems [message #495807 is a reply to message #495654] Fri, 06 November 2009 03:53 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
hi,
do you want to install ATF and play with it, or learn how it's built?
The http://wiki.eclipse.org/ATF/Workspace is aimed at developers willing
to learn ATF internals (java code) and contribute to project. But I
guess, you'd be more interested to read
http://wiki.eclipse.org/ATF/Installing to learn how to install ATF in
Eclipse and try it out.

I've updated those wiki pages to better describe what's their task. Let
me know if this doesn't help you move on.

Jacek


ruslanrf wrote:
> I tried to install ATF project into eclipse IDE (Plig-in Development)
> 3.5 as it is written in http://wiki.eclipse.org/ATF/Workspace.
>
> Unfortunatelly I have following problem in the parameters of Target
> Platform:
> "Unable to locate installable unit
> org.eclipse.wst.web_ui.feature.feature.group" at the location
> http://download.eclipse.org/webtools/updates"
>
> How to resolve this problem?
Re: ATF plug-ins installation. Problems [message #495953 is a reply to message #495807] Fri, 06 November 2009 13:42 Go to previous messageGo to next message
ruslanrf  is currently offline ruslanrf
Messages: 14
Registered: November 2009
Junior Member
Thank you for your reply!
I am interested more in how it is build.
I have written some notes and problems during installing.

About installing ATF:
* There is nothing at http://downloads.zend.com/atf/
* In "bug 507575 " all links to the xulrunner plug-ins are wrong. Attachment there (xulrunner-updatesite-releng) is not clear for me. As I understand it is a part of your project org.eclipse.atf.mozilla.xulrunner.releng for creating XULRunner update site.
Because of that I just have chosen XulRunner 1.8.1.3 and have set this URL: http://releases.mozilla.org/pub/mozilla.org/xulrunner/releas es/1.8.1.3/contrib/eclipse/. It helped and works.

About setting up ATF workspace:
* A problem that there is no plug-in org.eclipse.wst.web_ui.feature.feature.group in http://download.eclipse.org/webtools/updates
* When I execute the ATF core I get following error:
...
!ENTRY org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE Bundle reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/plugins/org.eclipse.pde.core_3.5.100.v20090821.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.core 2 0 2009-11-06 18:38:35.561
!MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.1.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE Bundle reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/plugins/org.eclipse.pde.ui_3.5.0.v20090821.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ui 2 0 2009-11-06 18:38:35.561
!MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.0.0).
...

Do you know why I have this error message?

About building XULRunner update site:
* In build.properties the parameter XULRunnerVersion should be like XULRunnerVersion=1.9.1.X where X is a number from 2 to 4. Otherwise the script construct a wrong link.
*Is this ant-script only for Windows? (as I understand)
Re: ATF plug-ins installation. Problems [message #496031 is a reply to message #495953] Sat, 07 November 2009 06:41 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
hi Ruslanrf,
thanks for trying ATF.
my answers below.

ruslanrf wrote:
> Thank you for your reply!
> I am interested more in how it is build.
> I have written some notes and problems during installing.
>
> About http://wiki.eclipse.org/ATF/Installing:
> * There is nothing at http://downloads.zend.com/atf/

Are you trying with install dialog? That's in Eclipse, go to Help->
Install New Software... and then enter this URL in "Work with" field. I
just tried and noticed that Install dialog
clears the "Work with" field whenever I press enter, so the other way is
to press "Add" button and manually add the URL. Then select it from the
drop-down list.

> * In "https://bugzilla.mozilla.org/show_bug.cgi?id=507575" all links
> to the xulrunner plug-ins are wrong. Attachment there
> (https://bugzilla.mozilla.org/attachment.cgi?id=393199) is not clear
> for me. As I understand it is a part of your project
> org.eclipse.atf.mozilla.xulrunner.releng for creating XULRunner update
> site.
> Because of that I just have chosen XulRunner 1.8.1.3 and have set this
> URL:
> http://releases.mozilla.org/pub/mozilla.org/xulrunner/releas es/1.8.1.3/contrib/eclipse/.
> It helped and works.

bug https://bugzilla.mozilla.org/show_bug.cgi?id=507575 is work in
progress unfortunately. It describes progress with building XULRunner
update site on mozilla.org and outlines how to prepare XULRunner by
yourself.

XULRunner 1.8.1.3 might not work with ATF, because it's API is not
compatible with XULRunner 1.9


> About http://wiki.eclipse.org/ATF/Workspace:
> * A problem that there is no plug-in
> org.eclipse.wst.web_ui.feature.feature.group in
> http://download.eclipse.org/webtools/updates

you're right. Yesterday I hit that too and hopefully fixed it now. I
think that Webtools repository content might have changed (maybe their
features versions) which made the broke ATF target configuration. Could
you update org.eclipse.atf.releng project to get my changes from CVS?
Right click on that project and choose Team->Update
Eclipse should automatically pick-up the changes, but if not, open
Window->Preferences, go to Plug-in Development -> Target Platform and
make sure that "ATF Target Platform" is checked and press "Reload", then
"OK".

> * When I execute the ATF core I get following error:

This might be caused be one of above errors. You can fix the launch
configuration yourself. Go to main menu Run -> Run Configurations and
then locate "ATF core". In plugins tab press "Validate plug-ins". Are
there any errors? Pressing "Add Required Plug-ins" should resolve them.
Does pressing "Run" from there launches ATF now?

> ..
> !ENTRY org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE One or more bundles are not resolved because the following
> root constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE Bundle
> reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.core_3.5.100.v20090821.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.pde.core 2 0 2009-11-06 18:38:35.561
> !MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.1.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE Bundle
> reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.ui_3.5.0.v20090821.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.pde.ui 2 0 2009-11-06 18:38:35.561
> !MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.0.0).
> ..
> Do you know why I have this error message?
>
> About http://wiki.eclipse.org/ATF/XULRunner:
> * In build.properties the parameter XULRunnerVersion should be like
> XULRunnerVersion=1.9.1.X where X is a number from 2 to 4. Otherwise
> the script construct a wrong link.

that's true. Actually 1.9.1 build existed some time ago, but recently it
was removed from Mozilla server. Changing to 1.9.1.4 should work.

> *Is this ant-script only for Windows? (as I understand)

no, it should run on all platforms. It uses PDE Build, so it actually
requires Eclipse to run. Why does it look like Windows-only?
The script could also be rewritten to plain ANT, without PDE Build and
Eclipse dependency, because all it does is download a couple of Mozilla
zips, unzip, add MANIFEST.MF and zip into jars. I used PDE Build,
because it easily integrates with p2 to generate Eclipse p2 repository.
Re: ATF plug-ins installation. Problems [message #496666 is a reply to message #496031] Tue, 10 November 2009 15:43 Go to previous messageGo to next message
ruslanrf  is currently offline ruslanrf
Messages: 14
Registered: November 2009
Junior Member
Considering http://wiki.eclipse.org/ATF/Installing I just could not download via Eclipse Xulrunner and xpcom. But now it is works, I can download again. I don't know the reason.

With making the ATF Workspace everyting is also fine now. Thank you.

Deploying the XULRunner -- I didn't try.
Re: ATF plug-ins installation. Problems [message #561787 is a reply to message #495654] Fri, 06 November 2009 03:53 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
hi,
do you want to install ATF and play with it, or learn how it's built?
The http://wiki.eclipse.org/ATF/Workspace is aimed at developers willing
to learn ATF internals (java code) and contribute to project. But I
guess, you'd be more interested to read
http://wiki.eclipse.org/ATF/Installing to learn how to install ATF in
Eclipse and try it out.

I've updated those wiki pages to better describe what's their task. Let
me know if this doesn't help you move on.

Jacek


ruslanrf wrote:
> I tried to install ATF project into eclipse IDE (Plig-in Development)
> 3.5 as it is written in http://wiki.eclipse.org/ATF/Workspace
>
> Unfortunatelly I have following problem in the parameters of Target
> Platform:
> "Unable to locate installable unit
> org.eclipse.wst.web_ui.feature.feature.group" at the location
> http://download.eclipse.org/webtools/updates"
>
> How to resolve this problem?
Re: ATF plug-ins installation. Problems [message #561807 is a reply to message #495807] Fri, 06 November 2009 13:42 Go to previous messageGo to next message
ruslanrf  is currently offline ruslanrf
Messages: 14
Registered: November 2009
Junior Member
Thank you for your reply!
I am interested more in how it is build.
I have written some notes and problems during installing.

About http://wiki.eclipse.org/ATF/Installing:
* There is nothing at http://downloads.zend.com/atf/
* In "https://bugzilla.mozilla.org/show_bug.cgi?id=507575" all links to the xulrunner plug-ins are wrong. Attachment there (https://bugzilla.mozilla.org/attachment.cgi?id=393199) is not clear for me. As I understand it is a part of your project org.eclipse.atf.mozilla.xulrunner.releng for creating XULRunner update site.
Because of that I just have chosen XulRunner 1.8.1.3 and have set this URL: http://releases.mozilla.org/pub/mozilla.org/xulrunner/releas es/1.8.1.3/contrib/eclipse/ It helped and works.

About http://wiki.eclipse.org/ATF/Workspace:
* A problem that there is no plug-in org.eclipse.wst.web_ui.feature.feature.group in http://download.eclipse.org/webtools/updates
* When I execute the ATF core I get following error:
...
!ENTRY org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE Bundle reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.core_3.5.100.v20090821.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.core 2 0 2009-11-06 18:38:35.561
!MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.1.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
!MESSAGE Bundle reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.ui_3.5.0.v20090821.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ui 2 0 2009-11-06 18:38:35.561
!MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.0.0).
...
Do you know why I have this error message?

About http://wiki.eclipse.org/ATF/XULRunner:
* In build.properties the parameter XULRunnerVersion should be like XULRunnerVersion=1.9.1.X where X is a number from 2 to 4. Otherwise the script construct a wrong link.
*Is this ant-script only for Windows? (as I understand)
Re: ATF plug-ins installation. Problems [message #561910 is a reply to message #561807] Sat, 07 November 2009 06:41 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
hi Ruslanrf,
thanks for trying ATF.
my answers below.

ruslanrf wrote:
> Thank you for your reply!
> I am interested more in how it is build.
> I have written some notes and problems during installing.
>
> About http://wiki.eclipse.org/ATF/Installing:
> * There is nothing at http://downloads.zend.com/atf/

Are you trying with install dialog? That's in Eclipse, go to Help->
Install New Software... and then enter this URL in "Work with" field. I
just tried and noticed that Install dialog
clears the "Work with" field whenever I press enter, so the other way is
to press "Add" button and manually add the URL. Then select it from the
drop-down list.

> * In "https://bugzilla.mozilla.org/show_bug.cgi?id=507575" all links
> to the xulrunner plug-ins are wrong. Attachment there
> (https://bugzilla.mozilla.org/attachment.cgi?id=393199) is not clear
> for me. As I understand it is a part of your project
> org.eclipse.atf.mozilla.xulrunner.releng for creating XULRunner update
> site.
> Because of that I just have chosen XulRunner 1.8.1.3 and have set this
> URL:
> http://releases.mozilla.org/pub/mozilla.org/xulrunner/releas es/1.8.1.3/contrib/eclipse/
> It helped and works.

bug https://bugzilla.mozilla.org/show_bug.cgi?id=507575 is work in
progress unfortunately. It describes progress with building XULRunner
update site on mozilla.org and outlines how to prepare XULRunner by
yourself.

XULRunner 1.8.1.3 might not work with ATF, because it's API is not
compatible with XULRunner 1.9


> About http://wiki.eclipse.org/ATF/Workspace:
> * A problem that there is no plug-in
> org.eclipse.wst.web_ui.feature.feature.group in
> http://download.eclipse.org/webtools/updates

you're right. Yesterday I hit that too and hopefully fixed it now. I
think that Webtools repository content might have changed (maybe their
features versions) which made the broke ATF target configuration. Could
you update org.eclipse.atf.releng project to get my changes from CVS?
Right click on that project and choose Team->Update
Eclipse should automatically pick-up the changes, but if not, open
Window->Preferences, go to Plug-in Development -> Target Platform and
make sure that "ATF Target Platform" is checked and press "Reload", then
"OK".

> * When I execute the ATF core I get following error:

This might be caused be one of above errors. You can fix the launch
configuration yourself. Go to main menu Run -> Run Configurations and
then locate "ATF core". In plugins tab press "Validate plug-ins". Are
there any errors? Pressing "Add Required Plug-ins" should resolve them.
Does pressing "Run" from there launches ATF now?

> ..
> !ENTRY org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE One or more bundles are not resolved because the following
> root constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE Bundle
> reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.core_3.5.100.v20090821.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.pde.core 2 0 2009-11-06 18:38:35.561
> !MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.1.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-06 18:38:35.561
> !MESSAGE Bundle
> reference:file:/home/ruslan/programs/eclipse_3.5_rcp_test/pl ugins/org.eclipse.pde.ui_3.5.0.v20090821.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.pde.ui 2 0 2009-11-06 18:38:35.561
> !MESSAGE Missing required bundle org.eclipse.pde.build_[3.2.0,4.0.0).
> ..
> Do you know why I have this error message?
>
> About http://wiki.eclipse.org/ATF/XULRunner:
> * In build.properties the parameter XULRunnerVersion should be like
> XULRunnerVersion=1.9.1.X where X is a number from 2 to 4. Otherwise
> the script construct a wrong link.

that's true. Actually 1.9.1 build existed some time ago, but recently it
was removed from Mozilla server. Changing to 1.9.1.4 should work.

> *Is this ant-script only for Windows? (as I understand)

no, it should run on all platforms. It uses PDE Build, so it actually
requires Eclipse to run. Why does it look like Windows-only?
The script could also be rewritten to plain ANT, without PDE Build and
Eclipse dependency, because all it does is download a couple of Mozilla
zips, unzip, add MANIFEST.MF and zip into jars. I used PDE Build,
because it easily integrates with p2 to generate Eclipse p2 repository.
Re: ATF plug-ins installation. Problems [message #562030 is a reply to message #496031] Tue, 10 November 2009 15:43 Go to previous message
ruslanrf  is currently offline ruslanrf
Messages: 14
Registered: November 2009
Junior Member
Considering http://wiki.eclipse.org/ATF/Installing I just could not download via Eclipse Xulrunner and xpcom. But now it is works, I can download again. I don't know the reason.

With making the ATF Workspace everyting is also fine now. Thank you.

Deploying the XULRunner -- I didn't try.
Previous Topic:What mozilla version is used?
Next Topic:Get coordinates for text, letters in rendered web page
Goto Forum:
  


Current Time: Tue Jul 29 19:12:08 EDT 2014

Powered by FUDForum. Page generated in 0.06334 seconds