Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » WorkbenchTestable : No classLoader
WorkbenchTestable : No classLoader [message #494751] Mon, 02 November 2009 14:04 Go to next message
No real name is currently offline No real name
Messages: 1
Registered: November 2009
Junior Member
Hello,

I retrieve the SWTBot RCP Exemples from
http://dev.eclipse.org/svnroot/technology/org.eclipse.swtbot /trunk/examples/rcp

and i try to launch "myFirstTest" SWTBot test with eclipse

I get this message :

Exception in thread "WorkbenchTestable" java.lang.IllegalArgumentException: No Classloader found for plug-in org.rcpmail.test
	at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getClassLoader(RemotePluginTestRunner.java:79)
	at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getTestClassLoader(RemotePluginTestRunner.java:73)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClass(RemoteTestRunner.java:693)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClasses(RemoteTestRunner.java:429)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:452)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
	at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.main(RemotePluginTestRunner.java:64)
	at org.eclipse.swtbot.eclipse.core.UITestApplication.runTests(UITestApplication.java:117)
	at org.eclipse.ui.internal.testing.WorkbenchTestable$1.run(WorkbenchTestable.java:68)
	at java.lang.Thread.run(Unknown Source)


Is there a thing that I missed ?
Re: WorkbenchTestable : No classLoader [message #495710 is a reply to message #494751] Thu, 05 November 2009 19:47 Go to previous message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
It seems you may be running as a pde-junit launch. See the user guide
and the video for more. The video is linked on the user's guide page.

http://wiki.eclipse.org/SWTBot/UsersGuide

-- Ketan

letlilac@yahoo.fr wrote:
> Hello,
>
> I retrieve the SWTBot RCP Exemples from
> http://dev.eclipse.org/svnroot/technology/org.eclipse.swtbot /trunk/examples/rcp
>
>
> and i try to launch "myFirstTest" SWTBot test with eclipse
>
> I get this message :
>
>
> Exception in thread "WorkbenchTestable"
> java.lang.IllegalArgumentException: No Classloader found for plug-in
> org.rcpmail.test
> at
> org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getCl assLoader(RemotePluginTestRunner.java:79)
>
> at
> org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getTe stClassLoader(RemotePluginTestRunner.java:73)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lass(RemoteTestRunner.java:693)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lasses(RemoteTestRunner.java:429)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:452)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:683)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:390)
>
> at
> org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.main( RemotePluginTestRunner.java:64)
>
> at
> org.eclipse.swtbot.eclipse.core.UITestApplication.runTests(U ITestApplication.java:117)
>
> at
> org.eclipse.ui.internal.testing.WorkbenchTestable$1.run(Work benchTestable.java:68)
>
> at java.lang.Thread.run(Unknown Source)
>
>
> Is there a thing that I missed ?
>
Previous Topic:Testing and Eclipse RCP Application
Next Topic:Get the TreeItem after selecting the nested TreeItem
Goto Forum:
  


Current Time: Thu Oct 23 06:57:18 GMT 2014

Powered by FUDForum. Page generated in 0.07595 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software