Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Password problem with subversive
Password problem with subversive [message #493871] Wed, 28 October 2009 06:45 Go to next message
Dirk J. is currently offline Dirk J.
Messages: 1
Registered: July 2009
Junior Member
Hi,

we have a problem with Subversive (V0.7.8.I20090506-1500) in Eclipse (V3.4.2 / Ganymede) using Connector "Default SVNKit (SVN/1.5.5 SVNKit/1.2.2 ... r5428". (Same problem exists with older versions in Eclipse 3.2)

Authorization for our Subversion-repositories is realized by LDAP-Server. So I can use the same User/Password for multiple systems, which is basically a good idea. But I have to save my password in Subversive because otherwise it asks a hundred times when synchronizing the repository.

And that leads to the following problem: Subversive does not recognize when the password has expired! It obviously tries to connect multiple times with the "old" password. So the user gets locked out and the password must be reset. We have that situation multiple times a week in our team. There is no chance to see that the password has expired! I would have expected that Subversive asks for the new password when the first connection attempt failed ... !?

Does someone know this problem?
How can it be handled with Subversive?

Regards
Dirk
Re: Password problem with subversive [message #494106 is a reply to message #493871] Thu, 29 October 2009 04:57 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Dirk,

We need to deeper investigate this problem, so I created a corresponding bug
on tracker: https://bugs.eclipse.org/bugs/show_bug.cgi?id=293644, you can
add yourself to CC for this bug in order to track its activity or possibly
provide valuable comments.

> Hi,
>
> we have a problem with Subversive (V0.7.8.I20090506-1500) in Eclipse
> (V3.4.2 / Ganymede) using Connector "Default SVNKit (SVN/1.5.5
> SVNKit/1.2.2 ... r5428". (Same problem exists with older versions in
> Eclipse 3.2)
>
> Authorization for our Subversion-repositories is realized by LDAP-Server.
> So I can use the same User/Password for multiple systems, which is
> basically a good idea. But I have to save my password in Subversive
> because otherwise it asks a hundred times when synchronizing the
> repository.
>
> And that leads to the following problem: Subversive does not recognize
> when the password has expired! It obviously tries to connect multiple
> times with the "old" password. So the user gets locked out and the
> password must be reset. We have that situation multiple times a week in
> our team. There is no chance to see that the password has expired! I would
> have expected that Subversive asks for the new password when the first
> connection attempt failed ... !?
>
> Does someone know this problem?
> How can it be handled with Subversive?
>
> Regards
> Dirk
Re: Password problem with subversive [message #501824 is a reply to message #493871] Thu, 03 December 2009 18:18 Go to previous message
dmitriy  is currently offline dmitriy
Messages: 1
Registered: December 2009
Junior Member
Hi Dirk

I seems to have very similar problem.
Did you by any chance found any workarounds ?
Did you have a chance to try SubClipse ?

Thank you
Dmitriy
Previous Topic:SVN Drop down menu disabled
Next Topic:Uninstall Eclipse
Goto Forum:
  


Current Time: Fri Aug 22 17:57:16 EDT 2014

Powered by FUDForum. Page generated in 0.02346 seconds