Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Treeviewer losing expand/collapse boxes when jarred
Treeviewer losing expand/collapse boxes when jarred [message #485783] Mon, 14 September 2009 22:43 Go to next message
Allen D. McDonald is currently offline Allen D. McDonaldFriend
Messages: 13
Registered: July 2009
Junior Member
I have an app using a TreeViewer. It works fine and I can programatically
expand and collapse the tree to various levels but when I jarred it up it
loses the plus/minus boxes on the branch corners!
Has anybody seen this before? Got any suggestions?
I am using Galileo, SWT 3.5 and Java 1.6.0 on Windows XP.

Thanks!
Re: Treeviewer losing expand/collapse boxes when jarred [message #486154 is a reply to message #485783] Wed, 16 September 2009 14:34 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
Hi,

This definitely should not happen. My only guess is, in the jarred case are
you using swt's WPF port instead of its win32 port? If I remember
correctly, the Trees in WPF (and also on Vista in general) do not show their
expand/collapse icons until you hover over the Tree.

Grant


"Allen D. McDonald" <admcdonald1@verizon.net> wrote in message
news:7c48d1324501d6c053696f52ed86b125$1@www.eclipse.org...
> I have an app using a TreeViewer. It works fine and I can programatically
> expand and collapse the tree to various levels but when I jarred it up it
> loses the plus/minus boxes on the branch corners!
> Has anybody seen this before? Got any suggestions?
> I am using Galileo, SWT 3.5 and Java 1.6.0 on Windows XP.
>
> Thanks!
>
Re: Treeviewer losing expand/collapse boxes when jarred [message #486518 is a reply to message #486154] Thu, 17 September 2009 23:20 Go to previous messageGo to next message
Allen D. McDonald is currently offline Allen D. McDonaldFriend
Messages: 13
Registered: July 2009
Junior Member
Grant, thanks for the reply. I looked at swt.jar, and I am using win32.
Internally, it says it is version 3.5.5.
Unfortunally there are other funny things going on... My label provider
for the tree is supposed to put a specific image in front of the label
under certain conditions ( a red circle). Well it is doing it for all
labels and it is not the circle it is a square! I will poke around some
more, do some more logging and see if I can discover anything.
Thanks.
Re: Treeviewer losing expand/collapse boxes when jarred [message #486651 is a reply to message #486518] Fri, 18 September 2009 14:08 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
I assume that the swt jar's version is 3.5 (the latest release), not 3.5.5
(doesn't exist). If it's really 3.5.5 then perhaps you're not using swt
;-).

The red square probably indicates that the file with your image is not being
found.

Grant


"Allen D. McDonald" <admcdonald1@verizon.net> wrote in message
news:eb51477f17c7d2306782b7220620e9c1$1@www.eclipse.org...
> Grant, thanks for the reply. I looked at swt.jar, and I am using win32.
> Internally, it says it is version 3.5.5.
> Unfortunally there are other funny things going on... My label provider
> for the tree is supposed to put a specific image in front of the label
> under certain conditions ( a red circle). Well it is doing it for all
> labels and it is not the circle it is a square! I will poke around some
> more, do some more logging and see if I can discover anything.
> Thanks.
>
Previous Topic:Trees and Tables
Next Topic:StyledText Extension
Goto Forum:
  


Current Time: Sat Nov 29 02:33:52 GMT 2014

Powered by FUDForum. Page generated in 0.07798 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software