Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Mirror local archive site from command line?
Mirror local archive site from command line? [message #485014] Thu, 10 September 2009 09:12 Go to next message
Tom Dalton is currently offline Tom Dalton
Messages: 12
Registered: September 2009
Junior Member
Hello,

I posted some original questions (http://www.eclipse.org/forums/index.php?t=msg&th=153956) in the Newcomers forum, but I think my current questions belong here.

(Copied from other thread):

I have got the P2 director looking at a local site for fetaures, but I'm now running into a problem. If I point the remote site url at

file:/path/to/emf-site.zip


java -jar plugins/org.eclipse.equinox.launcher_<version>.jar
    -application org.eclipse.update.core.standaloneUpdate
    -command mirror
    -from file:/path/to/emf-site.zip
    -to .


Then it tries to open the file

/path/to/emf-site.zip/site.xml


So it doesn't seem to understand a zipped site. That's fine, but if I unzip the site manually and pass the p2 director:

file:/path/to/emf-site-extracted


Then it analyses the features ok, but when it comes to install them it bombs out with a file not found error. This seems to be caused by the plugins in the extracted site zip being .jar.pack.gz files, but the site.xml refers to the plugins as plain .jar files. Any ideas how to fix this?
Re: Mirror local archive site from command line? [message #485027 is a reply to message #485014] Thu, 10 September 2009 10:16 Go to previous messageGo to next message
Tom Dalton is currently offline Tom Dalton
Messages: 12
Registered: September 2009
Junior Member
Ok, so I tried to use the p2.director instead of standaloneUpdate to do the install, and while I get a little bit further, it still runs into the same problem:

java -jar plugins/org.eclipse.equinox.launcher_*.jar
   -application org.eclipse.equinox.p2.director 
   -repository /path/to/my/extracted/emf/site.xml 
   -installIU org.eclipse.emf.feature.group


Starts off ok with it saying it's installing the first feature, but then spams a mass of file not found errors that again seem to be because it's only looking for .jar files and not the actual .jar.pack.gz

I tried modifying the extracted site.xml to change the references in that from .jar.to .jar.pack.gz but then when i run the command line about it says it cannot find the features as all!

Help, this is driving me mad - is it a bug?!

[Updated on: Thu, 10 September 2009 10:20]

Report message to a moderator

Re: Mirror local archive site from command line? [message #485346 is a reply to message #485014] Fri, 11 September 2009 13:07 Go to previous message
Tom Dalton is currently offline Tom Dalton
Messages: 12
Registered: September 2009
Junior Member
RESOLVED : http://www.eclipse.org/forums/index.php?t=msg&th=154020
Previous Topic:CompareUI with Syntax Colouring
Next Topic:Capabilities and Key Bindings
Goto Forum:
  


Current Time: Thu Oct 23 08:46:56 GMT 2014

Powered by FUDForum. Page generated in 0.08067 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software