Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [XPAND] Xpand/Xtend Invoker builder slowdown
[XPAND] Xpand/Xtend Invoker builder slowdown [message #480475] Mon, 17 August 2009 06:00 Go to next message
ekkehard gentz is currently offline ekkehard gentz
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

This is a multi-part message in MIME format.
--------------020803000808090600030703
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

I noticed a slowdown of Xpand/Xtend Invoke Builder

starting up my modeling workspace no needs 30+ sec invoking the builder

eclipse 35
osx cocoa 64
mwe-xpand/xtend-xtext 0.7.2

emf + uml2 + uml2 profiles

any idea ?
should I open a bugzilla ?

(hopefully this topic will be only one time posted,
tried this morning 2 times using Community Forum)
--

ekke (ekkehard gentz)
independent software-architect
senior erp-consultant
eclipse | osgi | equinox | mdsd | oaw | emf | uml
max-josefs-platz 30, D-83022 rosenheim, germany
mailto:ekke@ekkes-corner.org
homepage (de): http://gentz-software.de
blog (en): http://ekkes-corner.org
twitter: @ekkescorner
skype: ekkes-corner
Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490


--------------020803000808090600030703
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
I noticed a slowdown of Xpand/Xtend Invoke Builder<br>
<br>
starting up my modeling workspace no needs 30+ sec invoking the builder<br>
<br>
eclipse 35<br>
osx cocoa 64<br>
mwe-xpand/xtend-xtext 0.7.2<br>
<br>
emf + uml2 + uml2 profiles<br>
<br>
any idea ?<br>
should I open a bugzilla ?<br>
<br>
(hopefully this topic will be only one time posted,<br>
tried this morning 2 times using Community Forum)<br>
<div class="moz-signature">-- <br>
<p style="margin-bottom: 0cm;"> <font ,="" color="#808080"
face="Verdana, sans-serif"> <font size="4">ekke (ekkehard gentz)<br>
</font> <font size="3"> independent software-architect<br>
senior erp-consultant<br>
</font> <font size="2">eclipse | osgi | equinox | mdsd | oaw | emf |
uml<br>
max-josefs-platz 30, D-83022 rosenheim, germany<br>
<a class="moz-txt-link-freetext" href="mailto:ekke@ekkes-corner.org">mailto:ekke@ekkes-corner.org</a><br>
homepage (de): <a class="moz-txt-link-freetext" href="http://gentz-software.de">http://gentz-software.de</a><br>
blog (en): <a class="moz-txt-link-freetext" href="http://ekkes-corner.org">http://ekkes-corner.org</a><br>
twitter: @ekkescorner<br>
skype: ekkes-corner<br>
</font> <font size="1"> Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID:
DE189929490<br>
</font> </font> </p>
</div>
</body>
</html>

--------------020803000808090600030703--


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: [XPAND] Xpand/Xtend Invoker builder slowdown [message #480476 is a reply to message #480475] Mon, 17 August 2009 06:05 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2807
Registered: July 2009
Senior Member
Hi Ekke,

actually we thought that we greatly improved the performance of the
project builder. Please file a ticket with a reproducable example.

Thanks,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 17.08.09 12:00, schrieb ekke:
> I noticed a slowdown of Xpand/Xtend Invoke Builder
>
> starting up my modeling workspace no needs 30+ sec invoking the builder
>
> eclipse 35
> osx cocoa 64
> mwe-xpand/xtend-xtext 0.7.2
>
> emf + uml2 + uml2 profiles
>
> any idea ?
> should I open a bugzilla ?
>
> (hopefully this topic will be only one time posted,
> tried this morning 2 times using Community Forum)
> --
>
> ekke (ekkehard gentz)
> independent software-architect
> senior erp-consultant
> eclipse | osgi | equinox | mdsd | oaw | emf | uml
> max-josefs-platz 30, D-83022 rosenheim, germany
> mailto:ekke@ekkes-corner.org
> homepage (de): http://gentz-software.de
> blog (en): http://ekkes-corner.org
> twitter: @ekkescorner
> skype: ekkes-corner
> Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490
>
Re: [XPAND] Xpand/Xtend Invoker builder slowdown [message #480493 is a reply to message #480476] Mon, 17 August 2009 07:57 Go to previous messageGo to next message
ekkehard gentz is currently offline ekkehard gentz
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

This is a multi-part message in MIME format.
--------------050105040809020509080002
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Sebastian Zarnekow schrieb:
> Hi Ekke,
>
> actually we thought that we greatly improved the performance of the
> project builder. Please file a ticket with a reproducable example.
>
> Thanks,
> Sebastian
....will not be easy, but of course I'll try to make it reproduceable

btw: it looks like this:
http://ekkescorner.files.wordpress.com/2009/08/xpand_xtend_i nvoker_slowdown.mov

--

ekke (ekkehard gentz)
independent software-architect
senior erp-consultant
eclipse | osgi | equinox | mdsd | oaw | emf | uml
max-josefs-platz 30, D-83022 rosenheim, germany
mailto:ekke@ekkes-corner.org
homepage (de): http://gentz-software.de
blog (en): http://ekkes-corner.org
twitter: @ekkescorner
skype: ekkes-corner
Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490


--------------050105040809020509080002
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Sebastian Zarnekow schrieb:
<blockquote cite="mid:h6ba1j$g18$1@build.eclipse.org" type="cite">Hi
Ekke,
<br>
<br>
actually we thought that we greatly improved the performance of the
project builder. Please file a ticket with a reproducable example.
<br>
<br>
Thanks,
<br>
Sebastian
<br>
</blockquote>
....will not be easy, but of course I'll try to make it reproduceable<br>
<br>
btw: it looks like this: <br>
<a class="moz-txt-link-freetext" href=" http://ekkescorner.files.wordpress.com/2009/08/xpand_xtend_i nvoker_slowdown.mov"> http://ekkescorner.files.wordpress.com/2009/08/xpand_xtend_i nvoker_slowdown.mov</a><br>
<br>
<div class="moz-signature">-- <br>
<p style="margin-bottom: 0cm;"> <font ,="" color="#808080"
face="Verdana, sans-serif"> <font size="4">ekke (ekkehard gentz)<br>
</font> <font size="3"> independent software-architect<br>
senior erp-consultant<br>
</font> <font size="2">eclipse | osgi | equinox | mdsd | oaw | emf |
uml<br>
max-josefs-platz 30, D-83022 rosenheim, germany<br>
<a class="moz-txt-link-freetext" href="mailto:ekke@ekkes-corner.org">mailto:ekke@ekkes-corner.org</a><br>
homepage (de): <a class="moz-txt-link-freetext" href="http://gentz-software.de">http://gentz-software.de</a><br>
blog (en): <a class="moz-txt-link-freetext" href="http://ekkes-corner.org">http://ekkes-corner.org</a><br>
twitter: @ekkescorner<br>
skype: ekkes-corner<br>
</font> <font size="1"> Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID:
DE189929490<br>
</font> </font> </p>
</div>
</body>
</html>

--------------050105040809020509080002--


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: [XPAND] Xpand/Xtend Invoker builder slowdown [message #480807 is a reply to message #480493] Tue, 18 August 2009 10:50 Go to previous message
ekkehard gentz is currently offline ekkehard gentz
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

This is a multi-part message in MIME format.
--------------090207060304090809020003
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

perhaps its an OSX-Cocoa-64bit problem
invoker slowdown happens on

Eclipse35 - cocoa-64

yesterday I switched to
Eclipse 3.6M1 - cocoa-64 bit
exact same workspace and installation
now instead of 30+ seconds only 5 seconds - thats ok for me

I'll watch the issue and report if it slows down again

ekke

ekke schrieb:
> Sebastian Zarnekow schrieb:
>> Hi Ekke,
>>
>> actually we thought that we greatly improved the performance of the
>> project builder. Please file a ticket with a reproducable example.
>>
>> Thanks,
>> Sebastian
> ...will not be easy, but of course I'll try to make it reproduceable
>
> btw: it looks like this:
> http://ekkescorner.files.wordpress.com/2009/08/xpand_xtend_i nvoker_slowdown.mov
>


--

ekke (ekkehard gentz)
independent software-architect
senior erp-consultant
eclipse | osgi | equinox | mdsd | oaw | emf | uml
max-josefs-platz 30, D-83022 rosenheim, germany
mailto:ekke@ekkes-corner.org
homepage (de): http://gentz-software.de
blog (en): http://ekkes-corner.org
twitter: @ekkescorner
skype: ekkes-corner
Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490


--------------090207060304090809020003
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
perhaps its an OSX-Cocoa-64bit problem<br>
invoker slowdown happens on <br>
<br>
Eclipse35 - cocoa-64<br>
<br>
yesterday I switched to<br>
Eclipse 3.6M1 - cocoa-64 bit<br>
exact same workspace and installation<br>
now instead of 30+ seconds only 5 seconds - thats ok for me<br>
<br>
I'll watch the issue and report


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Previous Topic:[MTL] How to reverse lists ?
Next Topic:[XPAND] analyzing Xpand/Xtend projects
Goto Forum:
  


Current Time: Sun Apr 20 19:36:54 EDT 2014

Powered by FUDForum. Page generated in 0.09089 seconds