Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Modeling (top-level project) » How to use ecore2xml?
How to use ecore2xml? [message #480474] Mon, 17 August 2009 09:58 Go to next message
Mark Hoffmann is currently offline Mark Hoffmann
Messages: 102
Registered: July 2009
Location: Jena
Senior Member
Hello,

I have created an ecore2xml mapping. Now I want to make it work. Is it
correct that ecore2xml only works with the resource type xml in my
genmodel? How can I tell my genmodel to use the ecore2xml mapping? Is it
even possible to give the genmodel the ecore2xml mapping?

Mark
Re: How to use ecore2xml? [message #480505 is a reply to message #480474] Mon, 17 August 2009 12:47 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn Hussey
Messages: 1618
Registered: July 2009
Senior Member
Mark,

This question is probably more appropriate for the EMF newsgroup (copied).

It's not really expected that Ecore2XML models be used as input to a
generator model... what were you looking to achieve? The original intent
of Ecore2XML models was to use them as input to a resource
implementation, to help drive the way resources are (de)serialized
to/from XML...

Kenn

Mark Hoffmann wrote:
> Hello,
>
> I have created an ecore2xml mapping. Now I want to make it work. Is it
> correct that ecore2xml only works with the resource type xml in my
> genmodel? How can I tell my genmodel to use the ecore2xml mapping? Is it
> even possible to give the genmodel the ecore2xml mapping?
>
> Mark
Re: How to use ecore2xml? [message #480507 is a reply to message #480474] Mon, 17 August 2009 12:50 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040108070608090607060904
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Mark,

It's best to use the EMF newsgroup to ask EMF questions. I've added it
to the "to" list of the reply.

This presentation has some information about how to use it:
< http://www.eclipse.org/modeling/emf/docs/presentations/Eclip seCon/EclipseCon2006_EMF_Advanced.pdf>


http://www.eclipse.org/modeling/emf/docs/presentations/Eclip seCon/EclipseCon2006_EMF_Advanced.pdf

You can't tell the GenModel to generated code to use it...


Mark Hoffmann wrote:
> Hello,
>
> I have created an ecore2xml mapping. Now I want to make it work. Is it
> correct that ecore2xml only works with the resource type xml in my
> genmodel? How can I tell my genmodel to use the ecore2xml mapping? Is it
> even possible to give the genmodel the ecore2xml mapping?
>
> Mark
>

--------------040108070608090607060904
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Mark,<br>
<br>
It's best to use the EMF newsgroup to ask EMF questions.
Re: How to use ecore2xml? [message #617775 is a reply to message #480474] Mon, 17 August 2009 12:47 Go to previous message
Kenn Hussey is currently offline Kenn Hussey
Messages: 1618
Registered: July 2009
Senior Member
Mark,

This question is probably more appropriate for the EMF newsgroup (copied).

It's not really expected that Ecore2XML models be used as input to a
generator model... what were you looking to achieve? The original intent
of Ecore2XML models was to use them as input to a resource
implementation, to help drive the way resources are (de)serialized
to/from XML...

Kenn

Mark Hoffmann wrote:
> Hello,
>
> I have created an ecore2xml mapping. Now I want to make it work. Is it
> correct that ecore2xml only works with the resource type xml in my
> genmodel? How can I tell my genmodel to use the ecore2xml mapping? Is it
> even possible to give the genmodel the ecore2xml mapping?
>
> Mark
Re: How to use ecore2xml? [message #617778 is a reply to message #480474] Mon, 17 August 2009 12:50 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040108070608090607060904
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Mark,

It's best to use the EMF newsgroup to ask EMF questions. I've added it
to the "to" list of the reply.

This presentation has some information about how to use it:
< http://www.eclipse.org/modeling/emf/docs/presentations/Eclip seCon/EclipseCon2006_EMF_Advanced.pdf>


http://www.eclipse.org/modeling/emf/docs/presentations/Eclip seCon/EclipseCon2006_EMF_Advanced.pdf

You can't tell the GenModel to generated code to use it...


Mark Hoffmann wrote:
> Hello,
>
> I have created an ecore2xml mapping. Now I want to make it work. Is it
> correct that ecore2xml only works with the resource type xml in my
> genmodel? How can I tell my genmodel to use the ecore2xml mapping? Is it
> even possible to give the genmodel the ecore2xml mapping?
>
> Mark
>

--------------040108070608090607060904
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Mark,<br>
<br>
It's best to use the EMF newsgroup to ask EMF questions.
Previous Topic:How to use ecore2xml?
Next Topic:[Announce] Eclipse Modeling Days
Goto Forum:
  


Current Time: Tue Sep 02 23:54:44 GMT 2014

Powered by FUDForum. Page generated in 0.01652 seconds