Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » [galileo] "Unsatisfied version constraint" error
[galileo] "Unsatisfied version constraint" error [message #480214] Fri, 14 August 2009 12:07 Go to next message
Daniel Rampanelli is currently offline Daniel Rampanelli
Messages: 8
Registered: July 2009
Junior Member
Hi to all,

I'm working on a RCP application and until now I was using Eclipse
Ganymede (3.4). Since I wanted to take advantage of the new features
provided by Galileo, I installed it but things are not so nice as I had
expected. I'm getting a lot of "unsatisfied version constraint" errors. I
have discovered that I can get rid of those errors by converting the
"Require-Bundle" dependencies into "Import-Package" statements. But even
after this change, I have REALLY strange errors (e.g. build path errors
for SWT classes only on a single class o_O).

Has somebody any clue what is going on here?

Best regards,
Daniel
Re: [galileo] "Unsatisfied version constraint" error [message #480231 is a reply to message #480214] Fri, 14 August 2009 13:25 Go to previous messageGo to next message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

If I remember correctly, "unsatisfied version constraint" usually means
that you are trying to run code generated for a higher level of Java
then what you are running on.

Daniel Rampanelli wrote:
> Hi to all,
>
> I'm working on a RCP application and until now I was using Eclipse
> Ganymede (3.4). Since I wanted to take advantage of the new features
> provided by Galileo, I installed it but things are not so nice as I had
> expected. I'm getting a lot of "unsatisfied version constraint" errors.
> I have discovered that I can get rid of those errors by converting the
> "Require-Bundle" dependencies into "Import-Package" statements. But even
> after this change, I have REALLY strange errors (e.g. build path errors
> for SWT classes only on a single class o_O).
>
> Has somebody any clue what is going on here?
>
> Best regards,
> Daniel
>

--
Thanks,
Rich Kulp
Re: [galileo] "Unsatisfied version constraint" error [message #480479 is a reply to message #480231] Mon, 17 August 2009 10:26 Go to previous messageGo to next message
Daniel Rampanelli is currently offline Daniel Rampanelli
Messages: 8
Registered: July 2009
Junior Member
Well, I think the problem is not the Java version, because the
configuration is the same as before. I'm using Java 1.5 on Mac OS X.

It is really strange, I have no clue what could cause the problem.

Maybe the projects created under Ganymede have strange settings that are
not compatible with Galielo?

Thanks,
Daniel
Re: [galileo] "Unsatisfied version constraint" error [message #480597 is a reply to message #480231] Mon, 17 August 2009 19:19 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2307
Registered: July 2009
Senior Member
Rich Kulp wrote:
> Daniel Rampanelli wrote:
>> I'm working on a RCP application and until now I was using Eclipse
>> Ganymede (3.4). Since I wanted to take advantage of the new features
>> provided by Galileo, I installed it but things are not so nice as I
>> had expected. I'm getting a lot of "unsatisfied version constraint"
>> errors. I have discovered that I can get rid of those errors by
>> converting the "Require-Bundle" dependencies into "Import-Package"
>> statements. But even after this change, I have REALLY strange errors
>> (e.g. build path errors for SWT classes only on a single class o_O).
>>
>> Has somebody any clue what is going on here?
> If I remember correctly, "unsatisfied version constraint" usually
means
> that you are trying to run code generated for a higher level of Java
> then what you are running on.

Actually, it's not reporting a problem with the version of the
bytecodes in the classes, it's literally saying that your manifest's
Require-Bundle versions ranges aren't satisfied any more. This can
happen if you had a tight upper bound specified and Galileo's
version numbers increased beyond what was specified.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:How to create code to be called when a project is loaded?
Next Topic:[CVS] creating a branch from an od tag
Goto Forum:
  


Current Time: Mon Oct 20 09:50:43 GMT 2014

Powered by FUDForum. Page generated in 0.01804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software