Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » comparing 0.95 with 1.0
comparing 0.95 with 1.0 [message #479944] Thu, 13 August 2009 04:24 Go to next message
Vlad Dumitrescu is currently offline Vlad Dumitrescu
Messages: 318
Registered: July 2009
Location: Gothenburg
Senior Member
Hi!

I am considering porting our Erlang IDE (http://erlide.org) on DLTK, but
am stuck on Eclipse 3.4, which means DLTK 0.95.

I couldn't find an executive summary of things that are changed in 1.0,
is there any?

The big thing I notice is the use of EMF, which probably has a bunch of
new stuff in the 3.5 release.

Will there be any maintenance on 0.95? I suppose not, but it doesn't
hurt to ask.

best regards,
Vlad
Re: comparing 0.95 with 1.0 [message #479962 is a reply to message #479944] Thu, 13 August 2009 05:38 Go to previous messageGo to next message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Hi Vlad,

DLTK 1.0 is compatible with Eclipse 3.4 (you should use appropriate
version of EMF as well).

There is no maintenance planned for 0.95, since most problems could not
be solved without changing API. And API changes require to increment
version number.

Regards,
Alex

Vlad Dumitrescu wrote:
> Hi!
>
> I am considering porting our Erlang IDE (http://erlide.org) on DLTK, but
> am stuck on Eclipse 3.4, which means DLTK 0.95.
>
> I couldn't find an executive summary of things that are changed in 1.0,
> is there any?
>
> The big thing I notice is the use of EMF, which probably has a bunch of
> new stuff in the 3.5 release.
>
> Will there be any maintenance on 0.95? I suppose not, but it doesn't
> hurt to ask.
>
> best regards,
> Vlad
Re: comparing 0.95 with 1.0 [message #479991 is a reply to message #479962] Thu, 13 August 2009 07:31 Go to previous messageGo to next message
Vlad Dumitrescu is currently offline Vlad Dumitrescu
Messages: 318
Registered: July 2009
Location: Gothenburg
Senior Member
Alex Panchenko wrote:
> DLTK 1.0 is compatible with Eclipse 3.4 (you should use appropriate
> version of EMF as well).

Is it? That's great, I suppose I got the wrong EMF version somehow. I
will try again.

Thanks for the answer!
/Vlad
Re: comparing 0.95 with 1.0 [message #484305 is a reply to message #479962] Sat, 05 September 2009 18:46 Go to previous messageGo to next message
Gergely Nagy is currently offline Gergely Nagy
Messages: 17
Registered: July 2009
Junior Member
Alex Panchenko wrote:
> DLTK 1.0 is compatible with Eclipse 3.4 (you should use appropriate
> version of EMF as well).

Hmm, would I be foolish to ask: is it compatible with 3.3 as well?
Thanks,
Gergo
Re: comparing 0.95 with 1.0 [message #484342 is a reply to message #484305] Sun, 06 September 2009 23:38 Go to previous message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Gergely Nagy wrote:
> Alex Panchenko wrote:
>> DLTK 1.0 is compatible with Eclipse 3.4 (you should use appropriate
>> version of EMF as well).
>
> Hmm, would I be foolish to ask: is it compatible with 3.3 as well? Thanks,
> Gergo

DLTK Core, Javascript and Ruby should are believed to be compatible with
3.3.

DLTK Tcl is compatible with 3.4+.

Regards,
Alex
Previous Topic:generating an IDE
Next Topic:TCL Open Method
Goto Forum:
  


Current Time: Mon Jul 28 10:24:02 EDT 2014

Powered by FUDForum. Page generated in 0.01902 seconds