Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Using the same Eclipse application on Linux/Windows/Mac... (was "Headless build on Windows usin
Using the same Eclipse application on Linux/Windows/Mac... (was "Headless build on Windows usin [message #478716] Thu, 06 August 2009 14:04 Go to next message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
Hello,

I have seen and used several Galileo-based RCP applications, built using DeltaPack, which are packaged with launchers for several platforms (Linux, win, osx), and I can successfully use their application in command line using "java -jar org.eclipse.equinox.launcher_*.jar -application [app]" .
For a RCP build purpose, I would like to have a single Galileo base with DeltaPack that I could use to call org.eclipse.ant.core.antRunner application on any platform. This is the same thing as what I am able to do with my previous RCP examples. However, I always get a NoClassDefFound (org/eclipse/swt/SWTError while loading AbstractUIPlugin) when trying to call this antRunner on any system except Linux. As far as I remember, the same trick was working with Ganymede.

How can I get the expected behaviour of a multi-platform Eclipse to invoke antRunner? I imagine it is related to p2 and/or target platform definition, but I may be totally wrong ;)

Thanks in advance
Mickael
Re: Using the same Eclipse application on Linux/Windows/Mac... (was "Headless build on Windows [message #479346 is a reply to message #478716] Mon, 10 August 2009 17:56 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Hi,

I would think if the org.eclipse.swt.* fragments for the system you care about are available then:

java -jar org.eclipse.equinox.launcher_1.0.300.v20090720.jar -application org.eclipse.ant.core.antRunner ... would be enough.

You might try passing in -os win32 -ws win32 -arch x86 (for example) to see if that forces it to pick the correct fragments.

if that doesn't work, it might be as you surmised that the correct info needs to be in the bundles.info/p2 profile. You might have to ask in the Equinox or p2 forum (eclipse.technology.equinox, I'm not sure about p2).

PW


Previous Topic:plug-in jar remains same during uninstall and reinstall
Next Topic:Highlight code in CompareEditor
Goto Forum:
  


Current Time: Sat Oct 25 16:58:34 GMT 2014

Powered by FUDForum. Page generated in 0.01789 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software