Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Eclipse Language Pack for Eclipse Standalone Helpsystem
Eclipse Language Pack for Eclipse Standalone Helpsystem [message #473898] Thu, 05 June 2008 15:24 Go to next message
Marcus is currently offline MarcusFriend
Messages: 16
Registered: July 2009
Junior Member
Hello everyone,

currently we are going to internationalize our standalone Helpsystem.
Therefore we wanted to know, if anyone has already experiences with
current Language Packs.

We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
Those packages worked well, but unfortunately there are two translation
bugs. If there isn't yet a fix for it, I might gonna write a bugreport.

1)“Search” -bar is always known as “Search”.
2)In “Search-Scope” the 2nd radio button (“search only the following
topics”) is not translated either

We found both in properties file, but still they ain't translated. Is
there already a newer version, or any possibility to translate them on our
own?

Thanks in advance,
Marcus
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #473901 is a reply to message #473898] Sun, 08 June 2008 21:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi Marcus,

I haven't worked with the language packs from Babel (yet). So, at this
point, I can only offer some pointers where you can look for more info
on how you can get translated strings for these two items.

Hopefully someone on the Eclipse UA team will weigh in if anything I
state is incorrect.

First, I wouldn't think the org.eclipse.help.base.nl has the strings for
the standalone help system. I would think that the strings for the
standalone help system UI are going to be in the
org.eclipse.help.webapp.nl* plug-in, in the nl1.jar of that plugin.

And I believe that those two areas of the standalone help system (Search
bar and Search Scope) have not changed much between 3.2.1 and now. So
maybe you can get the right properties file from the 3.2.1 language pack
and get the strings that you need and replace them in the appropriate
properties file for the Eclipse version that you're using.

So, look for the org.eclipse.help.webapp.nl* plug-in, and in the nl1.jar
of that plugin.

In the 3.2.1 language pack for the Platform SDK, I see the plug-in is:
org.eclipse.help.webapp.nl1_3.2.1.v200609270227

If I look into the nl1.jar file that's in that plug-in, I see the set of
WebappResources_*.properties files. Inside those files, I see translated
strings. I would think that maybe you could copy the relevant lines that
you need into the WebappResources*.properties files for your Eclipse
version.

Hope this helps in at least some small way to get past this obstacle!
--Lee Anne


Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #473903 is a reply to message #473898] Mon, 09 June 2008 14:48 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi again,

OK, this morning, I used my 3.3 Platform SDK and the Updater to get the
Babel Europa plug-ins for French (fr), Brazilian Portugeuse (pt_BR),
Spanish (es), and Simplified Chinese.

I started up an infocenter from the installation and looked at the
French, and confirmed that the "Search:" label reads "Search" while the
button is "ALLER". And the second radio button in Search Scope is not
translated.

When I compare the WebappResources_fr.properties file from the 3.2.1 NL
pack with the WebappResources_fr.properties file in the Babel Europa
plug-in for fr, the following lines are missing from the Babel Europa file:
Search=Rec&hercher
selectWorkingSet=Rechercher uni&quement dans les rubriques suivantes

I suspect that those are the ones for those two untranslated pieces. You
could try to copy those two lines from the 3.2.1 NL
WebappResources_*.properties files into the corresponding ones for your
version and see if they fix the problem.

Best regards,
Lee Anne

Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #473906 is a reply to message #473898] Tue, 10 June 2008 15:46 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi Marcus,

Two things FYI:
- There is now a newsgroup for questions related to translations from
Eclipse Babel: eclipse.technology.babel.

- I posted the results of my investigation there and someone has opened
a Bugzilla bug related to why the 3.2.1 NL strings didn't get carried
into the Babel packages for the related lines:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=236454

You can add yourself on cc to that bug.

Hope this helps,
Lee Anne

Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #474090 is a reply to message #473903] Mon, 23 June 2008 13:52 Go to previous messageGo to next message
Marcus is currently offline MarcusFriend
Messages: 16
Registered: July 2009
Junior Member
We have been able to fix this with your detailed explanations. Your
solutions are working perfectly fine.

Thank you very much for your time!
Marcus
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #475231 is a reply to message #473901] Tue, 10 March 2009 13:51 Go to previous messageGo to next message
Gerardo Laster is currently offline Gerardo LasterFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Lee Ann,
I am looking for the file org.eclipse.help.webapp.nl1* at
http://archive.eclipse.org/eclipse/downloads/drops/L-3.2_Lan guage_Packs-200607121700/index.php
or inside the packaged files there and I can't find it.
Could you please point me out to the location?

Also, in a related note. We are testing modifying org.eclipse.help.webapp
and adding the WebappResources_xx.properties to it. So far, we haven't had
any problems. Do you know of any ill effects of doing it instead of going
with separate org.eclipse.help.webapp.nl files?

Thanks,
Gerardo
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #475238 is a reply to message #475231] Tue, 10 March 2009 18:50 Go to previous messageGo to next message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
Hi Gerardo,

Which package did you download from that URL below?

(FYI: Those packages are for use with Eclipse 3.2.x. If you're using a
more recent version of Eclipse, you'd want to get the NL jars for that
Eclipse version.)

That URL has timestamp info = 200607121700 in the URL path.

I found a different URL that has what looks like a more recent timestamp:
http://archive.eclipse.org/eclipse/downloads/drops/L-3.2.1_L anguage_Packs-200609210945/index.php

What I did to make sure I got a package with most everything, I
downloaded the "Platform SDK Language Packs". I just now downloaded the
one with name:
"NLpack1-eclipse-platform-SDK-3.2.1-win32.zip"

Inside that zip file, going into eclipse/platform/ directory, I see the
following directory:
org.eclipse.help.webapp.nl1_3.2.1.v200609270227

That directory is the org.eclipse.help.webapp.nl1* plug-in that I
referred to in my previous posting.

Inside that folder, are the following items:
META-INF directory
plugin_*.properties files (where * = locales)
nl_fragment.properties file
nl1.jar file
about.html

---------------------
If you are using a more recent version of Eclipse and want the matching
NL plug-in for org.eclipse.help.webapp, you can get those by starting
this URL:
http://build.eclipse.org/technology/babel/test-updates/

Choose the Eclipse version link (for example, europa or ganymede), and
then the 'plugins' link. Do a Find for 'org.eclipse.help.webapp', and
you'll see the jar files that are the NL plug-ins for each language (for
example org.eclipse.help.webapp.nl_fr_3.3.0.v20090310043402.jar in the
Europa version).

Something is weird with the 'galileo' directory at that URL. But if you
want Europa nl plug-ins, those seem to be there.
----------------------

About your other question, I don't know of any specific ill effects of
adding the WebappResources_xx.properties directly to the plug-in.

I know that most teams try to get the plug-in jar from Eclipse and not
have to make changes inside the jars because it makes their process of
adopting Eclipse simpler. That is, so when they move to a new version of
Eclipse, or use the Eclipse update to update their installation, then
they don't have to go back inside the jars. That's the only "cost" that
I can think of.

That said though, you might want to repost your question about
WebappResources_xx.properties specifically as a new thread. Someone else
might know of something that I don't. :-)

Hope that helps!
Lee Anne


Gerardo Laster wrote:
> Hi Lee Ann,
> I am looking for the file org.eclipse.help.webapp.nl1* at
> http://archive.eclipse.org/eclipse/downloads/drops/L-3.2_Lan guage_Packs-200607121700/index.php
> or inside the packaged files there and I can't find it.
> Could you please point me out to the location?
> Also, in a related note. We are testing modifying
> org.eclipse.help.webapp and adding the WebappResources_xx.properties to
> it. So far, we haven't had any problems. Do you know of any ill effects
> of doing it instead of going with separate org.eclipse.help.webapp.nl
> files?
>
> Thanks,
> Gerardo
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #475240 is a reply to message #475238] Tue, 10 March 2009 18:59 Go to previous message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
> Something is weird with the 'galileo' directory at that URL. But if you
> want Europa nl plug-ins, those seem to be there.
> ----------------------

Oh, I just realized that Galileo is Eclipse 3.5 which is in development,
so I shouldn't expect it to be perfect at that URL. :-)

(sorry, got the two "G" moons confused!)
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #614415 is a reply to message #473898] Sun, 08 June 2008 21:25 Go to previous message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi Marcus,

I haven't worked with the language packs from Babel (yet). So, at this
point, I can only offer some pointers where you can look for more info
on how you can get translated strings for these two items.

Hopefully someone on the Eclipse UA team will weigh in if anything I
state is incorrect.

First, I wouldn't think the org.eclipse.help.base.nl has the strings for
the standalone help system. I would think that the strings for the
standalone help system UI are going to be in the
org.eclipse.help.webapp.nl* plug-in, in the nl1.jar of that plugin.

And I believe that those two areas of the standalone help system (Search
bar and Search Scope) have not changed much between 3.2.1 and now. So
maybe you can get the right properties file from the 3.2.1 language pack
and get the strings that you need and replace them in the appropriate
properties file for the Eclipse version that you're using.

So, look for the org.eclipse.help.webapp.nl* plug-in, and in the nl1.jar
of that plugin.

In the 3.2.1 language pack for the Platform SDK, I see the plug-in is:
org.eclipse.help.webapp.nl1_3.2.1.v200609270227

If I look into the nl1.jar file that's in that plug-in, I see the set of
WebappResources_*.properties files. Inside those files, I see translated
strings. I would think that maybe you could copy the relevant lines that
you need into the WebappResources*.properties files for your Eclipse
version.

Hope this helps in at least some small way to get past this obstacle!
--Lee Anne


Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #614419 is a reply to message #473898] Mon, 09 June 2008 14:48 Go to previous message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi again,

OK, this morning, I used my 3.3 Platform SDK and the Updater to get the
Babel Europa plug-ins for French (fr), Brazilian Portugeuse (pt_BR),
Spanish (es), and Simplified Chinese.

I started up an infocenter from the installation and looked at the
French, and confirmed that the "Search:" label reads "Search" while the
button is "ALLER". And the second radio button in Search Scope is not
translated.

When I compare the WebappResources_fr.properties file from the 3.2.1 NL
pack with the WebappResources_fr.properties file in the Babel Europa
plug-in for fr, the following lines are missing from the Babel Europa file:
Search=Rec&hercher
selectWorkingSet=Rechercher uni&quement dans les rubriques suivantes

I suspect that those are the ones for those two untranslated pieces. You
could try to copy those two lines from the 3.2.1 NL
WebappResources_*.properties files into the corresponding ones for your
version and see if they fix the problem.

Best regards,
Lee Anne

Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #614425 is a reply to message #473898] Tue, 10 June 2008 15:46 Go to previous message
Eclipse UserFriend
Originally posted by: nospam_kowalskilee.gmail.com

Hi Marcus,

Two things FYI:
- There is now a newsgroup for questions related to translations from
Eclipse Babel: eclipse.technology.babel.

- I posted the results of my investigation there and someone has opened
a Bugzilla bug related to why the 3.2.1 NL strings didn't get carried
into the Babel packages for the related lines:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=236454

You can add yourself on cc to that bug.

Hope this helps,
Lee Anne

Marcus Storre wrote:
> Hello everyone,
>
> currently we are going to internationalize our standalone Helpsystem.
> Therefore we wanted to know, if anyone has already experiences with
> current Language Packs.
> We tried org.eclipse.help.base.nl_de_0.2.0.v20080525043401.jar and fr.
> Those packages worked well, but unfortunately there are two translation
> bugs. If there isn't yet a fix for it, I might gonna write a bugreport.
> 1)�Search� -bar is always known as �Search�.
> 2)In �Search-Scope� the 2nd radio button (�search only the following
> topics�) is not translated either
> We found both in properties file, but still they ain't translated. Is
> there already a newer version, or any possibility to translate them on
> our own?
>
> Thanks in advance,
> Marcus
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #617648 is a reply to message #473903] Mon, 23 June 2008 13:52 Go to previous message
Marcus is currently offline MarcusFriend
Messages: 16
Registered: July 2009
Junior Member
We have been able to fix this with your detailed explanations. Your
solutions are working perfectly fine.

Thank you very much for your time!
Marcus
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #623240 is a reply to message #473901] Tue, 10 March 2009 13:51 Go to previous message
Gerardo Laster is currently offline Gerardo LasterFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Lee Ann,
I am looking for the file org.eclipse.help.webapp.nl1* at
http://archive.eclipse.org/eclipse/downloads/drops/L-3.2_Lan guage_Packs-200607121700/index.php
or inside the packaged files there and I can't find it.
Could you please point me out to the location?

Also, in a related note. We are testing modifying org.eclipse.help.webapp
and adding the WebappResources_xx.properties to it. So far, we haven't had
any problems. Do you know of any ill effects of doing it instead of going
with separate org.eclipse.help.webapp.nl files?

Thanks,
Gerardo
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #623244 is a reply to message #475231] Tue, 10 March 2009 18:50 Go to previous message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
Hi Gerardo,

Which package did you download from that URL below?

(FYI: Those packages are for use with Eclipse 3.2.x. If you're using a
more recent version of Eclipse, you'd want to get the NL jars for that
Eclipse version.)

That URL has timestamp info = 200607121700 in the URL path.

I found a different URL that has what looks like a more recent timestamp:
http://archive.eclipse.org/eclipse/downloads/drops/L-3.2.1_L anguage_Packs-200609210945/index.php

What I did to make sure I got a package with most everything, I
downloaded the "Platform SDK Language Packs". I just now downloaded the
one with name:
"NLpack1-eclipse-platform-SDK-3.2.1-win32.zip"

Inside that zip file, going into eclipse/platform/ directory, I see the
following directory:
org.eclipse.help.webapp.nl1_3.2.1.v200609270227

That directory is the org.eclipse.help.webapp.nl1* plug-in that I
referred to in my previous posting.

Inside that folder, are the following items:
META-INF directory
plugin_*.properties files (where * = locales)
nl_fragment.properties file
nl1.jar file
about.html

---------------------
If you are using a more recent version of Eclipse and want the matching
NL plug-in for org.eclipse.help.webapp, you can get those by starting
this URL:
http://build.eclipse.org/technology/babel/test-updates/

Choose the Eclipse version link (for example, europa or ganymede), and
then the 'plugins' link. Do a Find for 'org.eclipse.help.webapp', and
you'll see the jar files that are the NL plug-ins for each language (for
example org.eclipse.help.webapp.nl_fr_3.3.0.v20090310043402.jar in the
Europa version).

Something is weird with the 'galileo' directory at that URL. But if you
want Europa nl plug-ins, those seem to be there.
----------------------

About your other question, I don't know of any specific ill effects of
adding the WebappResources_xx.properties directly to the plug-in.

I know that most teams try to get the plug-in jar from Eclipse and not
have to make changes inside the jars because it makes their process of
adopting Eclipse simpler. That is, so when they move to a new version of
Eclipse, or use the Eclipse update to update their installation, then
they don't have to go back inside the jars. That's the only "cost" that
I can think of.

That said though, you might want to repost your question about
WebappResources_xx.properties specifically as a new thread. Someone else
might know of something that I don't. :-)

Hope that helps!
Lee Anne


Gerardo Laster wrote:
> Hi Lee Ann,
> I am looking for the file org.eclipse.help.webapp.nl1* at
> http://archive.eclipse.org/eclipse/downloads/drops/L-3.2_Lan guage_Packs-200607121700/index.php
> or inside the packaged files there and I can't find it.
> Could you please point me out to the location?
> Also, in a related note. We are testing modifying
> org.eclipse.help.webapp and adding the WebappResources_xx.properties to
> it. So far, we haven't had any problems. Do you know of any ill effects
> of doing it instead of going with separate org.eclipse.help.webapp.nl
> files?
>
> Thanks,
> Gerardo
>
Re: Eclipse Language Pack for Eclipse Standalone Helpsystem [message #623245 is a reply to message #475238] Tue, 10 March 2009 18:59 Go to previous message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
> Something is weird with the 'galileo' directory at that URL. But if you
> want Europa nl plug-ins, those seem to be there.
> ----------------------

Oh, I just realized that Galileo is Eclipse 3.5 which is in development,
so I shouldn't expect it to be perfect at that URL. :-)

(sorry, got the two "G" moons confused!)
Previous Topic:Huge memory consumption of Eclipse Infocenter
Next Topic:Add link to RCP Help in Windows Start menu
Goto Forum:
  


Current Time: Wed Nov 26 03:23:44 GMT 2014

Powered by FUDForum. Page generated in 0.06072 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software