Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » SVN Install fails - dependencies
SVN Install fails - dependencies [message #47927] Sat, 27 June 2009 22:09 Go to next message
John Moore is currently offline John Moore
Messages: 3
Registered: July 2009
Junior Member
(Warning Eclipse newbie, be kind to the ignorant)

I have Ganymede 3.4.1

Mac OSX 10.5.7 (with latest Java version update)

(Ganymede was installed as part of the latest PDT package (PHP))

I would like to install SVN

I reviewed the install instructions at:

http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/install.php

and end up at:

http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject

It seems to indicate under "Ganymede Release" that I should see these two
entries in my "Updates and Add-ons" module.. I do not.

I then added the two indicated sites to my list, Refreshed and then
checked and Install.

I get the following dependency errors after the install fails..

Any suggestions as to what I need to install to resolve this..???

Thanks much....

John..

============================
Cannot complete the request. See the details.
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feat ure.group/[0.9.2,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/com.csc.dip.projectset.feature.fea ture.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.1.I20080612-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feat ure.group/[0.9.2,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency: requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency: requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group /
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.projectset.feature.group
2.0.1.I20080612-1500] requiredCapability:
org.eclipse.equinox.p2.iu/com.csc.dip.projectset.feature.fea ture.group/0.0.0
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.projectset.feature.group
2.0.1.I20080612-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.1.I20080612-1500,1.0.0)
Re: SVN Install fails - dependencies [message #47956 is a reply to message #47927] Sun, 28 June 2009 19:03 Go to previous messageGo to next message
Werner Keil is currently offline Werner Keil
Messages: 1083
Registered: July 2009
Senior Member
It also fails if you try to install it into more recent Galileo versions.

See RC4:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.pulsar,
phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.Collect,
operand=, action=).
Problems downloading artifact:
osgi.bundle,org.eclipse.mtj.core.hooks,1.0.0.v200906121354.
File has invalid content:%TEMP%\signatureFile1195602631999079774.jar
Invalid content:lib/asm-all-3.0.jar
The file "lib/asm-all-3.0.jar" in the jar
"%TEMP%\signatureFile1195602631999079774.jar" has been tampered!

(tried with Pulsar, which as a matter of fact currently only works with
Android Developer Tools ;-/)

I substituted the Temp path, but this file always gets downloaded wrong!!
Even after deleting it manually the next install fails.

I'll try with a Final distro, but other install issues working in Final also
usually worked with RC4 already.
If it persists, I'll also file a bug.
Re: SVN Install fails - dependencies [message #48326 is a reply to message #47927] Fri, 03 July 2009 15:18 Go to previous message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello John,

I would recommend you to install Latest release, here are links:
SVN Team Provider:
http://download.eclipse.org/technology/subversive/0.7/update -site/

SVN Connectors:
http://community.polarion.com/projects/subversive/download/e clipse/2.0/update-site/

At first install SVN Team Provider and then SVN Connectors.
If you experience any problems with installation, you can install Subversive
from archived update sites.

> (Warning Eclipse newbie, be kind to the ignorant)
>
> I have Ganymede 3.4.1
>
> Mac OSX 10.5.7 (with latest Java version update)
>
> (Ganymede was installed as part of the latest PDT package (PHP))
>
> I would like to install SVN
> I reviewed the install instructions at:
>
> http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/install.php
>
> and end up at:
> http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject
>
> It seems to indicate under "Ganymede Release" that I should see these two
> entries in my "Updates and Add-ons" module.. I do not.
>
> I then added the two indicated sites to my list, Refreshed and then
> checked and Install.
>
> I get the following dependency errors after the install fails..
>
> Any suggestions as to what I need to install to resolve this..???
>
> Thanks much....
>
> John..
>
> ============================
> Cannot complete the request. See the details.
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feat ure.group/[0.9.2,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/com.csc.dip.projectset.feature.fea ture.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.1.I20080612-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.maven.ide.eclipse.feature.feat ure.group/[0.9.2,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency: requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency: requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group /
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.debug.core/
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
> Unsatisfied dependency:
> [org.polarion.eclipse.team.svn.projectset.feature.group
> 2.0.1.I20080612-1500] requiredCapability:
> org.eclipse.equinox.p2.iu/com.csc.dip.projectset.feature.fea ture.group/0.0.0
> Unsatisfied dependency:
> [org.polarion.eclipse.team.svn.projectset.feature.group
> 2.0.1.I20080612-1500] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.1.I20080612-1500,1.0.0)
>
>
>
>
Previous Topic:issue: svn repositories exploring content-type external editor association
Next Topic:Differences between connectors / preferred connector
Goto Forum:
  


Current Time: Mon Sep 22 16:23:26 GMT 2014

Powered by FUDForum. Page generated in 0.02629 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software