Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » errors
errors [message #471606] Sat, 08 April 2006 12:11 Go to next message
Alessandro Fredianelli is currently offline Alessandro Fredianelli
Messages: 32
Registered: July 2009
Member
when i try to add a reference to a managed bean from a jsp page, i get a
stakoverflow :

java.lang.StackOverflowError
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:8 91)
at java.lang.ClassLoader.loadClass(ClassLoader.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:367)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
....
....


Trying to design page flow is also not possible cause i'm unable to see any
jsp contained
in my web project, what i'm i missing?


thanks.
Re: errors [message #471608 is a reply to message #471606] Tue, 11 April 2006 19:56 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hi Alessandro,

Can you give us a bit more detail? What version of the JSF deliverables
are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
Are you using a Dynamic Web project with the JSF facet enabled?

Also, can check the stack trace you have and try and find some line
entries that start org.eclipse.wtp.jsf?


--Cam

Alessandro Fredianelli wrote:

> when i try to add a reference to a managed bean from a jsp page, i get a
> stakoverflow :

> java.lang.StackOverflowError
> at java.lang.ClassLoader.findBootstrapClass(Native Method)
> at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:8 91)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> at
>
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:367)
> at
>
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
> at
>
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> ....
> ....


> Trying to design page flow is also not possible cause i'm unable to see any
> jsp contained
> in my web project, what i'm i missing?


> thanks.
Re: errors [message #471612 is a reply to message #471608] Tue, 18 April 2006 10:31 Go to previous messageGo to next message
Alessandro Fredianelli is currently offline Alessandro Fredianelli
Messages: 32
Registered: July 2009
Member
jsf deliverable milestone 5 and all dependancies described into related
tutorial.
I'm following the tutorial, everything works fine except the one i
mentioned.
I attach a more detailed stacktrace extract :

!ENTRY org.eclipse.ui 4 4 2006-04-18 12:22:16.109
!MESSAGE Unhandled event loop exception

!ENTRY org.eclipse.ui 4 0 2006-04-18 12:22:16.109
!MESSAGE java.lang.StackOverflowError
!STACK 0
java.lang.StackOverflowError
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:8 91)
at java.lang.ClassLoader.loadClass(ClassLoader.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:367)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .createExtension(ExtendedConfigurationBuilder.java:89)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .createConfigurations(ExtendedConfigurationBuilder.java:134)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .getConfigurations(ExtendedConfigurationBuilder.java:203)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:90)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
......

it continues this way until the overflow.



"Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
> Hi Alessandro,
>
> Can you give us a bit more detail? What version of the JSF deliverables
> are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
> Are you using a Dynamic Web project with the JSF facet enabled?
>
> Also, can check the stack trace you have and try and find some line
> entries that start org.eclipse.wtp.jsf?
Re: errors [message #471615 is a reply to message #471612] Tue, 18 April 2006 13:20 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2266
Registered: July 2009
Senior Member
Alessandro Fredianelli wrote:
> "Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
> news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
>> Hi Alessandro,
>> Can you give us a bit more detail? What version of the JSF deliverables
>> are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
>> Are you using a Dynamic Web project with the JSF facet enabled?

Also, which build of WTP are you using? This may already be fixed
in newer builds.

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: errors [message #471616 is a reply to message #471615] Tue, 18 April 2006 13:30 Go to previous messageGo to next message
Alessandro Fredianelli is currently offline Alessandro Fredianelli
Messages: 32
Registered: July 2009
Member
wtp-S-1.5M5-200603022222.

i tryied with 1.5m6 but i had problems.


"Nitin Dahyabhai" <nitind@us.ibm.com> ha scritto nel messaggio
news:e22p29$7go$1@utils.eclipse.org...
> Alessandro Fredianelli wrote:
>> "Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
>> news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
>>> Hi Alessandro,
>>> Can you give us a bit more detail? What version of the JSF deliverables
>>> are you using? What version of the JSF dependencies (Eclipse, EMF
>>> etc.)? Are you using a Dynamic Web project with the JSF facet enabled?
>
> Also, which build of WTP are you using? This may already be fixed in
> newer builds.
>
> --
> - Nitin
Re: errors [message #471617 is a reply to message #471616] Thu, 20 April 2006 01:01 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
The required WTP build was I20060310 (the March 10 integration build),
which I can't find anymore (actually all integration builds seem to have
disappeared). This build fixes a bug in a JSF dependency that caused the
stack overflow you are seeing.

Bugzilla: https://bugs.eclipse.org/bugs/show_bug.cgi?id=130402


--Cam

Alessandro Fredianelli wrote:

> wtp-S-1.5M5-200603022222.

> i tryied with 1.5m6 but i had problems.
Re: errors [message #596929 is a reply to message #471606] Tue, 11 April 2006 19:56 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hi Alessandro,

Can you give us a bit more detail? What version of the JSF deliverables
are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
Are you using a Dynamic Web project with the JSF facet enabled?

Also, can check the stack trace you have and try and find some line
entries that start org.eclipse.wtp.jsf?


--Cam

Alessandro Fredianelli wrote:

> when i try to add a reference to a managed bean from a jsp page, i get a
> stakoverflow :

> java.lang.StackOverflowError
> at java.lang.ClassLoader.findBootstrapClass(Native Method)
> at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:8 91)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> at
>
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:367)
> at
>
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
> at
>
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> ....
> ....


> Trying to design page flow is also not possible cause i'm unable to see any
> jsp contained
> in my web project, what i'm i missing?


> thanks.
Re: errors [message #596957 is a reply to message #471608] Tue, 18 April 2006 10:31 Go to previous message
Alessandro Fredianelli is currently offline Alessandro Fredianelli
Messages: 32
Registered: July 2009
Member
jsf deliverable milestone 5 and all dependancies described into related
tutorial.
I'm following the tutorial, everything works fine except the one i
mentioned.
I attach a more detailed stacktrace extract :

!ENTRY org.eclipse.ui 4 4 2006-04-18 12:22:16.109
!MESSAGE Unhandled event loop exception

!ENTRY org.eclipse.ui 4 0 2006-04-18 12:22:16.109
!MESSAGE java.lang.StackOverflowError
!STACK 0
java.lang.StackOverflowError
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:8 91)
at java.lang.ClassLoader.loadClass(ClassLoader.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:367)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .createExtension(ExtendedConfigurationBuilder.java:89)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .createConfigurations(ExtendedConfigurationBuilder.java:134)
at
org.eclipse.wst.sse.ui.internal.ExtendedConfigurationBuilder .getConfigurations(ExtendedConfigurationBuilder.java:203)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:90)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.setContentAssistProcessor(StructuredContentAssi stant.java:52)
at
org.eclipse.wst.sse.ui.internal.contentassist.StructuredCont entAssistant.getContentAssistProcessor(StructuredContentAssi stant.java:95)
......

it continues this way until the overflow.



"Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
> Hi Alessandro,
>
> Can you give us a bit more detail? What version of the JSF deliverables
> are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
> Are you using a Dynamic Web project with the JSF facet enabled?
>
> Also, can check the stack trace you have and try and find some line
> entries that start org.eclipse.wtp.jsf?
Re: errors [message #596964 is a reply to message #471612] Tue, 18 April 2006 13:20 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2266
Registered: July 2009
Senior Member
Alessandro Fredianelli wrote:
> "Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
> news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
>> Hi Alessandro,
>> Can you give us a bit more detail? What version of the JSF deliverables
>> are you using? What version of the JSF dependencies (Eclipse, EMF etc.)?
>> Are you using a Dynamic Web project with the JSF facet enabled?

Also, which build of WTP are you using? This may already be fixed
in newer builds.

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: errors [message #596969 is a reply to message #471615] Tue, 18 April 2006 13:30 Go to previous message
Alessandro Fredianelli is currently offline Alessandro Fredianelli
Messages: 32
Registered: July 2009
Member
wtp-S-1.5M5-200603022222.

i tryied with 1.5m6 but i had problems.


"Nitin Dahyabhai" <nitind@us.ibm.com> ha scritto nel messaggio
news:e22p29$7go$1@utils.eclipse.org...
> Alessandro Fredianelli wrote:
>> "Cameron Bateman" <cameron.bateman@oracle.com> ha scritto nel messaggio
>> news:df94cc655456a877ce7a7eab86e0cfde$1@www.eclipse.org...
>>> Hi Alessandro,
>>> Can you give us a bit more detail? What version of the JSF deliverables
>>> are you using? What version of the JSF dependencies (Eclipse, EMF
>>> etc.)? Are you using a Dynamic Web project with the JSF facet enabled?
>
> Also, which build of WTP are you using? This may already be fixed in
> newer builds.
>
> --
> - Nitin
Re: errors [message #596978 is a reply to message #471616] Thu, 20 April 2006 01:01 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
The required WTP build was I20060310 (the March 10 integration build),
which I can't find anymore (actually all integration builds seem to have
disappeared). This build fixes a bug in a JSF dependency that caused the
stack overflow you are seeing.

Bugzilla: https://bugs.eclipse.org/bugs/show_bug.cgi?id=130402


--Cam

Alessandro Fredianelli wrote:

> wtp-S-1.5M5-200603022222.

> i tryied with 1.5m6 but i had problems.
Previous Topic:problem setting up eclipse ide with jsf support
Next Topic:problem setting up eclipse ide with jsf support
Goto Forum:
  


Current Time: Tue Sep 16 21:46:12 GMT 2014

Powered by FUDForum. Page generated in 0.01908 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software