Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » mac requires win32 dll?
mac requires win32 dll? [message #466763] Tue, 17 January 2006 10:48 Go to next message
Matt White is currently offline Matt White
Messages: 4
Registered: July 2009
Junior Member
If I try to run my exported jar on my mac I get the the unsatisfied link
error message:

Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-win32-
3062 in java.library.path

I'm using eclipse 3.1.0.
Re: mac requires win32 dll? [message #466764 is a reply to message #466763] Tue, 17 January 2006 10:55 Go to previous messageGo to next message
Jeff Myers is currently offline Jeff Myers
Messages: 489
Registered: July 2009
Senior Member
Matt,

Are you using the the Windows or OS X version of the SWT jars with your
application?

- Jeff
Re: mac requires win32 dll? [message #466765 is a reply to message #466763] Tue, 17 January 2006 11:18 Go to previous message
Alex Blewitt is currently offline Alex Blewitt
Messages: 946
Registered: July 2009
Senior Member
You may also want to look into your plugins; it's possible that you've inadvertently specified a dependency on the Win32 fragment instead of the org.eclipse.swt 'virtual' plugin.

Mac doesn't need the win32 dll ;-)

Are you running on one of the new intel macs? I wonder if there's an assumption that there's a processor-specific flag in there ...

Alex.
Previous Topic:Why these cursor can not be disposed??
Next Topic:Retrieve minsize for use in ScrolledComposite
Goto Forum:
  


Current Time: Wed Jul 23 10:06:43 EDT 2014

Powered by FUDForum. Page generated in 0.02577 seconds