Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Derby fails to create database
Derby fails to create database [message #46629] Wed, 09 July 2008 22:36 Go to next message
Eclipse User
Originally posted by: cuco2772.gmail.com

I downloaded this plugin: org.apache.derby_10.1.2.1_v200706111724.jar
to eclipse/plugins, started
eclipse. Everything was going well with defining a driver definition but
when I got to the part where the 'New Derby Connection Profile' window
comes up and I fill in the details and press
'Finish' for the wizard to complete. Instead of connecting to the database
I get
this error:

Error creating SQL Model Connection to New Derby.(Error: Failed to create
database '/home/cuco/DerbyDatabases/MyNewDB')
Error creating JDBC Connection to New Derby - Failed to create database

THanks for any help
Re: Derby fails to create database [message #46651 is a reply to message #46629] Thu, 10 July 2008 14:52 Go to previous messageGo to next message
Eclipse User
Originally posted by: brianf.sybase.com

I'm wondering if this is a permissions issue in that particular directory? I
can't say that I've tested the Derby functionality on a Linux or UNIX
machine.

Was the "Create Database (if required)" checkbox checked and did
";create=true" appear in the URL in the wizard page where you configured
your Derby connection?

--Fitz

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:f7855a0145521b443a1d591d13a08c4a$1@www.eclipse.org...
>I downloaded this plugin: org.apache.derby_10.1.2.1_v200706111724.jar
> to eclipse/plugins, started
> eclipse. Everything was going well with defining a driver definition but
> when I got to the part where the 'New Derby Connection Profile' window
> comes up and I fill in the details and press
> 'Finish' for the wizard to complete. Instead of connecting to the database
> I get this error:
>
> Error creating SQL Model Connection to New Derby.(Error: Failed to create
> database '/home/cuco/DerbyDatabases/MyNewDB')
> Error creating JDBC Connection to New Derby - Failed to create database
>
> THanks for any help
>
>
Re: Derby fails to create database [message #46756 is a reply to message #46651] Thu, 10 July 2008 18:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: cuco2772.gmail.com

I just checked that. I restarted the wizard and clicked the properties.
when the New Driver Definition window came up. I noticed it had (under
General)
something like jdbc:derby:C\:myDatabases\......, so I changed that to
/home/cuco/DerbyDatabases/MyNewDB. The create=true was in the URL.
Now when I rt. click on New Derby in the Data Source Explorer and click
JDBC Connection Properties I see that it does have the URL as
jdbc:derby:/home/cuco/DerbyDatabases/MyNewDB:create=true, so that part
looks correct.
One other thing I noticed that looks strange,though, is that in the Data
Source Explorer it has the little blue icon for New Derby, but above that
it has another blue icon that just says c. I click on that to see what it
is, and I dont see any info for it. Anyway, thanks for your help. I'm
wondering it this could be a bug.
Re: Derby fails to create database [message #46867 is a reply to message #46756] Mon, 14 July 2008 16:55 Go to previous messageGo to next message
Eclipse User
Originally posted by: brianf.sybase.com

Can you create a Bugzilla entry and attach a screen shot along with any
steps to reproduce it? I'll be happy to take a look and see if I can repro
it then.

Thanks!

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:a0ca41310615fc7b2d1777fa2337cb87$1@www.eclipse.org...
>I just checked that. I restarted the wizard and clicked the properties.
> when the New Driver Definition window came up. I noticed it had (under
> General)
> something like jdbc:derby:C\:myDatabases\......, so I changed that to
> /home/cuco/DerbyDatabases/MyNewDB. The create=true was in the URL.
> Now when I rt. click on New Derby in the Data Source Explorer and click
> JDBC Connection Properties I see that it does have the URL as
> jdbc:derby:/home/cuco/DerbyDatabases/MyNewDB:create=true, so that part
> looks correct. One other thing I noticed that looks strange,though, is
> that in the Data Source Explorer it has the little blue icon for New
> Derby, but above that it has another blue icon that just says c. I click
> on that to see what it is, and I dont see any info for it. Anyway, thanks
> for your help. I'm wondering it this could be a bug.
>
>
Re: Derby fails to create database [message #47015 is a reply to message #46867] Tue, 15 July 2008 23:11 Go to previous messageGo to next message
Eclipse User
Originally posted by: cuco2772.gmail.com

Well, it looks it's not a bug afterall. The tutorial I was using was
written
for Windows, which uses the C: drive for everything. THe tutorial has the
database URL as C:\databasedir\databasename. I'm using Linux, so I
substituted
my homedir for the C; drive part. It turns out that in Linux you need the
fully
qualified path, so ~home/workspace/dblocation, which worked.
Re: Derby fails to create database [message #47045 is a reply to message #47015] Wed, 16 July 2008 16:29 Go to previous message
Eclipse User
Originally posted by: brianf.sybase.com

We just fixed a bug that will be going into our 1.6.1 release to make the
default platform-aware, so hopefully it'll be less confusing from that point
forward (i.e. it'll know you're on UNIX/LINUX and change the home path to
the database so you get a more meaningful default).

Thanks for your patience with this and I'm glad you figured out the
solution. I didn't think to ask if you were on Linux or not. :)

--Fitz

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:0bb7c01b4b9d417d8bea7485cee77c9a$1@www.eclipse.org...
> Well, it looks it's not a bug afterall. The tutorial I was using was
> written
> for Windows, which uses the C: drive for everything. THe tutorial has the
> database URL as C:\databasedir\databasename. I'm using Linux, so I
> substituted
> my homedir for the C; drive part. It turns out that in Linux you need the
> fully
> qualified path, so ~home/workspace/dblocation, which worked.
Re: Derby fails to create database [message #591853 is a reply to message #46629] Thu, 10 July 2008 14:52 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
I'm wondering if this is a permissions issue in that particular directory? I
can't say that I've tested the Derby functionality on a Linux or UNIX
machine.

Was the "Create Database (if required)" checkbox checked and did
";create=true" appear in the URL in the wizard page where you configured
your Derby connection?

--Fitz

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:f7855a0145521b443a1d591d13a08c4a$1@www.eclipse.org...
>I downloaded this plugin: org.apache.derby_10.1.2.1_v200706111724.jar
> to eclipse/plugins, started
> eclipse. Everything was going well with defining a driver definition but
> when I got to the part where the 'New Derby Connection Profile' window
> comes up and I fill in the details and press
> 'Finish' for the wizard to complete. Instead of connecting to the database
> I get this error:
>
> Error creating SQL Model Connection to New Derby.(Error: Failed to create
> database '/home/cuco/DerbyDatabases/MyNewDB')
> Error creating JDBC Connection to New Derby - Failed to create database
>
> THanks for any help
>
>
Re: Derby fails to create database [message #591887 is a reply to message #46651] Thu, 10 July 2008 18:34 Go to previous message
Adam Posner is currently offline Adam Posner
Messages: 8
Registered: July 2009
Junior Member
I just checked that. I restarted the wizard and clicked the properties.
when the New Driver Definition window came up. I noticed it had (under
General)
something like jdbc:derby:C\:myDatabases\......, so I changed that to
/home/cuco/DerbyDatabases/MyNewDB. The create=true was in the URL.
Now when I rt. click on New Derby in the Data Source Explorer and click
JDBC Connection Properties I see that it does have the URL as
jdbc:derby:/home/cuco/DerbyDatabases/MyNewDB:create=true, so that part
looks correct.
One other thing I noticed that looks strange,though, is that in the Data
Source Explorer it has the little blue icon for New Derby, but above that
it has another blue icon that just says c. I click on that to see what it
is, and I dont see any info for it. Anyway, thanks for your help. I'm
wondering it this could be a bug.
Re: Derby fails to create database [message #591928 is a reply to message #46756] Mon, 14 July 2008 16:55 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Can you create a Bugzilla entry and attach a screen shot along with any
steps to reproduce it? I'll be happy to take a look and see if I can repro
it then.

Thanks!

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:a0ca41310615fc7b2d1777fa2337cb87$1@www.eclipse.org...
>I just checked that. I restarted the wizard and clicked the properties.
> when the New Driver Definition window came up. I noticed it had (under
> General)
> something like jdbc:derby:C\:myDatabases\......, so I changed that to
> /home/cuco/DerbyDatabases/MyNewDB. The create=true was in the URL.
> Now when I rt. click on New Derby in the Data Source Explorer and click
> JDBC Connection Properties I see that it does have the URL as
> jdbc:derby:/home/cuco/DerbyDatabases/MyNewDB:create=true, so that part
> looks correct. One other thing I noticed that looks strange,though, is
> that in the Data Source Explorer it has the little blue icon for New
> Derby, but above that it has another blue icon that just says c. I click
> on that to see what it is, and I dont see any info for it. Anyway, thanks
> for your help. I'm wondering it this could be a bug.
>
>
Re: Derby fails to create database [message #591981 is a reply to message #46867] Tue, 15 July 2008 23:11 Go to previous message
Adam Posner is currently offline Adam Posner
Messages: 8
Registered: July 2009
Junior Member
Well, it looks it's not a bug afterall. The tutorial I was using was
written
for Windows, which uses the C: drive for everything. THe tutorial has the
database URL as C:\databasedir\databasename. I'm using Linux, so I
substituted
my homedir for the C; drive part. It turns out that in Linux you need the
fully
qualified path, so ~home/workspace/dblocation, which worked.
Re: Derby fails to create database [message #591994 is a reply to message #47015] Wed, 16 July 2008 16:29 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
We just fixed a bug that will be going into our 1.6.1 release to make the
default platform-aware, so hopefully it'll be less confusing from that point
forward (i.e. it'll know you're on UNIX/LINUX and change the home path to
the database so you get a more meaningful default).

Thanks for your patience with this and I'm glad you figured out the
solution. I didn't think to ask if you were on Linux or not. :)

--Fitz

"Adam Posner" <cuco2772@gmail.com> wrote in message
news:0bb7c01b4b9d417d8bea7485cee77c9a$1@www.eclipse.org...
> Well, it looks it's not a bug afterall. The tutorial I was using was
> written
> for Windows, which uses the C: drive for everything. THe tutorial has the
> database URL as C:\databasedir\databasename. I'm using Linux, so I
> substituted
> my homedir for the C; drive part. It turns out that in Linux you need the
> fully
> qualified path, so ~home/workspace/dblocation, which worked.
Previous Topic:Generating a DDL from java
Next Topic:Adding an Apache Derby Database to a project in Ganymede
Goto Forum:
  


Current Time: Wed Oct 22 09:46:01 GMT 2014

Powered by FUDForum. Page generated in 0.02413 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software