Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Doesn't recognize classes in the same package
Doesn't recognize classes in the same package [message #3924] Thu, 14 October 2004 16:35
Eclipse UserFriend
Originally posted by: Paulo.Sargaco.sapo.pt

Hi there. I wonder if someone can help me out. I started working with
Eclipse recently. It seems a cool IDE and everything went well at first.
However, after a while, Eclipse started showing (apparentely) wrong items
on the Problems window. For instance, I have a package, let's call it
a.b.c with two different classes Class1, Class2,..., ClassN. I'm using
Class2 objects on Class1 methods and Eclipse isn't able to resolve Class1.
I tried, just for the sake of solving the thing, to make an import of
Class1 but still no cigar. The strange thing is that this problem started
spreading. At first it was only Class2 that was showing problems, but then
more classes on the same package had the same problem. And other packages
too.

I'm using Ant tasks for the compilation and all the classes compile
without problems, so I'm having problems pinpointing the issue.

Just to add more data to the explanation, this started hapening after
installing Lomboz plug-in to edit JSPs. I'm not sure both facts are
related, though.
Previous Topic:Supress compilation and errors for large fiels
Next Topic:Problem with CDT
Goto Forum:
  


Current Time: Fri Nov 28 20:47:39 GMT 2014

Powered by FUDForum. Page generated in 0.01514 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software