Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Can't install Subversive SVN Connectors release (2.0.7 or 2.0.8?)
Can't install Subversive SVN Connectors release (2.0.7 or 2.0.8?) [message #40972] Thu, 05 February 2009 03:54 Go to next message
Christoph  is currently offline Christoph
Messages: 16
Registered: July 2009
Junior Member
Hi,

I try to install latest release version of Polarion SVN connectors with
Eclipse 3.4.1 and after having installed Subversive 0.7.6 successfully.

When using the URL
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
as described on
http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject,
the update manager fails with the following message:

An error occurred while collecting items to be installed
Problems downloading artifact:
osgi.bundle,org.polarion.eclipse.team.svn.connector,2.0.7.I2 0081222-1900.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for
org.polarion.eclipse.team.svn.connector/org.eclipse.update.f eature/2.0.7.I20081222-1900
on repository file:/D:/Java/dev/eclipse-3.4.1/.
Error unzipping
D:\Profile\ams00585\LOKALE~1\Temp\org.polarion.eclipse.team. svn.connector_2.0.7.I20081222-190061302.jar:
Invalid zip file format

The mentioned file contains the following:

...
<H1>Multiple Choices</H1>
The document name you requested
(<code> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector_2.0.7.I20081222-1 900.jar </code>)
could not be found on this server.
However, we found documents with names similar to the one you
requested.<p>Available documents:
<ul>
<li><a
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar </a>
(common basename)
<li><a
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar </a>
(common basename)
<li><a
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar </a>
(common basename)
...

So, it seems the site contains version 2.0.8 of these plugins, but Update
manager thinks there should be files of version 2.0.7 which he can't find.

What can I do?

Thanks,
Christoph
Re: Can't install Subversive SVN Connectors release (2.0.7 or 2.0.8?) [message #41062 is a reply to message #40972] Thu, 05 February 2009 09:16 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Christoph,

It seems strange. What version do you see for SVN Connectors in "Software
Updates and Add-ons" dialog? Do you have an enabled "Show only the latest
versions of available software" option?
Also as a quick resolution you can install connectors from archived update
site:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/builds/

> Hi,
>
> I try to install latest release version of Polarion SVN connectors with
> Eclipse 3.4.1 and after having installed Subversive 0.7.6 successfully.
>
> When using the URL
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
> as described on
> http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject,
> the update manager fails with the following message:
>
> An error occurred while collecting items to be installed
> Problems downloading artifact:
> osgi.bundle,org.polarion.eclipse.team.svn.connector,2.0.7.I2 0081222-1900.
> Downloaded stream not a valid archive. Check the server.
> Error closing the output stream for
> org.polarion.eclipse.team.svn.connector/org.eclipse.update.f eature/2.0.7.I20081222-1900
> on repository file:/D:/Java/dev/eclipse-3.4.1/. Error unzipping
> D:\Profile\ams00585\LOKALE~1\Temp\org.polarion.eclipse.team. svn.connector_2.0.7.I20081222-190061302.jar:
> Invalid zip file format
>
> The mentioned file contains the following:
>
> ..
> <H1>Multiple Choices</H1>
> The document name you requested
> (<code> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector_2.0.7.I20081222-1 900.jar </code>)
> could not be found on this server.
> However, we found documents with names similar to the one you
> requested.<p>Available documents:
> <ul>
> <li><a
> href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar </a>
> (common basename)
> <li><a
> href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar </a>
> (common basename)
> <li><a
> href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar </a>
> (common basename)
> ..
>
> So, it seems the site contains version 2.0.8 of these plugins, but Update
> manager thinks there should be files of version 2.0.7 which he can't find.
> What can I do?
>
> Thanks,
> Christoph
>
Re: Can't install Subversive SVN Connectors release (2.0.7 or 2.0.8?) [message #41184 is a reply to message #41062] Thu, 05 February 2009 10:38 Go to previous message
Christoph  is currently offline Christoph
Messages: 16
Registered: July 2009
Junior Member
The version I see is exactly what is listed in the error message:
2.0.7.I20081222-1900. The checkbox "Show only the latest" does not change
the listed items, nor does pressing Refresh button.

BTW, I tried both with an existing Eclipse 3.4.0 installation (having
version 2.0.3 of connectors installed) as well as with a fresh 3.4.1
installation. Neither restarting Eclipse nor rebooting the system did help.

I just tried to use the URL you gave me but recognized this is not an
update site but providing the ZIPs. I will probably download and use that
now.

Thanks for your help,
Christoph


> Hello Christoph,

> It seems strange. What version do you see for SVN Connectors in "Software
> Updates and Add-ons" dialog? Do you have an enabled "Show only the latest
> versions of available software" option?
> Also as a quick resolution you can install connectors from archived update
> site:
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/builds/

>> Hi,
>>
>> I try to install latest release version of Polarion SVN connectors with
>> Eclipse 3.4.1 and after having installed Subversive 0.7.6 successfully.
>>
>> When using the URL
>>
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
>> as described on
>> http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject,
>> the update manager fails with the following message:
>>
>> An error occurred while collecting items to be installed
>> Problems downloading artifact:
>> osgi.bundle,org.polarion.eclipse.team.svn.connector,2.0.7.I2 0081222-1900.
>> Downloaded stream not a valid archive. Check the server.
>> Error closing the output stream for
>>
org.polarion.eclipse.team.svn.connector/org.eclipse.update.f eature/2.0.7.I20081222-1900
>> on repository file:/D:/Java/dev/eclipse-3.4.1/. Error unzipping
>>
D:Profileams00585LOKALE~1Temporg.polarion.eclipse.team.svn.c onnector_2.0.7.I20081222-190061302.jar:
>> Invalid zip file format
>>
>> The mentioned file contains the following:
>>
>> ..
>> <H1>Multiple Choices</H1>
>> The document name you requested
>>
(<code> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector_2.0.7.I20081222-1 900.jar </code>)
>> could not be found on this server.
>> However, we found documents with names similar to the one you
>> requested.<p>Available documents:
>> <ul>
>> <li><a
>>
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.sources_2. 0.8.I20090202-1500.jar </a>
>> (common basename)
>> <li><a
>>
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl.win32_2.0. 8.I20090202-1500.jar </a>
>> (common basename)
>> <li><a
>>
href=" /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar "> /projects/subversive/download/eclipse/2.0/update-site/featur es/org.polarion.eclipse.team.svn.connector.javahl15.sources_ 2.0.8.I20090202-1500.jar </a>
>> (common basename)
>> ..
>>
>> So, it seems the site contains version 2.0.8 of these plugins, but Update
>> manager thinks there should be files of version 2.0.7 which he can't find.
>> What can I do?
>>
>> Thanks,
>> Christoph
>>
Previous Topic:Differt kinds of changesets?
Next Topic:Assign hotkeys for Team>Commit/Update
Goto Forum:
  


Current Time: Mon Jul 28 04:35:53 EDT 2014

Powered by FUDForum. Page generated in 0.07902 seconds