Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Configuration Caching missing for Bugzilla 2.2.0
Configuration Caching missing for Bugzilla 2.2.0 [message #40174] Mon, 31 December 2007 22:40 Go to next message
Jason Faust is currently offline Jason FaustFriend
Messages: 2
Registered: July 2009
Junior Member
I have a quick question, to verify a problem before I file a bug report,
about the Bugzilla Connector.

The New & Noteworthy shows a screen shot of a option labeled "Cached
Configuration" that I cannot seem to find on the version that I
installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
and to verify I did a clean install onto a bare platform runtime, and
saw the same missing option. This this indeed missing or am I doing
something wrong?

Thank you for your time.

Sun JDK 1.6.0_03
Windows XP SP2
Eclipse SDK 3.3.1.1
Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #40512 is a reply to message #40174] Wed, 09 January 2008 10:22 Go to previous messageGo to next message
maarten meijer is currently offline maarten meijerFriend
Messages: 145
Registered: July 2009
Senior Member
Noticed the same thing today.

It was put in place to resolve a load/performance problem on
bugs.eclipse.org. It works by sending a HEAD request before doing a
config update to check whether there have been mods and works only on
bugs.eclipse.org as it requires mods to bugzilla itself.

It was dropped from the development stream on 5 october 2007 when the
gzip patches were put in. See the source history on
BugzillaRepositorySettingsPage.java#createAdditionalControls
version 1.70

bugs.eclipse.org resolved the issue by generating the config once a day
and propagating that to the download mirrors around the world.

When you request confiig.cgi from bugs.eclipse.org, you actually get a
file from some other server near you.

Vote for bug 205416 when you want gzip encoding on bugs.eclipse.org

If you want to increase performance on another bugzilla, look at:
196056: [performance] reduce frequency of repository configuration download
https://bugs.eclipse.org/bugs/show_bug.cgi?id=196056

205416: In order to reduce traffic, the bugzilla should not only cache
its config but also gzip it
https://bugs.eclipse.org/bugs/show_bug.cgi?id=205416

205708: Make Mylyn accept gzip encoded data on all requests
https://bugs.eclipse.org/bugs/show_bug.cgi?id=205708

These require mods to bugzilla itself as well for the config, but the
rest can be implemented by adding mod_gzip/mod_deflate to Apache

You should file a bug report, as it is an error in the new and noteworthy!

Maarten

Jason Faust wrote:
> I have a quick question, to verify a problem before I file a bug report,
> about the Bugzilla Connector.
>
> The New & Noteworthy shows a screen shot of a option labeled "Cached
> Configuration" that I cannot seem to find on the version that I
> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
> and to verify I did a clean install onto a bare platform runtime, and
> saw the same missing option. This this indeed missing or am I doing
> something wrong?
>
> Thank you for your time.
>
> Sun JDK 1.6.0_03
> Windows XP SP2
> Eclipse SDK 3.3.1.1
> Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #40573 is a reply to message #40174] Wed, 09 January 2008 12:57 Go to previous messageGo to next message
maarten meijer is currently offline maarten meijerFriend
Messages: 145
Registered: July 2009
Senior Member
Created bug 214739: New & Noteworthy for 2.2 mentions cached
configuration, but option is absent from bugzilla connector
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214739


Jason Faust wrote:
> I have a quick question, to verify a problem before I file a bug report,
> about the Bugzilla Connector.
>
> The New & Noteworthy shows a screen shot of a option labeled "Cached
> Configuration" that I cannot seem to find on the version that I
> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
> and to verify I did a clean install onto a bare platform runtime, and
> saw the same missing option. This this indeed missing or am I doing
> something wrong?
>
> Thank you for your time.
>
> Sun JDK 1.6.0_03
> Windows XP SP2
> Eclipse SDK 3.3.1.1
> Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #40975 is a reply to message #40573] Fri, 11 January 2008 23:36 Go to previous message
Eclipse UserFriend
Originally posted by: beatmik.acm.org

This is now automatic if caching is available, so the user does not need
to be aware of the setting. Thanks for pointing this out. I have
updated the New & Noteworthy and linked to your instructions for admins,
which I have moved to:
http://wiki.eclipse.org/Mylyn_User_Guide#Tips_for_server_adm inistrators

Mik

Maarten Meijer wrote:
> Created bug 214739: New & Noteworthy for 2.2 mentions cached
> configuration, but option is absent from bugzilla connector
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=214739
>
> Jason Faust wrote:
>> I have a quick question, to verify a problem before I file a bug
>> report, about the Bugzilla Connector.
>>
>> The New & Noteworthy shows a screen shot of a option labeled "Cached
>> Configuration" that I cannot seem to find on the version that I
>> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
>> and to verify I did a clean install onto a bare platform runtime, and
>> saw the same missing option. This this indeed missing or am I doing
>> something wrong?
>>
>> Thank you for your time.
>>
>> Sun JDK 1.6.0_03
>> Windows XP SP2
>> Eclipse SDK 3.3.1.1
>> Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #586708 is a reply to message #40174] Wed, 09 January 2008 10:22 Go to previous message
maarten meijer is currently offline maarten meijerFriend
Messages: 145
Registered: July 2009
Senior Member
Noticed the same thing today.

It was put in place to resolve a load/performance problem on
bugs.eclipse.org. It works by sending a HEAD request before doing a
config update to check whether there have been mods and works only on
bugs.eclipse.org as it requires mods to bugzilla itself.

It was dropped from the development stream on 5 october 2007 when the
gzip patches were put in. See the source history on
BugzillaRepositorySettingsPage.java#createAdditionalControls
version 1.70

bugs.eclipse.org resolved the issue by generating the config once a day
and propagating that to the download mirrors around the world.

When you request confiig.cgi from bugs.eclipse.org, you actually get a
file from some other server near you.

Vote for bug 205416 when you want gzip encoding on bugs.eclipse.org

If you want to increase performance on another bugzilla, look at:
196056: [performance] reduce frequency of repository configuration download
https://bugs.eclipse.org/bugs/show_bug.cgi?id=196056

205416: In order to reduce traffic, the bugzilla should not only cache
its config but also gzip it
https://bugs.eclipse.org/bugs/show_bug.cgi?id=205416

205708: Make Mylyn accept gzip encoded data on all requests
https://bugs.eclipse.org/bugs/show_bug.cgi?id=205708

These require mods to bugzilla itself as well for the config, but the
rest can be implemented by adding mod_gzip/mod_deflate to Apache

You should file a bug report, as it is an error in the new and noteworthy!

Maarten

Jason Faust wrote:
> I have a quick question, to verify a problem before I file a bug report,
> about the Bugzilla Connector.
>
> The New & Noteworthy shows a screen shot of a option labeled "Cached
> Configuration" that I cannot seem to find on the version that I
> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
> and to verify I did a clean install onto a bare platform runtime, and
> saw the same missing option. This this indeed missing or am I doing
> something wrong?
>
> Thank you for your time.
>
> Sun JDK 1.6.0_03
> Windows XP SP2
> Eclipse SDK 3.3.1.1
> Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #586729 is a reply to message #40174] Wed, 09 January 2008 12:57 Go to previous message
maarten meijer is currently offline maarten meijerFriend
Messages: 145
Registered: July 2009
Senior Member
Created bug 214739: New & Noteworthy for 2.2 mentions cached
configuration, but option is absent from bugzilla connector
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214739


Jason Faust wrote:
> I have a quick question, to verify a problem before I file a bug report,
> about the Bugzilla Connector.
>
> The New & Noteworthy shows a screen shot of a option labeled "Cached
> Configuration" that I cannot seem to find on the version that I
> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
> and to verify I did a clean install onto a bare platform runtime, and
> saw the same missing option. This this indeed missing or am I doing
> something wrong?
>
> Thank you for your time.
>
> Sun JDK 1.6.0_03
> Windows XP SP2
> Eclipse SDK 3.3.1.1
> Targeting bugs.eclipse.org/bugs
Re: Configuration Caching missing for Bugzilla 2.2.0 [message #586926 is a reply to message #40573] Fri, 11 January 2008 23:36 Go to previous message
Mik Kersten is currently offline Mik KerstenFriend
Messages: 287
Registered: July 2009
Senior Member
This is now automatic if caching is available, so the user does not need
to be aware of the setting. Thanks for pointing this out. I have
updated the New & Noteworthy and linked to your instructions for admins,
which I have moved to:
http://wiki.eclipse.org/Mylyn_User_Guide#Tips_for_server_adm inistrators

Mik

Maarten Meijer wrote:
> Created bug 214739: New & Noteworthy for 2.2 mentions cached
> configuration, but option is absent from bugzilla connector
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=214739
>
> Jason Faust wrote:
>> I have a quick question, to verify a problem before I file a bug
>> report, about the Bugzilla Connector.
>>
>> The New & Noteworthy shows a screen shot of a option labeled "Cached
>> Configuration" that I cannot seem to find on the version that I
>> installed today (2.2.0.I20071220-1700). This was an upgrade from 2.1,
>> and to verify I did a clean install onto a bare platform runtime, and
>> saw the same missing option. This this indeed missing or am I doing
>> something wrong?
>>
>> Thank you for your time.
>>
>> Sun JDK 1.6.0_03
>> Windows XP SP2
>> Eclipse SDK 3.3.1.1
>> Targeting bugs.eclipse.org/bugs
Previous Topic:Unable to execute jira query
Next Topic:Problems updating from Mylyn 2.1 to 2.2 using Update Manager
Goto Forum:
  


Current Time: Thu Dec 18 10:41:25 GMT 2014

Powered by FUDForum. Page generated in 0.01882 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software