Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Imported plugin code into eclipse. Compile problem.
Imported plugin code into eclipse. Compile problem. [message #3451] Fri, 25 April 2008 03:21 Go to next message
Eclipse User
Originally posted by: eclipsedev.20.geekrunner.spamgourmet.com

I tried importing the project for org.maven.ide.eclipse into eclipse
3.3.1.1 but it's giving me a red flag on NexusIndexManager.java. The line
in question looks like this:

int sourcesExists = artifactInfo.sourcesExists.ordinal();

and the error is:

The type Enum_ is not generic; it cannot be parameterized with
arguments <ArtifactAvailability>.

Any ideas?

Regards,

Gavin
Re: Imported plugin code into eclipse. Compile problem. [message #3487 is a reply to message #3451] Fri, 25 April 2008 09:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: igorfie.yahoo.com

Gavin,

Sounds like you have java 1.5 compatibility enabled for
org.maven.ide.eclipse project. Have you followed these instructions
http://docs.codehaus.org/display/M2ECLIPSE/Configuring+Devel opment+Environment
to setup m2eclipse development emnironment?

Gavin Bong wrote:
> I tried importing the project for org.maven.ide.eclipse into eclipse
> 3.3.1.1 but it's giving me a red flag on NexusIndexManager.java. The
> line in question looks like this:
>
> int sourcesExists = artifactInfo.sourcesExists.ordinal();
>
> and the error is:
>
> The type Enum_ is not generic; it cannot be parameterized with
> arguments <ArtifactAvailability>.
>
> Any ideas?
>
> Regards,
>
> Gavin
>
Re: Imported plugin code into eclipse. Compile problem. [message #3520 is a reply to message #3487] Fri, 25 April 2008 10:12 Go to previous message
Eugene Kuleshov is currently offline Eugene Kuleshov
Messages: 505
Registered: July 2009
Senior Member
I've tried to reproduce it and checked out m2eclipse code into clean
Eclipse 3.3.1.1 workspace that doesn't have 1.4 JRE registered but don't
see this compilation error. Would be interesting to figure out what is
going on here.

regards,
Eugene


Igor Fedorenko wrote:
> Gavin,
>
> Sounds like you have java 1.5 compatibility enabled for
> org.maven.ide.eclipse project. Have you followed these instructions
> http://docs.codehaus.org/display/M2ECLIPSE/Configuring+Devel opment+Environment
> to setup m2eclipse development emnironment?
>
> Gavin Bong wrote:
>> I tried importing the project for org.maven.ide.eclipse into eclipse
>> 3.3.1.1 but it's giving me a red flag on NexusIndexManager.java. The
>> line in question looks like this:
>>
>> int sourcesExists = artifactInfo.sourcesExists.ordinal();
>>
>> and the error is:
>>
>> The type Enum_ is not generic; it cannot be parameterized with
>> arguments <ArtifactAvailability>.
>>
>> Any ideas?
>>
>> Regards,
>>
>> Gavin
>>
Previous Topic:xml-based editor for maven pom
Next Topic:contributing to m2eclipse
Goto Forum:
  


Current Time: Fri Jul 25 07:31:18 EDT 2014

Powered by FUDForum. Page generated in 0.02607 seconds