Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » JDK 1.4?
JDK 1.4? [message #385409] Wed, 28 January 2009 20:24 Go to next message
hbpham is currently offline hbphamFriend
Messages: 2
Registered: July 2009
Junior Member

Is there a version of EclipseLink / TopLink Essentials that will work
under JDK 1.4? If not what are my options? i.e. any chance I can just
recompile the source under 1.4? TIA.

Re: JDK 1.4? [message #385410 is a reply to message #385409] Thu, 29 January 2009 15:43 Go to previous message
James Sutherland is currently offline James SutherlandFriend
Messages: 1939
Registered: July 2009
Location: Ottawa, Canada
Senior Member

Nope. EclipseLink and JPA require at least JDK 1.5, annotations an other
1.5 artifacts are used extensively.

You need to upgrade you JDK.

You can get an older version on TopLink that does support 1.4, TopLink
10.1.3 still supported JDK 1.4.


James : Wiki : Book : Blog : Twitter
Previous Topic:Mapping inherited id attribute
Next Topic:UpdateAllQuery does not seem to execute
Goto Forum:

Current Time: Sat Oct 10 09:16:39 GMT 2015

Powered by FUDForum. Page generated in 0.04877 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software