Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [TCS]:beginning TCS with Eclipse
[TCS]:beginning TCS with Eclipse [message #379837] Fri, 05 October 2007 11:55 Go to next message
Eclipse User
Originally posted by: joseph.brooth.gmail.com

hi,
I am new with TCS
I tested the TCSToolkit project(Eclipse3.3+ATL2.0+EMF2.3) but I found the
problems of SampleDSL_InjectorCreation.xml and here the extract of the
errors.

BUILD FAILED
/home/ydkiouak/Desktop/eclipse/Test/SampleDSL/SampleDSL_Inje ctorCreation.xml:5:
The following error occurred while executing this line:
/home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:23: The
following error occurred while executing this line:
/home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:120:
Unable to determine generated class
Total time: 3 seconds


then I tried to start with TCS/Language Project but I didn't has to find
the AMMAScripts, and AMMACore projects ???
and also how to configure the fishier build.properties

regards
Joseph
Re: [TCS]:beginning TCS with Eclipse [message #379840 is a reply to message #379837] Fri, 05 October 2007 12:46 Go to previous messageGo to next message
Freddy Allilaire is currently offline Freddy Allilaire
Messages: 130
Registered: July 2009
Senior Member
Hi Joseph,

TCS sample project hasn't moved yet to the last versions of ATL & TCS.
For examples, please take a look to the TCS Zoo:
http://wiki.eclipse.org/TCS/Zoo

Concerning the second point, we have just updated the TCS/Language
Project wiki page (http://wiki.eclipse.org/TCS/Language_Project).
Normally you will find now all the necessary information.

HTH.

Regards,
Freddy.

Joseph Brouth a écrit :
> hi,
> I am new with TCS I tested the TCSToolkit
> project(Eclipse3.3+ATL2.0+EMF2.3) but I found the problems of
> SampleDSL_InjectorCreation.xml and here the extract of the errors.
> BUILD FAILED
> /home/ydkiouak/Desktop/eclipse/Test/SampleDSL/SampleDSL_Inje ctorCreation.xml:5:
> The following error occurred while executing this line:
> /home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:23: The
> following error occurred while executing this line:
> /home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:120:
> Unable to determine generated class
> Total time: 3 seconds
>
>
> then I tried to start with TCS/Language Project but I didn't has to find
> the AMMAScripts, and AMMACore projects ???
> and also how to configure the fishier build.properties
>
> regards
> Joseph
>
>
>
>
>
>


--
Freddy Allilaire - ATLAS Group (INRIA & LINA)
http://www.sciences.univ-nantes.fr/lina/atl/contrib/allilair e
Re: [TCS]:beginning TCS with Eclipse [message #379847 is a reply to message #379840] Fri, 05 October 2007 14:47 Go to previous messageGo to next message
Eclipse User
Originally posted by: joseph.brooth.gmail.com

thank you for informations
but i'm the problem with checked out the AMMAScripts and AMMACore.

is necessary to add CVS Repository ?
so yes I find how I can the configuration with this CVS(the host, the
standard connection.............)

thnx
Joseph
Re: [TCS]:beginning TCS with Eclipse [message #379854 is a reply to message #379847] Sat, 06 October 2007 16:45 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi,

> thank you for informations
> but i'm the problem with checked out the AMMAScripts and AMMACore.
>
> is necessary to add CVS Repository ?
> so yes I find how I can the configuration with this CVS(the host, the
> standard connection.............)

Currently, apart from manually downloading the files from the viewcvs,
you have to use CVS to get the projects. We will offer an easier
download later.

The AMMAScripts and AMMACore projects are in:
server: dev.eclipse.org
repository: /cvsroot/technology
connect annonymously using pserver


Then, checkout the two projects available in:
org.eclipse.gmt/org.eclipse.gmt.tcs/scripts/


Regards,

Frédéric Jouault
Re: [TCS]:beginning TCS with Eclipse [message #379901 is a reply to message #379854] Mon, 08 October 2007 09:28 Go to previous messageGo to next message
Eclipse User
Originally posted by: joseph.Brooth.gmail.com

Hi,
yes I added the All scripts in my workspace but I have remarks for the
following points:

******* build.properties (you can copy and paste
/SampleLanguage/build.properties and modify it).*******

for this file I recovered with one project of ZOO TCS because I did'nt
find "/SampleLanguage/build.properties"

how to configure this file?
for me I notched "Custom build"!!
Es this that it is correct?.


******** In the "Targets" tab:--Set "During a Clean" to target "clean"
*****

I dont arrive to fair this point because I found the zone "During a Clean"
desactivate and text posted inside "Builder is not set to run for this
build kind" same thing in the fields "After A clean" and "Auto build"
I tested with the button "Set Targets" but always this zone is desactivate?


how I should make to activate?


finaly for excute my TCS Projects(Model-To project -- Text) how I must
make?

Thank you for your Helps.
Joseph
Re: [TCS]:beginning TCS with Eclipse [message #380366 is a reply to message #379901] Fri, 16 November 2007 16:49 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi Joseph,

> ******* build.properties (you can copy and paste
> /SampleLanguage/build.properties and modify it).*******
>
> for this file I recovered with one project of ZOO TCS because I did'nt
> find "/SampleLanguage/build.properties"
> how to configure this file?
> for me I notched "Custom build"!!
> Es this that it is correct?.

You should simply specify the name of your DSL, and associated file
extension:
dsl.name=<language name, same as project name>
dsl.extension=<associated file extension>


> ******** In the "Targets" tab:--Set "During a Clean" to target "clean"
> *****
>
> I dont arrive to fair this point because I found the zone "During a
> Clean" desactivate and text posted inside "Builder is not set to run for
> this build kind" same thing in the fields "After A clean" and "Auto
build"
> I tested with the button "Set Targets" but always this zone is
desactivate?
>
>
> how I should make to activate?

Does the configuration point to the correct ant script?


> finaly for excute my TCS Projects(Model-To project -- Text) how I must
> make?
> Thank you for your Helps.
> Joseph

You could start from the sample injection ant script available at the
bottom of http://wiki.eclipse.org/TCS/Language_Project


Regards,

Frédéric Jouault
Re: [TCS]:beginning TCS with Eclipse [message #608042 is a reply to message #379837] Fri, 05 October 2007 12:46 Go to previous message
Freddy Allilaire is currently offline Freddy Allilaire
Messages: 130
Registered: July 2009
Senior Member
Hi Joseph,

TCS sample project hasn't moved yet to the last versions of ATL & TCS.
For examples, please take a look to the TCS Zoo:
http://wiki.eclipse.org/TCS/Zoo

Concerning the second point, we have just updated the TCS/Language
Project wiki page (http://wiki.eclipse.org/TCS/Language_Project).
Normally you will find now all the necessary information.

HTH.

Regards,
Freddy.

Joseph Brouth a écrit :
> hi,
> I am new with TCS I tested the TCSToolkit
> project(Eclipse3.3+ATL2.0+EMF2.3) but I found the problems of
> SampleDSL_InjectorCreation.xml and here the extract of the errors.
> BUILD FAILED
> /home/ydkiouak/Desktop/eclipse/Test/SampleDSL/SampleDSL_Inje ctorCreation.xml:5:
> The following error occurred while executing this line:
> /home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:23: The
> following error occurred while executing this line:
> /home/ydkiouak/Desktop/eclipse/Test/TCSToolkit/TCS2JAR/build .xml:120:
> Unable to determine generated class
> Total time: 3 seconds
>
>
> then I tried to start with TCS/Language Project but I didn't has to find
> the AMMAScripts, and AMMACore projects ???
> and also how to configure the fishier build.properties
>
> regards
> Joseph
>
>
>
>
>
>


--
Freddy Allilaire - ATLAS Group (INRIA & LINA)
http://www.sciences.univ-nantes.fr/lina/atl/contrib/allilair e
Re: [TCS]:beginning TCS with Eclipse [message #608047 is a reply to message #379840] Fri, 05 October 2007 14:47 Go to previous message
Eclipse User
Originally posted by: joseph.brooth.gmail.com

thank you for informations
but i'm the problem with checked out the AMMAScripts and AMMACore.

is necessary to add CVS Repository ?
so yes I find how I can the configuration with this CVS(the host, the
standard connection.............)

thnx
Joseph
Re: [TCS]:beginning TCS with Eclipse [message #608052 is a reply to message #379847] Sat, 06 October 2007 16:45 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi,

> thank you for informations
> but i'm the problem with checked out the AMMAScripts and AMMACore.
>
> is necessary to add CVS Repository ?
> so yes I find how I can the configuration with this CVS(the host, the
> standard connection.............)

Currently, apart from manually downloading the files from the viewcvs,
you have to use CVS to get the projects. We will offer an easier
download later.

The AMMAScripts and AMMACore projects are in:
server: dev.eclipse.org
repository: /cvsroot/technology
connect annonymously using pserver


Then, checkout the two projects available in:
org.eclipse.gmt/org.eclipse.gmt.tcs/scripts/


Regards,

Frédéric Jouault
Re: [TCS]:beginning TCS with Eclipse [message #608063 is a reply to message #379854] Mon, 08 October 2007 09:28 Go to previous message
Eclipse User
Originally posted by: joseph.Brooth.gmail.com

Hi,
yes I added the All scripts in my workspace but I have remarks for the
following points:

******* build.properties (you can copy and paste
/SampleLanguage/build.properties and modify it).*******

for this file I recovered with one project of ZOO TCS because I did'nt
find "/SampleLanguage/build.properties"

how to configure this file?
for me I notched "Custom build"!!
Es this that it is correct?.


******** In the "Targets" tab:--Set "During a Clean" to target "clean"
*****

I dont arrive to fair this point because I found the zone "During a Clean"
desactivate and text posted inside "Builder is not set to run for this
build kind" same thing in the fields "After A clean" and "Auto build"
I tested with the button "Set Targets" but always this zone is desactivate?


how I should make to activate?


finaly for excute my TCS Projects(Model-To project -- Text) how I must
make?

Thank you for your Helps.
Joseph
Re: [TCS]:beginning TCS with Eclipse [message #608259 is a reply to message #379901] Fri, 16 November 2007 16:49 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi Joseph,

> ******* build.properties (you can copy and paste
> /SampleLanguage/build.properties and modify it).*******
>
> for this file I recovered with one project of ZOO TCS because I did'nt
> find "/SampleLanguage/build.properties"
> how to configure this file?
> for me I notched "Custom build"!!
> Es this that it is correct?.

You should simply specify the name of your DSL, and associated file
extension:
dsl.name=<language name, same as project name>
dsl.extension=<associated file extension>


> ******** In the "Targets" tab:--Set "During a Clean" to target "clean"
> *****
>
> I dont arrive to fair this point because I found the zone "During a
> Clean" desactivate and text posted inside "Builder is not set to run for
> this build kind" same thing in the fields "After A clean" and "Auto
build"
> I tested with the button "Set Targets" but always this zone is
desactivate?
>
>
> how I should make to activate?

Does the configuration point to the correct ant script?


> finaly for excute my TCS Projects(Model-To project -- Text) how I must
> make?
> Thank you for your Helps.
> Joseph

You could start from the sample injection ant script available at the
bottom of http://wiki.eclipse.org/TCS/Language_Project


Regards,

Frédéric Jouault
Previous Topic:[MOFScript] Navigable Asociation
Next Topic:[TCS]:Create a Language project!!
Goto Forum:
  


Current Time: Sat Oct 25 21:21:05 GMT 2014

Powered by FUDForum. Page generated in 0.05081 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software