Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » plug-in jar remains same during uninstall and reinstall
plug-in jar remains same during uninstall and reinstall [message #336784] Thu, 02 July 2009 12:55 Go to next message
Prasanna K is currently offline Prasanna K
Messages: 78
Registered: July 2009
Member
Hi,

I have two installations of eclipse-3.4.2. One for development of our
plug-in and another for testing the same.
This is what happens :
I install our plug-in on eclipse-3.4.2. And after a couple of quick tests
I uninstall it.
Then I do some changes to the plug-in and build fresh plug-in update site
by following this method :
http://wiki.eclipse.org/FAQ_How_do_I_create_an_update_site_(site.xml)%3F
I install the plug-in again on the test-eclipse-installation and test out
the features. But I don't find the latest changes in the plug-in. I don't
even see the simple println statements.
Also, when I check the creation date of plug-in jar it clearly tells me
that the jar present in eclipse/plugins is old one.

How do I solve this problem?

Thanks.
Re: plug-in jar remains same during uninstall and reinstall [message #336794 is a reply to message #336784] Fri, 03 July 2009 05:15 Go to previous messageGo to next message
Prasanna K is currently offline Prasanna K
Messages: 78
Registered: July 2009
Member
Any answers please...
Please point me to the right newsgroup if this isn't the one..
Thanks.
Re: plug-in jar remains same during uninstall and reinstall [message #336798 is a reply to message #336794] Fri, 03 July 2009 09:45 Go to previous messageGo to next message
Eclipse User
Originally posted by: user.domain.invalid

kaprasi ha scritto:
> Any answers please...
> Please point me to the right newsgroup if this isn't the one..
> Thanks.
>
I'm not an expert. I think that the 'right' thing is to increment the
plugin version number, so that eclipse knows it is changed. If Eclipse
had the possibility to see changes in the content of the plugin without
different plugin version, it should download every plugin installed at
each update command (if you have automatic updates, this can be really
expensive).


If there is another way, I'm very intereasted too, since everytime I put
on my update site a new version, and there is a little bug (like a
NullPointer...), I dislike very much to increment version number just to
update clients...
Re: plug-in jar remains same during uninstall and reinstall [message #336800 is a reply to message #336798] Fri, 03 July 2009 11:27 Go to previous messageGo to next message
Prasanna K is currently offline Prasanna K
Messages: 78
Registered: July 2009
Member
> I think that the 'right' thing is to increment the
> plugin version number, so that eclipse knows it is changed.

Thanks.
Re: plug-in jar remains same during uninstall and reinstall [message #336834 is a reply to message #336784] Mon, 06 July 2009 15:08 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

As mentioned, you need a higher version number. most plugins have a
version similar to:
Bundle-Version: 0.9.0.qualifier

qualifier gets replaced on build, and can be replaced on a
File>Export...>Deployable plugin and fragment as well.

Most qualifiers look like: v20090629 or I20090629-1930

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/ganymede/index.jsp?topic=/org.eclips e.platform.doc.isv/guide/workbench.htm


Re: plug-in jar remains same during uninstall and reinstall [message #468210 is a reply to message #336834] Tue, 04 August 2009 14:44 Go to previous messageGo to next message
Prasanna K is currently offline Prasanna K
Messages: 78
Registered: July 2009
Member
Paul Webster wrote:

> As mentioned, you need a higher version number. most plugins have a
> version similar to:
> Bundle-Version: 0.9.0.qualifier

> qualifier gets replaced on build, and can be replaced on a
> File>Export...>Deployable plugin and fragment as well.

> Most qualifiers look like: v20090629 or I20090629-1930

> PW

To make sure plug-in sources are updated between uninstall and reinstall I
realized that I had to change the version number.
To do so :

I added the qualifier in plug-in's MANIFEST.MF as :
Bundle-Version: 1.0.0.v200908041905

Then I created update site by following steps in this document (just as I
do normally and works great):
http://wiki.eclipse.org/FAQ_How_do_I_create_an_update_site_(site.xml)%3F

Problem :
This added another plug-in jar to update-site/plugins directory apart from
the old one with just 1.0.0 as the version number.
A new unit with this version number was added to content.xml.
Also a new artifact was added to the artifacts.xml.
The size of our final zip (of update-site dir) has obviously doubled!
Deleting old jar manually before zipping up doesn't solve the problem as
old entries of 'unit' and 'artifact' remain in the xml files which are
then searched for during installation. And installation halts on not
finding them.

Am I doing something wrong here while adding a qualifier to the bundle
version?
If yes please tell me what is the right way of changing version number of
plug-in jar.

Thanks.
Re: plug-in jar remains same during uninstall and reinstall [message #479345 is a reply to message #468210] Mon, 10 August 2009 17:48 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Adding the qualifier allows update (now p2) to know that bundle needs to be updated. So adding v200908041905 to the MANIFEST and jar name solves that problem when deploying your site?

Is the problem now that your deployed site is twice as big because it has the 1.0.0 version as well as the one with the qualifier? If you are deploying from eclipse, it should be possible to delete the 1.0.0 version from your site project and/or site.xml and re-deploy the site ... no?

PW


Previous Topic:Test Framework Update Site
Next Topic:Using the same Eclipse application on Linux/Windows/Mac... (was "Headless build on Windows usin
Goto Forum:
  


Current Time: Sun Oct 26 05:14:35 GMT 2014

Powered by FUDForum. Page generated in 0.05207 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software