Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » 0.7.3 does not install
0.7.3 does not install [message #31884] Thu, 14 August 2008 09:37 Go to next message
Eclipse User
Originally posted by: gregor.rosenauer.itsv.at

I have successfully (well, with some hickups when renaming files, but else
ok) used Subversive 0.7.1/Ganymede.
Now for some reason SVN-connectors disappeared and I cannot get them back
(I believe the problems started after installing the SQLExplorer-Plugin,
which I now uninstalled without effect).
I have read through the list and changed the URLs accordingly, but always
get errors that either some dependencies cannot be resolved, or the view
cannot be initialized.

When trying to update via the update sites, I get this:

Cannot complete the request. See the details.
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.svnkit.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.javahl.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.feature.group
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.feature.group
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency: [org.maven.ide.eclipse.feature.feature.group
0.9.5.20080717-1821] requiredCapability:
org.eclipse.equinox.p2.iu/org.maven.ide.components.maven_mod el_edit/[1.0.0.20080717-1819,1.0.0.20080717-1819]
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.javahl.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.javahl.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.javahl.win32.featur e.group
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.svnkit.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.polarion.eclipse.team.svn.conn ector.feature.group/0.0.0
Unsatisfied dependency:
[org.polarion.eclipse.team.svn.connector.svnkit.feature.grou p
2.0.3.I20080814-1500] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.feature.group /[0.7.2.I20080801-1500,1.0.0)

From the archived site I get this, after the install runs through:

An error occurred during provisioning.
Failed to prepare partial IU: [R]org.eclipse.team.svn.core
0.7.3.I20080814-1500.

Please help, or else I have to go back to Subversive...,-)
Re: 0.7.3 does not install [message #31955 is a reply to message #31884] Thu, 14 August 2008 11:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: gregor.rosenauer.itsv.at

[Update] I removed all SVN/Polarion bundles from plugins/ and features/
(although I uninstalled them via p2 inside Eclipse, there were many
packages left), did an eclipse -clean but still face the same problems,
both with the online update sites and the archived site.
Re: 0.7.3 does not install [message #32304 is a reply to message #31955] Mon, 18 August 2008 23:17 Go to previous messageGo to next message
David Muir is currently offline David Muir
Messages: 63
Registered: July 2009
Member
Ganymede's software updates has never worked well for me. Whenever I have
this problem, the easiest solution is to uninstall the plugin in question,
and then reinstall.

That said, I couldn't get 0.7.3 running either. More specifically, the
connectors for 0.7.3.

I think I'll just have to wait until the update in September. Just wasted
3 hours trying to fix this issue...
Re: 0.7.3 does not install [message #32374 is a reply to message #32304] Tue, 19 August 2008 12:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: micky_lee.cyberpowersystems.com.tw

me too, I download all files and installed well, but when I create a new
SVN repository, it told me the following...

SVN: '0x00400006: Validate Repository Location' operation finished with
error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.
Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.


but I download all native JavaHL 1.4.5 and 1.5 include others in
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/

after all updated, the SVN connector still can't use....

I am very sad...
Re: 0.7.3 does not install [message #33933 is a reply to message #32374] Tue, 23 September 2008 10:53 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello micky,

You should install connectors from
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/,
because connectors from
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
are not compatible with SVN Team Provider 0.7.3.
For more details, please, see
http://www.eclipse.org/newsportal/article.php?id=701&gro up=eclipse.technology.subversive#701

"micky" <micky_lee@cyberpowersystems.com.tw> ???????/???????? ? ????????
?????????: news:8ae2a75caa9947fff998fd319935bdbd$1@www.eclipse.org...
> me too, I download all files and installed well, but when I create a new
> SVN repository, it told me the following...
>
> SVN: '0x00400006: Validate Repository Location' operation finished with
> error: Selected SVN connector library is not available or cannot be
> loaded.
> If you selected native JavaHL connector, please check if binaries are
> available or install and select pure Java Subversion connector from the
> plug-in connectors update site.
> If connectors already installed then you can change the selected one at:
> Window->Preferences->Team->SVN->SVN Client.
> Selected SVN connector library is not available or cannot be loaded.
> If you selected native JavaHL connector, please check if binaries are
> available or install and select pure Java Subversion connector from the
> plug-in connectors update site.
> If connectors already installed then you can change the selected one at:
> Window->Preferences->Team->SVN->SVN Client.
>
>
> but I download all native JavaHL 1.4.5 and 1.5 include others in
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
>
> after all updated, the SVN connector still can't use....
>
> I am very sad...
>
Re: 0.7.3 does not install [message #34194 is a reply to message #33933] Thu, 25 September 2008 21:43 Go to previous messageGo to next message
Howard Shen is currently offline Howard Shen
Messages: 1
Registered: July 2009
Junior Member
To Igor:

You said:
"You should install connectors from
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/"

I do not see any connectors on this site. Only the plug-in (and srcs) are
available. I am working in OSX... could this be the problem?

Please advise on where I can find the appropriate connectors. I am trying
to install the plug-in "Subversive SVN Team Provider 0.7.3.I20080814-1500"
from http://download.eclipse.org/technolgy/subversive/0.7/update- site/ as
suggested by Alex.

Thanks!
Re: 0.7.3 does not install [message #34298 is a reply to message #34194] Fri, 26 September 2008 11:37 Go to previous messageGo to next message
Alexei Goncharov is currently offline Alexei Goncharov
Messages: 35
Registered: July 2009
Member
Howard Shen wrote:

> I do not see any connectors on this site. Only the plug-in (and srcs) are
> available. I am working in OSX... could this be the problem?

> Please advise on where I can find the appropriate connectors. I am trying
> to install the plug-in "Subversive SVN Team Provider 0.7.3.I20080814-1500"
> from http://download.eclipse.org/technolgy/subversive/0.7/update- site/ as
> suggested by Alex.

> Thanks!

The URL Igor gave is for 2.0.3 connectors, which are compatible with 0.7.3
Subversive release.

The content of update-site is below. I can see it both through web and
from Eclipse IDE.

"Subversive Connectors Subversive SVN Connectors
org.polarion.eclipse.team.svn.connector - 2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.javahl - 2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.javahl.win32 - 2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.javahl15 - 2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.javahl15.win32 -
2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.svnkit - 2.0.3.I20080814-1500

org.polarion.eclipse.team.svn.connector.svnkit15 - 2.0.3.I20080814-1500

Subversive Connectors Sources Subversive SVN Connectors Sources
org.polarion.eclipse.team.svn.connector.source - 2.0.3.I20080814-1500"

Did you try to restart Eclipse and add this URL again? Remove and then add
this URL?

Best regards, Alexei Goncharov.
Subversive Team.
Re: 0.7.3 does not install [message #34507 is a reply to message #31884] Mon, 29 September 2008 13:48 Go to previous messageGo to next message
Ray Hurst is currently offline Ray Hurst
Messages: 121
Registered: July 2009
Senior Member
Has anybody gotten this to work?

I updated to eclipse-cdt-ganymede-SR1-win32.zip.
Installed:
Subversive SVN Team Provider 0.7.3.I20080814-1500


I installed connnectors into plugin direcotry from this website:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/

The symtoms I get is the SVN window under preferences is blank (does not
show JavaHL connector. Also looks like the polarion connectors are being
refused.
Ray
Re: 0.7.3 does not install [message #34540 is a reply to message #31884] Mon, 29 September 2008 13:50 Go to previous messageGo to next message
Ray Hurst is currently offline Ray Hurst
Messages: 121
Registered: July 2009
Senior Member
Has anybody gotten this to work?

I updated to eclipse-cdt-ganymede-SR1-win32.zip.
Installed:
Subversive SVN Team Provider 0.7.3.I20080814-1500


I installed connnectors into plugin direcotry from this website:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/

The symtoms I get is the SVN window under preferences is blank (does not
show JavaHL connector. Also looks like the polarion connectors are being
refused.
Ray
Re: 0.7.3 does not install [message #34574 is a reply to message #34540] Mon, 29 September 2008 13:53 Go to previous messageGo to next message
Ray Hurst is currently offline Ray Hurst
Messages: 121
Registered: July 2009
Senior Member
Never mind - fourth reinstall works.
Ray

Ray Hurst wrote:
> Has anybody gotten this to work?
>
> I updated to eclipse-cdt-ganymede-SR1-win32.zip.
> Installed:
> Subversive SVN Team Provider 0.7.3.I20080814-1500
>
>
> I installed connnectors into plugin direcotry from this website:
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
>
>
> The symtoms I get is the SVN window under preferences is blank (does not
> show JavaHL connector. Also looks like the polarion connectors are being
> refused.
> Ray
Re: 0.7.3 does not install [message #34745 is a reply to message #34574] Wed, 01 October 2008 22:38 Go to previous message
Neil Lalonde is currently offline Neil Lalonde
Messages: 2
Registered: July 2009
Junior Member
I have only reinstalled twice to try to get this working. I guess I'm
just not trying hard enough?
=P

Any idea what the solution was on the fourth install?
Previous Topic:How to get subversive to work on ubuntu on eclipse 3.4.1
Next Topic:Subversive 0.7.4 release is available
Goto Forum:
  


Current Time: Sat Aug 30 20:33:31 EDT 2014

Powered by FUDForum. Page generated in 0.02138 seconds