Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » No schemas displayed when connecting to DB2 Express-C V9.1
No schemas displayed when connecting to DB2 Express-C V9.1 [message #31524] Mon, 18 June 2007 12:32 Go to next message
JG is currently offline JG
Messages: 51
Registered: July 2009
Member
Hi,

I am just trying the DTP, for the moment only as an alternative to the
cumbersome DB2 CC. I created a driver template using the JCC driver,
created a new "SQL Model JDBC COnnection", Ping works okay. I connect to
the DB (name of DB is "GTS") and try to browse it. However, the "tree"
ends at the "Schemas" node under the "GTS" node representing my
database. No schemas or anything else is shown (there are several
schemas in the DBMS instance, including one named GTS). "Refresh" didn't
work. I also tried different versions (including 1.0 and the latest 1.5
nightly), currently I am using

Eclipse SDK 3.3RC4
EMF/SDO/XSD 2.3.0RC3
GEF 3.3RC3
mdt-uml2 SDK 2.1RC3
Subclipse 1.2

and

DTP SDK 1.5_RC3

Any help appreciated.

Regards

JG
BTW: Postgres works (Re: No schemas displayed when connecting to DB2 Express-C V9.1) [message #31562 is a reply to message #31524] Mon, 18 June 2007 12:40 Go to previous messageGo to next message
JG is currently offline JG
Messages: 51
Registered: July 2009
Member
I just tried connecting to a Postgres server, seems to work fine, so I
guess the problem is no with my DTP installation per se, or is it?
Re: No schemas displayed when connecting to DB2 Express-C V9.1 [message #31704 is a reply to message #31524] Thu, 28 June 2007 18:30 Go to previous messageGo to next message
Eclipse User
Originally posted by: brianf.sybase.com

Hi JG...

Which driver are you using? There are multiple "enablement" plug-ins
available for DB2 variations that might help you out... They're available in
the DTP CVS repository

HEAD
org.eclipse.datatools.enablement
plugins
org.eclipse.datatools.enablement.ibm.db2.*

It appears we currently have DB2 enablement plug-ins for iseries, luw, and
zseries.

Did you try those or try to roll your own driver definition using the
Generic JDBC driver?

Thanks
--Brian Fitzpatrick

"JG" <jguni@gmx.de> wrote in message news:f55u13$bl6$1@build.eclipse.org...
> Hi,
>
> I am just trying the DTP, for the moment only as an alternative to the
> cumbersome DB2 CC. I created a driver template using the JCC driver,
> created a new "SQL Model JDBC COnnection", Ping works okay. I connect to
> the DB (name of DB is "GTS") and try to browse it. However, the "tree"
> ends at the "Schemas" node under the "GTS" node representing my
> database. No schemas or anything else is shown (there are several
> schemas in the DBMS instance, including one named GTS). "Refresh" didn't
> work. I also tried different versions (including 1.0 and the latest 1.5
> nightly), currently I am using
>
> Eclipse SDK 3.3RC4
> EMF/SDO/XSD 2.3.0RC3
> GEF 3.3RC3
> mdt-uml2 SDK 2.1RC3
> Subclipse 1.2
>
> and
>
> DTP SDK 1.5_RC3
>
> Any help appreciated.
>
> Regards
>
> JG
>
Re: No schemas displayed when connecting to DB2 Express-C V9.1 [message #33960 is a reply to message #31524] Fri, 03 August 2007 15:15 Go to previous message
David S. Soleno is currently offline David S. Soleno
Messages: 2
Registered: July 2009
Junior Member
I'm experiencing the same problem. I can connect and retrieve data but the
schema trees are blank. I don't believe it's our db because I can connect,
retrieve data, and see the schema using the same driver in Callisto, JDK
1.4, and Database Explorer. The developer next to me can connect, retrieve
data, and see the schema using the same driver in Europa with Quantum DB.

My environment:
DB2 v7 z/OS
Eclipse Europa
JDK 6
DTP 1.5

These are my 'enablement' plugins for db2
org.eclipse.datatools.enablement.ibm.db2.iseries.dbdefinitio n_1.0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.iseries.profile_1.0 .0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.luw.dbdefinition_1. 0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.luw.profile_1.0.0.2 00706071.jar
org.eclipse.datatools.enablement.ibm.db2.zseries.dbdefinitio n_1.0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.zseries.profile_1.0 .0.200706071.jar

Any help would be appreciated as I would rather not install Quantum DB and
it's a pain to have Callisto open to navigate the schema and then switch
back to Europa to do my development.

"JG" <jguni@gmx.de> wrote in message news:f55u13$bl6$1@build.eclipse.org...
> Hi,
>
> I am just trying the DTP, for the moment only as an alternative to the
> cumbersome DB2 CC. I created a driver template using the JCC driver,
> created a new "SQL Model JDBC COnnection", Ping works okay. I connect to
> the DB (name of DB is "GTS") and try to browse it. However, the "tree"
> ends at the "Schemas" node under the "GTS" node representing my
> database. No schemas or anything else is shown (there are several
> schemas in the DBMS instance, including one named GTS). "Refresh" didn't
> work. I also tried different versions (including 1.0 and the latest 1.5
> nightly), currently I am using
>
> Eclipse SDK 3.3RC4
> EMF/SDO/XSD 2.3.0RC3
> GEF 3.3RC3
> mdt-uml2 SDK 2.1RC3
> Subclipse 1.2
>
> and
>
> DTP SDK 1.5_RC3
>
> Any help appreciated.
>
> Regards
>
> JG
>
BTW: Postgres works (Re: No schemas displayed when connecting to DB2 Express-C V9.1) [message #585952 is a reply to message #31524] Mon, 18 June 2007 12:40 Go to previous message
JG is currently offline JG
Messages: 51
Registered: July 2009
Member
I just tried connecting to a Postgres server, seems to work fine, so I
guess the problem is no with my DTP installation per se, or is it?
Re: No schemas displayed when connecting to DB2 Express-C V9.1 [message #586017 is a reply to message #31524] Thu, 28 June 2007 18:30 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Hi JG...

Which driver are you using? There are multiple "enablement" plug-ins
available for DB2 variations that might help you out... They're available in
the DTP CVS repository

HEAD
org.eclipse.datatools.enablement
plugins
org.eclipse.datatools.enablement.ibm.db2.*

It appears we currently have DB2 enablement plug-ins for iseries, luw, and
zseries.

Did you try those or try to roll your own driver definition using the
Generic JDBC driver?

Thanks
--Brian Fitzpatrick

"JG" <jguni@gmx.de> wrote in message news:f55u13$bl6$1@build.eclipse.org...
> Hi,
>
> I am just trying the DTP, for the moment only as an alternative to the
> cumbersome DB2 CC. I created a driver template using the JCC driver,
> created a new "SQL Model JDBC COnnection", Ping works okay. I connect to
> the DB (name of DB is "GTS") and try to browse it. However, the "tree"
> ends at the "Schemas" node under the "GTS" node representing my
> database. No schemas or anything else is shown (there are several
> schemas in the DBMS instance, including one named GTS). "Refresh" didn't
> work. I also tried different versions (including 1.0 and the latest 1.5
> nightly), currently I am using
>
> Eclipse SDK 3.3RC4
> EMF/SDO/XSD 2.3.0RC3
> GEF 3.3RC3
> mdt-uml2 SDK 2.1RC3
> Subclipse 1.2
>
> and
>
> DTP SDK 1.5_RC3
>
> Any help appreciated.
>
> Regards
>
> JG
>
Re: No schemas displayed when connecting to DB2 Express-C V9.1 [message #587014 is a reply to message #31524] Fri, 03 August 2007 15:15 Go to previous message
David S. Soleno is currently offline David S. Soleno
Messages: 2
Registered: July 2009
Junior Member
I'm experiencing the same problem. I can connect and retrieve data but the
schema trees are blank. I don't believe it's our db because I can connect,
retrieve data, and see the schema using the same driver in Callisto, JDK
1.4, and Database Explorer. The developer next to me can connect, retrieve
data, and see the schema using the same driver in Europa with Quantum DB.

My environment:
DB2 v7 z/OS
Eclipse Europa
JDK 6
DTP 1.5

These are my 'enablement' plugins for db2
org.eclipse.datatools.enablement.ibm.db2.iseries.dbdefinitio n_1.0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.iseries.profile_1.0 .0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.luw.dbdefinition_1. 0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.luw.profile_1.0.0.2 00706071.jar
org.eclipse.datatools.enablement.ibm.db2.zseries.dbdefinitio n_1.0.0.200706071.jar
org.eclipse.datatools.enablement.ibm.db2.zseries.profile_1.0 .0.200706071.jar

Any help would be appreciated as I would rather not install Quantum DB and
it's a pain to have Callisto open to navigate the schema and then switch
back to Europa to do my development.

"JG" <jguni@gmx.de> wrote in message news:f55u13$bl6$1@build.eclipse.org...
> Hi,
>
> I am just trying the DTP, for the moment only as an alternative to the
> cumbersome DB2 CC. I created a driver template using the JCC driver,
> created a new "SQL Model JDBC COnnection", Ping works okay. I connect to
> the DB (name of DB is "GTS") and try to browse it. However, the "tree"
> ends at the "Schemas" node under the "GTS" node representing my
> database. No schemas or anything else is shown (there are several
> schemas in the DBMS instance, including one named GTS). "Refresh" didn't
> work. I also tried different versions (including 1.0 and the latest 1.5
> nightly), currently I am using
>
> Eclipse SDK 3.3RC4
> EMF/SDO/XSD 2.3.0RC3
> GEF 3.3RC3
> mdt-uml2 SDK 2.1RC3
> Subclipse 1.2
>
> and
>
> DTP SDK 1.5_RC3
>
> Any help appreciated.
>
> Regards
>
> JG
>
Previous Topic:50 records returned
Next Topic:RoutineEditor to open different SQL Objects with same name
Goto Forum:
  


Current Time: Wed Sep 24 04:48:58 GMT 2014

Powered by FUDForum. Page generated in 0.02220 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software