Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Subversive Compatibility versions?(What is compatible?)
Subversive Compatibility versions? [message #1619972] Mon, 16 February 2015 23:53 Go to next message
Will Stewart is currently offline Will StewartFriend
Messages: 6
Registered: March 2014
Junior Member
The Subversive instructions say "... you have to select those that are compatible with your SVN server. Follow the standard SVN client-server compatibility notes to select the right connector."

There were no links or any other clues on the installation, page so I started looking through the documentation and haven't uncovered anything yet, so I'm assuming this is something people learn as they become fairly familiar with Eclipse and Subversion. I'm a newbie, so;

1. Need help understanding which connectors are compatible with my Ubuntu Subversion 1.8.8, and
2. Suggest that the words "standard SVN client-server compatibility notes" be hyperlinked to the notes themselves.
Re: Subversive Compatibility versions? [message #1620811 is a reply to message #1619972] Tue, 17 February 2015 12:53 Go to previous messageGo to next message
Will Stewart is currently offline Will StewartFriend
Messages: 6
Registered: March 2014
Junior Member
I still need help understanding which connectors are compatible with my Ubuntu Subversion 1.8.8
Re: Subversive Compatibility versions? [message #1621549 is a reply to message #1620811] Wed, 18 February 2015 00:10 Go to previous messageGo to next message
Will Stewart is currently offline Will StewartFriend
Messages: 6
Registered: March 2014
Junior Member
Ok, I've decided to dive and find out what might work. I loaded the following connectors - do these look right?

Native JavaHL 1.7 Implementation (Optional) 4.1.3.I20150214-1700 org.polarion.eclipse.team.svn.connector.javahl17.feature.group Polarion Software
Subclipse (Required) 1.10.9 org.tigris.subversion.subclipse.feature.group tigris.org
Subclipse Integration for Mylyn 3.x (Optional) 3.0.0 org.tigris.subversion.subclipse.mylyn.feature.group tigris.org
Subversion Client Adapter (Required) 1.10.3 org.tigris.subversion.clientadapter.feature.feature.group tigris.org
Subversion JavaHL Native Library Adapter 1.8.11 org.tigris.subversion.clientadapter.javahl.feature.feature.group tigris.org
Subversion Revision Graph 1.1.1 org.tigris.subversion.subclipse.graph.feature.feature.group tigris.org
Subversive Revision Graph (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.revision.graph.feature.group Eclipse.org
Subversive SVN Connectors 4.1.3.I20150214-1700 org.polarion.eclipse.team.svn.connector.feature.group Polarion Software
Subversive SVN Team Provider 2.0.1.I20140907-1700 org.eclipse.team.svn.feature.group Eclipse.org
Subversive SVN Integration for the Mylyn Project (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.mylyn.feature.group Eclipse.org
Mylyn Context Connector: Eclipse IDE 3.13.0.v20140702-2225 org.eclipse.mylyn.ide_feature.feature.group Eclipse Mylyn
Mylyn Task List 3.13.0.v20140826-1734 org.eclipse.mylyn_feature.feature.group Eclipse Mylyn
Mylyn Task-Focused Interface 3.13.0.v20140819-2236 org.eclipse.mylyn.context_feature.feature.group Eclipse Mylyn
Mylyn Tasks Connector: Bugzilla 3.13.0.v20140830-0030 org.eclipse.mylyn.bugzilla_feature.feature.group Eclipse Mylyn
Subversive SVN Team Provider Sources 2.0.1.I20140907-1700 org.eclipse.team.svn.source.feature.group Eclipse.org
Subversive Revision Graph Sources (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.revision.graph.sources.feature.group Eclipse.org
Subversive SVN Integration for the Mylyn Project Sources (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.mylyn.sources.feature.group Eclipse.org
Subversive SVN JDT Ignore Extensions Sources (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.resource.ignore.rules.jdt.sources.feature.group Eclipse.org
Subversive SVN Team Provider Localization Sources (Optional) 2.0.0.I20140609-1700 org.eclipse.team.svn.nl1.sources.feature.group Eclipse.org
Subversive SVN Team Provider Sources 2.0.1.I20140907-1700 org.eclipse.team.svn.sources.feature.group Eclipse.org
SVNKit 1.8.7 Implementation (Optional) 4.1.2.I20141224-1700 org.polarion.eclipse.team.svn.connector.svnkit18.feature.group Polarion Software
SVNKit Client Adapter (Not required) 1.8.9 org.tigris.subversion.clientadapter.svnkit.feature.feature.group tigris.org

Oddly enough, my repository is showing up twice in Eclipse. And under Eclipse Preferences > Team, SVN shows up twice. Is it because there are more than one connector or set of connectors?

[Updated on: Wed, 18 February 2015 00:15]

Report message to a moderator

Re: Subversive Compatibility versions? [message #1622321 is a reply to message #1621549] Wed, 18 February 2015 12:12 Go to previous messageGo to next message
Will Stewart is currently offline Will StewartFriend
Messages: 6
Registered: March 2014
Junior Member
Hmmm, is this a dead group? Is Subclipse the way to go now? Awfully quiet here...
Re: Subversive Compatibility versions? [message #1645541 is a reply to message #1622321] Mon, 02 March 2015 15:11 Go to previous message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 148
Registered: July 2009
Senior Member
Hello,

I'm sorry for the late reply.
Firstly you should install only one SVN support: Subversive or Subclipse. Secondly, as of compatiblity, it is the best to use SVN 1.7 based connectors with the SVN 1.7 server and the SVN 1.8-based connectors with the SVN 1.8 server. Also there should be a backward compatibility guaranteed and so, you should be able to use SVN 1.8 connectors with the SVN 1.7 servers too. So, in your case the best way to go is to use an SVN 1.8 based connectors (while you can install both of them, iit wouldn't hurt). Also, you need to mind following: SVN Kit based connectors starting SVN 1.7 are a little buggy, while SVN Kit 1.7.x are really slow on big projects, SVN Kit 1.8.x has a lot of unresolved issues. So, it is probably best to give a chance to JavaHL-based connector.
Previous Topic:.settings folder
Next Topic:Lock-modify-unlock procedure implementation with Eclipse and Subversive
Goto Forum:
  


Current Time: Wed Nov 22 16:58:15 GMT 2017

Powered by FUDForum. Page generated in 0.01662 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software