Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Create patch as file - encoding
Create patch as file - encoding [message #1549462] Tue, 06 January 2015 14:50 Go to next message
Holger Brands is currently offline Holger BrandsFriend
Messages: 12
Registered: September 2012
Junior Member
Hello,

I'm using
Eclipse Luna Service Release 1 (4.4.1) with
Subversive Team Provider 2.0.1, Subversive SVN Connectors 4.1.0 and connectors
JavaHL 1.7.9, SvnKit 1.7.13

Having a file with default file encoding on Windows plattform (encoding cp1252)
containing "german umlaute" like äüöß:

When creating a patch from it with JavaHL 1.7.9 as connector, the patch file looks good (it seems to have the same encoding as above).

When creating the same patch from it with SvnKit 1.7.13 as connector, the patch file seems to be created in UTF-8 encoding.

Can you reproduce this issue?
Is this intentional or a bug?

I've found an older, possibly related bug here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=404713

Thanks,
Holger
Re: Create patch as file - encoding [message #1566124 is a reply to message #1549462] Thu, 15 January 2015 17:45 Go to previous message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 148
Registered: July 2009
Senior Member
Earlier (before fixing issue 404713) there was a code in Subversive that always performed conversion to the UTF-8 encoding which was wrong. Now the only moment when Subversive works with encoding is when the patch is placed into the clipboard. Also there is no difference on Subversive's side when creating a patch with JavaHL or SVN Kit. So, I think there is an issue within SVN Kit library.
So, if you need to work with SVN Kit and not JavaHL, you can try SVN Kit 1.8.7 (but please note, that there is a difference in working copy format). Also, you may want to report the issue to SVN Kit team: http://issues.tmatesoft.com/dashboard
Previous Topic:missing osgi bundle on update
Next Topic:.settings folder
Goto Forum:
  


Current Time: Thu Nov 15 14:57:21 GMT 2018

Powered by FUDForum. Page generated in 0.02997 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top