Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » missing osgi bundle on update(Trouble updating to 2.0.3)
missing osgi bundle on update [message #1538482] Wed, 31 December 2014 11:06 Go to next message
Roger Appleby is currently offline Roger ApplebyFriend
Messages: 1
Registered: December 2014
Location: Zanzibar
Junior Member
Environment:
Windows 7 x64, Java 1.7.0_72, Luna 4.4.1
Version: 2.0.1.I20140907-1700
SVN Client: org.eclipse.team.svn.connector.svnkit18 4.1.2.I20141224-1700 SVN/1.8.1 SVNKit/1.8.7 r10376_v20141223_2131

Product: Eclipse 4.4.1.20140925-1820
Installed Features:
org.eclipse.team.svn 2.0.1.I20140907-1700

I ran the update and it failed to find the repository. Many of them, so I went back and selected a single update and the following error occurred:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.team.svn.revision.graph,2.0.3.I20141224-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.revision.graph,2.0.3.I20141224-1700

Looked on the internet and found many issues and "solutions".
I have unchecked the contact all repositories, added the EGit and several other suggestions.

I have tried over the past 5 days, thinking maybe the repository was offline.
nada! This seems to be a recurring theme over the past few releases.

Anyone have any ideas? I am not desperate, but I would like to get this resolved.
I have successfully done other updates and this seems to be limited to specific subversion libraries (I was able to get 2 updates to work) . The team and several of the optional updates are failing.
Re: missing osgi bundle on update [message #1566105 is a reply to message #1538482] Thu, 15 January 2015 17:28 Go to previous message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 148
Registered: July 2009
Senior Member
I do update my Eclipse instance on a regular basis and it works for me without any problem. So, I thought there is a chance that your p2 updates database is broken and that is the reason for this strange behaviour. Please try (as an experiment, at least) installing it into a fresh Eclipse instance and check if it works or not.
Previous Topic:silent delete
Next Topic:Create patch as file - encoding
Goto Forum:
  


Current Time: Sat Nov 18 10:31:29 GMT 2017

Powered by FUDForum. Page generated in 0.01356 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software