Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » waituntil some condition(waituntil is not working everywhere)
waituntil some condition [message #1463155] Thu, 06 November 2014 09:15 Go to next message
Aparajita K is currently offline Aparajita KFriend
Messages: 7
Registered: August 2014
Junior Member
Hi,
I have used waituntil conditions to wait. But it is not working all the time.
sometime it is waiting and some sometime it is not, and my test cases are failing in that case.

Thanks in advance.
Re: waituntil some condition [message #1468025 is a reply to message #1463155] Mon, 10 November 2014 14:14 Go to previous message
Mickael Istria - away until August 14th is currently offline Mickael Istria - away until August 14thFriend
Messages: 833
Registered: July 2009
Location: Grenoble, France
Senior Member

On 11/06/2014 10:15 AM, Aparajita K wrote:
> Hi,
> I have used waituntil conditions to wait. But it is not working all the
> time.
> sometime it is waiting and some sometime it is not, and my test cases
> are failing in that case.

Please provide some examples of failing conditions. I don't see any
reason why waitUntil or waitWhile method would behave "randomly" so I
have me the impression that it may be that your condition doesn't
exactly match what you're actually waiting for.

--
Mickael Istria
My job: http://www.jboss.org/tools
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Previous Topic:wait for the project complete
Next Topic:Anyone knows a way to click on submenus of a view menu?
Goto Forum:
  


Current Time: Sun Nov 18 11:51:44 GMT 2018

Powered by FUDForum. Page generated in 0.01578 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top