Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » "Invalid password or user ID" when connecting to daemon in AIX (Kerberos)(Unable to connect to daemon in AIX.)
"Invalid password or user ID" when connecting to daemon in AIX (Kerberos) [message #1444732] Tue, 14 October 2014 13:30 Go to next message
Alfonso Corona is currently offline Alfonso CoronaFriend
Messages: 2
Registered: October 2014
Junior Member
Hello all,

I'm trying to use RSE to connect to an AIX system which uses Kerberos, thru the DataStore daemon, but I always receive the message "Invalid password or user ID".

I've changed auth.pl replacing the traditional UNIX authentication for a call to a an external program which authenticates the username and password information against Kerberos and the PAM (Pluggable Authentication Module) architecture in AIX: (calling pam_authenticate(),....).

The original auth.pl file contained the following (relevant) lines:

   $pwdIN = <STDIN>;
   chomp($pwdIN);
   @passwdStruct = getpwnam($userIN);
   $passwd=$passwdStruct[1];
   $encryptedPWD = crypt($pwdIN, $passwd);
   if ($passwd eq $encryptedPWD)
   {
      system("su $suOptions $userIN -c '$javaExe -Duser.home=$homeDir -cp $classpath -DA_PLUGIN_PATH=$pathIN -DDSTORE_SPIRIT_ON=true org.eclipse.dstore.core.server.Server $portIN $timeoutIN $ticketIN'");
      1;
   }


And the modified one:

   $pwdIN = <STDIN>;
   chomp($pwdIN);
   $result = system("authenticatePAM " . $userIN . " " . $pwdIN);
   if ($result == 0)
   {
      system("su $suOptions $userIN -c '$javaExe -Duser.home=$homeDir -cp $classpath -DA_PLUGIN_PATH=$pathIN -DDSTORE_SPIRIT_ON=true org.eclipse.dstore.core.server.Server $portIN $timeoutIN $ticketIN'");
      1;
   }


The external program (authenticatePAM) validates the user credentials and when it returns, the variable "result" takes the value "0" and, consequently, the "su" command is executed (btw, "$portIN" is "0"), but in Eclipse I get the "Invalid password or user ID ()" message and the client doesn't connect. However I am able to connect to a running server (server.sh), instead of to the daemon (daemon.pl) (obviously configuring the connection accordingly in Eclipse).

I'm using Eclipse 4.2.2, RSE 3.5, AIX 6.1 TL8.

Any suggestions? Any way to trace the program execution?

Many thanks
Alfonso Corona
Re: "Invalid password or user ID" when connecting to daemon in AIX (Kerberos) [message #1445524 is a reply to message #1444732] Wed, 15 October 2014 15:06 Go to previous message
Alfonso Corona is currently offline Alfonso CoronaFriend
Messages: 2
Registered: October 2014
Junior Member
Problem solved!.

The approach was correct, but the authenticatePAM program's stdout was interfeering with the output from auth.pl and was misleading the logic in ServerLauncher java code.



Previous Topic:RSE error with SSH non-default port
Next Topic:Synchronization error for project *: Invalid packet line header - EGit/RSE bug?
Goto Forum:
  


Current Time: Sat Sep 22 13:47:56 GMT 2018

Powered by FUDForum. Page generated in 0.01598 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top