Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Problems with LuaDoc View(Problems with LuaDoc View (and autocompletion window) while running linux, )
Problems with LuaDoc View [message #1442017] Fri, 10 October 2014 13:58 Go to next message
Karim Mreisi is currently offline Karim MreisiFriend
Messages: 3
Registered: October 2014
Junior Member
Hello Everybody,

I have problems using the Lua Development Tools plugins while using debian + KDE. I tried different versions of Eclipse and can't get the development view correctly working.

A picture of Windows 8.1 with Eclipse Lua Development Tools installed,
here the LuaDoc view show correctly formatted the contend:

index.php/fa/19464/0/

A picture of Linux Debian + KDE with Eclipse Lua Development Tools installed,
here the LuaDoc view shows only the luadoc as something like plain text:

index.php/fa/19465/0/

what I have to do to get the Linux version looks like the Windows version.

Thanks for help Smile

greetings.
Re: Problems with LuaDoc View [message #1442114 is a reply to message #1442017] Fri, 10 October 2014 16:34 Go to previous messageGo to next message
Kevin KIN-FOO is currently offline Kevin KIN-FOOFriend
Messages: 58
Registered: January 2010
Member
Hi Karim,

I think this is a Gtk / KDE integration issue.
Even if I am using KDE with Opensuse without issue.

index.php/fa/19466/0/

Do you have gtk2-engine-oxygen installed?

Kevin
  • Attachment: ldt.png
    (Size: 97.66KB, Downloaded 341 times)
Re: Problems with LuaDoc View [message #1443445 is a reply to message #1442114] Sun, 12 October 2014 19:11 Go to previous messageGo to next message
Karim Mreisi is currently offline Karim MreisiFriend
Messages: 3
Registered: October 2014
Junior Member
Thanks for your reply Smile

yes gtk2-engine-oxygen is installed.

Today i made some more tests with different linux desktopts. LXDE/OpenBox and have had the same issues. (deleted the hole eclipse configuration and workspace before the tests)

Some more ideas? Smile

more information about my system:
vmware
linux debian jessy (testing)
kde/LXDE/OpenBox
openjdk 7
Re: Problems with LuaDoc View [message #1443982 is a reply to message #1443445] Mon, 13 October 2014 13:59 Go to previous messageGo to next message
Marc Aubry is currently offline Marc AubryFriend
Messages: 86
Registered: August 2012
Member
Using Ubuntu under XFCE I had some trouble with eclipse and GTK3.

According to this bug, the current version of Eclipse use GTK3 per default :
https://bugs.eclipse.org/bugs/show_bug.cgi?id=420180

You should try to force Eclipse to use GTK2 by settings environments variables SWT_GTK3 to 0 and SWT_GTK2 to 1 before launching Eclipse.

Marc


[Updated on: Mon, 13 October 2014 13:59]

Report message to a moderator

Re: Problems with LuaDoc View [message #1444726 is a reply to message #1443982] Tue, 14 October 2014 13:18 Go to previous message
Karim Mreisi is currently offline Karim MreisiFriend
Messages: 3
Registered: October 2014
Junior Member
Ok I have tried mostly everything to get it work with my debian configuration and have had the same issues with kubuntu. The first fix for me is now to use LinuxMint KDE (no idea whats here working better). On weekend I'll look for the difference and post it here. Smile

Thanks for your help Smile
Previous Topic:Windows 64 or 32 bit
Next Topic:LDT and Classes
Goto Forum:
  


Current Time: Mon Sep 24 01:23:08 GMT 2018

Powered by FUDForum. Page generated in 0.02068 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top