Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » Debugger with launch script
Debugger with launch script [message #1417177] Wed, 30 July 2014 14:34 Go to next message
Bob DeeBee is currently offline Bob DeeBeeFriend
Messages: 4
Registered: July 2014
Junior Member
Is there any way to use debugger after launching Lua/Löve from a .cmd script?

My situation: I set up a simple External Run Configuration by using the Program template; setting the Location to a Windows batch located in a .cmd file and the Working directory to its location. This script has a bunch of custom path settings, executable calls, and ultimately calls the Löve interpreter. Everything works fine, but now how to actually run the debugger?

Alternatively, would it be easier to reconfigure the project, setting the environment up within Eclipse and then manually setting up Löve as an external interpreter? I know that it is not officially supported, but people seem to have gotten it to. The instructions aren't completely clear and I haven't been successful.
Re: Debugger with launch script [message #1417182 is a reply to message #1417177] Fri, 01 August 2014 14:27 Go to previous messageGo to next message
Marc Aubry is currently offline Marc AubryFriend
Messages: 76
Registered: July 2009
Member
Hi Bob,

To debug an remote/external Lua please refer to Attach application debug configuration:
https://wiki.eclipse.org/LDT/User_Area/User_Guides/User_Guide_1.2#Attach_Debug

To set your executable as a Lua interpreter see interpreters in LDT:
https://wiki.eclipse.org/LDT/User_Area/User_Guides/User_Guide_1.2#Interpreters

Please be aware that debugging using interpreters through LDT is easier than doing "Attach application debug".

Marc
Re: Debugger with launch script [message #1417183 is a reply to message #1417182] Fri, 01 August 2014 14:34 Go to previous message
Bob DeeBee is currently offline Bob DeeBeeFriend
Messages: 4
Registered: July 2014
Junior Member
Thanks. I'll play with it. Ultimately I want the debugger to work with LoveFrames.
Previous Topic:Unable to Launch
Next Topic:Change keywords
Goto Forum:
  


Current Time: Tue Sep 25 22:33:28 GMT 2018

Powered by FUDForum. Page generated in 0.02132 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top