Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » Re: Autocomplete in eclipse with MOAI Lua
Re: Autocomplete in eclipse with MOAI Lua [message #1417087] Tue, 18 February 2014 10:25
Marc Aubry is currently offline Marc AubryFriend
Messages: 76
Registered: July 2009
Member
Hi Eric,

It seems you have set two Execution Environment(EE) for your project. The problem is that only the global.lua file from the first EE is take in account for auto-completion.

In fact, only one EE is expected by project, I will try to explain:

An EE represent the runtime environment where your Lua gonna run. In your case as your are developing a MOAI application expected to run with the MOAI interpreter, you should had only the MOAI EE associated to your project. Having two Execution Environment on a project means the project can run on both Lua and MOAI interpreters which is wrong. So if the MOAI interpreter provide standard Lua libraries such as "math", you should include them in the MOAI EE instead to having two EE.
I hope it's clear.

I have file a bug on the subject: https://bugs.eclipse.org/bugs/show_bug.cgi?id=428369

PS: In the rockspec the name shouldn't contain the version, you may set "moai" instead of "moai-1.4".
Previous Topic:ldt debugger.lua in android or IOS platform
Next Topic:LDT with goto support
Goto Forum:
  


Current Time: Sun Sep 23 21:31:41 GMT 2018

Powered by FUDForum. Page generated in 0.01540 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top