Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » Lua Modules
Lua Modules [message #1417082] Wed, 12 February 2014 02:59 Go to next message
Zack Price is currently offline Zack PriceFriend
Messages: 2
Registered: February 2014
Junior Member
I made a module script and then I attempted to link it with the line:

exct = require "Executable Functions"

and then I get the error message of:

Exception in thread "main" com.naef.jnlua.LuaRuntimeException: ...product-win32.win32.x86\workspace\Project\script.lua:4: module 'Executable Functions' not found:
no field package.preload['Executable Functions']
no file '.\Executable Functions.dll'
no file '.\Executable Functions51.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\Executable Functions.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\Executable Functions51.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\clibs\Executable Functions.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\clibs\Executable Functions51.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\loadall.dll'
no file 'C:\Program Files (x86)\Java\jre7\bin\clibs\loadall.dll'
at com.naef.jnlua.LuaState.lua_pcall(Native Method)
at com.naef.jnlua.LuaState.call(LuaState.java:555)
at org.eclipse.koneki.ldt.support.lua51.internal.interpreter.JNLua51Launcher.run(JNLua51Launcher.java:122)
at org.eclipse.koneki.ldt.support.lua51.internal.interpreter.JNLua51Launcher.main(JNLua51Launcher.java:137)


Help?
Re: Lua Modules [message #1417084 is a reply to message #1417082] Wed, 12 February 2014 14:37 Go to previous messageGo to next message
Simon Bernard is currently offline Simon BernardFriend
Messages: 339
Registered: July 2009
Senior Member
It's weird, your lua_path seems to not be set correctly, this looks like a bug...
Could you tell me which version of LDT did you use ? on which platform ? where is your Executable Functions script ? where is your "exct = require "Executable Functions"" code ?

Thx
Re: Lua Modules [message #1500278 is a reply to message #1417084] Fri, 05 December 2014 21:06 Go to previous message
Krista Hill is currently offline Krista HillFriend
Messages: 5
Registered: December 2014
Junior Member
Hi, I'm also struggling in this area. I'm guessing that there is a 32-bit/64-bit Windows conflict.

Are you on Win64? When you compiled against Lua, which did you use? I suspect that Lua for Windows is all 32-bit code.
Previous Topic:LDT debugger error
Next Topic:Autocompletion for external API
Goto Forum:
  


Current Time: Sat Nov 17 04:13:23 GMT 2018

Powered by FUDForum. Page generated in 0.02735 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top