Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » LUA development tools not running in order
LUA development tools not running in order [message #1416807] Tue, 26 February 2013 11:07 Go to next message
austin anderson is currently offline austin andersonFriend
Messages: 2
Registered: February 2013
Junior Member
Hello people of the internet
i recently got started working with lua, and the LuaDevelopmentTools are a big help. the only problem is, it doesn't run in the right order whenever I use io.read. whenever I use io.read, the program asks for input before any of the other code runs.

i tried a simple code, and it wouldn't work:

print("Enter a Number ")
x = io.read()
print(Your Number is: " .. x)


i even tried it using io.write instead of print

thanks for any help!

P.S: i don't know if i posted this on the right forum, so sorry if I did
Re: LUA development tools not running in order [message #1416809 is a reply to message #1416807] Tue, 26 February 2013 12:55 Go to previous message
Marc Aubry is currently offline Marc AubryFriend
Messages: 76
Registered: July 2009
Member
Hi Austin,

It's the right forum :)

LDT execute code in the right order, it's just that your stdout buffer policy is not configurate for your need.

More information on this topic: http://www.eclipse.org/forums/index.php/mv/msg/453033/1009733/#msg_1009733

Marc
Previous Topic:LDT doesn't show up (ubuntu)
Next Topic:Help understanding code assist
Goto Forum:
  


Current Time: Fri Nov 16 23:10:28 GMT 2018

Powered by FUDForum. Page generated in 0.02056 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top