Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » Can't update Nightly build 0.9.0.201209141432
Can't update Nightly build 0.9.0.201209141432 [message #1416656] Mon, 17 September 2012 08:32 Go to next message
Cheyi Lin is currently offline Cheyi LinFriend
Messages: 16
Registered: June 2012
Junior Member
Hi,

I can't update the latest nightly build LDT 0.9.0.201209141432


Cannot complete the install because of a conflicting dependency.
Software being installed: Lua Development Tools (Incubation) 0.9.0.201209141432 (org.eclipse.koneki.ldt.feature.group 0.9.0.201209141432)
Software currently installed: Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813 (epp.package.cpp 1.4.2.20120213-0813)
Only one of the following can be installed at once:
Expression Language 3.4.300.v20110228 (org.eclipse.core.expressions 3.4.300.v20110228)
Expression Language 3.4.200.v20100505 (org.eclipse.core.expressions 3.4.200.v20100505)
Expression Language 3.4.400.v20120523-2004 (org.eclipse.core.expressions 3.4.400.v20120523-2004)
Cannot satisfy dependency:
From: Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813 (epp.package.cpp 1.4.2.20120213-0813)
To: org.eclipse.epp.package.cpp.feature.feature.group [1.4.2.20120213-0813]
Cannot satisfy dependency:
From: EPP CPP Feature 1.4.2.20120213-0813 (org.eclipse.epp.package.cpp.feature.feature.group 1.4.2.20120213-0813)
To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
Cannot satisfy dependency:
From: Lua Development Tools Debug UI (Incubation) 0.9.0.201209141432 (org.eclipse.koneki.ldt.debug.ui 0.9.0.201209141432)
To: bundle org.eclipse.core.expressions 3.4.400
Cannot satisfy dependency:
From: Lua Development Tools (Incubation) 0.9.0.201209141432 (org.eclipse.koneki.ldt.feature.group 0.9.0.201209141432)
To: org.eclipse.koneki.ldt.debug.ui [0.9.0.201209141432]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
To: org.eclipse.rcp.feature.group [3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272]
Cannot satisfy dependency:
From: Eclipse RCP 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272 (org.eclipse.rcp.feature.group 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272)
To: org.eclipse.core.expressions [3.4.300.v20110228]


It seems to be because the "Expression Language 3.4.400.v20120523-2004" supports Eclipse 4.2+ (Juno) ?
I plan to stay with Eclipse 3.7.2 (Indigo) for a while.


Cheers,
Cheyi
Re: Can't update Nightly build 0.9.0.201209141432 [message #1416660 is a reply to message #1416656] Mon, 17 September 2012 16:30 Go to previous messageGo to next message
Marc Aubry is currently offline Marc AubryFriend
Messages: 76
Registered: July 2009
Member
Hi Cheyi,

Thanks for reporting the bug.

It seems that some code committed lately have some hard dependencies to Eclipse Juno.
I have open a bug about that: https://bugs.eclipse.org/bugs/show_bug.cgi?id=389745
It will be fixed in upcomming days (follow the bug to have the latest update).

Marc
Re: Can't update Nightly build 0.9.0.201209141432 [message #1416661 is a reply to message #1416660] Tue, 18 September 2012 01:34 Go to previous message
Cheyi Lin is currently offline Cheyi LinFriend
Messages: 16
Registered: June 2012
Junior Member
Thank you Marc.

Cheyi
Previous Topic:How to setup LTD with own executable?
Next Topic:Interpreter arguments
Goto Forum:
  


Current Time: Tue Sep 18 20:59:15 GMT 2018

Powered by FUDForum. Page generated in 0.01392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top