Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » No Outline Information for Lua Files
No Outline Information for Lua Files [message #1416592] Sun, 12 August 2012 19:03 Go to next message
Rob Dixon is currently offline Rob DixonFriend
Messages: 6
Registered: August 2012
Junior Member
I have installed the Lua Development Tools, both as a stand-alone IDE and as a plug-in for my main Eclipse application, but am unable to get it to display any Outline information for the .lua files in my project.

This is doubly odd as the project is a mix of Lua and XML, and the XML files are outlined properly despite there being no XML editor on offer.

I am quite willing to believe that the problem is my own stupidity, but I have been scrathcing my head over this on and off for days now and can't progress.

I'm running on Windows 7 64-bit. Is there something obvious I'm missing?
Re: No Outline Information for Lua Files [message #1416593 is a reply to message #1416592] Sun, 12 August 2012 19:13 Go to previous messageGo to next message
Eclipse UserFriend
Hi Rob

Care sharing an example of the files you're trying to edit?
You say they are a mix of XML and Lua... do they have a .xml file extension? If so, they are most likely opened by default by the XML editor in Eclipse, not the Lua one...
Re: No Outline Information for Lua Files [message #1416594 is a reply to message #1416593] Sun, 12 August 2012 19:59 Go to previous messageGo to next message
Rob Dixon is currently offline Rob DixonFriend
Messages: 6
Registered: August 2012
Junior Member
They're pretty standard Lua and XML. I didn't mean to imply that the syntaxes were mixed within a file - there are some XML files named *.xml and some Lua files named *.lua. The syntax colouring is working fine, I just have a blank outline
Re: No Outline Information for Lua Files [message #1416595 is a reply to message #1416594] Sun, 12 August 2012 20:06 Go to previous messageGo to next message
Rob Dixon is currently offline Rob DixonFriend
Messages: 6
Registered: August 2012
Junior Member
More information: the stand-alone installation doesn't syntax colour the XML and displays An outline is not available in the outline frame, which is greyed.

However the Lua files are syntax coloured and the outline frame it white with no message, presumably meaning that it can show an outline but there's nothing to show. Also, when I try to use 'Open Declaration' on an identifier it pings mw and does nothing. I'm making sure to use global variables to test this.
Re: No Outline Information for Lua Files [message #1416601 is a reply to message #1416595] Tue, 14 August 2012 15:11 Go to previous message
Marc Aubry is currently offline Marc AubryFriend
Messages: 76
Registered: July 2009
Member
Hi Rob,

Unfortunately, the current outline is quite limited. Only two things are handled by the outline :

* first level local variables and functions ("first level" means locals that have file scope)
* Any module, function and types commented using http://wiki.eclipse.org/Koneki/LDT/Technical_Documentation/Documentation_Language

If you don't have neither of this, your outline must be empty.
Previous Topic:LDT and Lua Inspect
Next Topic:Code Assistant doesn't work with networked sources?
Goto Forum:
  


Current Time: Sun Sep 23 06:04:34 GMT 2018

Powered by FUDForum. Page generated in 0.02255 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top