Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Koneki » The Selection cannot be launched, and there are no recent launches
The Selection cannot be launched, and there are no recent launches [message #1416331] Wed, 22 February 2012 20:21 Go to next message
Thijs Schreijer is currently offline Thijs SchreijerFriend
Messages: 7
Registered: February 2012
Junior Member

Just installed the standalone version, 32 bit on Win XP (also have Lua for windows installed).

Created a new project and added a simple "hello world" print statement. When clicking run or debug, I get the error; "The Selection cannot be launched, and there are no recent launches"

This is my first Eclipse experience, I tried googling it, but didn't manage to solve it.

Any help is appreciated.
Re: The Selection cannot be launched, and there are no recent launches [message #1416332 is a reply to message #1416331] Wed, 22 February 2012 22:49 Go to previous messageGo to next message
Eclipse UserFriend
Hi Thijs,
You may want to have a look at http://www.eclipse.org/forums/index.php/t/273959/ . Unfortunately, at the moment we don't provide a way to run Lua applications from the IDE. I understand that it would be an important feature, and it is indeed in our plan to support it. It is simply somtehing that we didn't decide to focus on at first.
In the topic I just mentioned, you'll find an explanation about a workaround based on external launch configurations that you could use (see also http://mwebhack.blogspot.com/2012/01/lua-development-tools-koneki-ide-based.html which may be of help to you to set it up).

HTH
Re: The Selection cannot be launched, and there are no recent launches [message #1416338 is a reply to message #1416332] Fri, 24 February 2012 22:29 Go to previous messageGo to next message
Thijs Schreijer is currently offline Thijs SchreijerFriend
Messages: 7
Registered: February 2012
Junior Member

Thanks for your help. That put me on the right track.

I created a similar but different solution, seems to work but with some quirks still. Unfortunately I cannot post any links here, but you can find it on my blog, through my homepage (see my profile on this forum) and then search on tag 'Lua' or 'Koneki'.
Re: The Selection cannot be launched, and there are no recent launches [message #1416341 is a reply to message #1416332] Fri, 24 February 2012 22:39 Go to previous messageGo to next message
Thijs Schreijer is currently offline Thijs SchreijerFriend
Messages: 7
Registered: February 2012
Junior Member

Thanks that helped get me in the right direction.

Solved it slightly different, unfortunately I cannot post any links here. So to get to the 'how-to' I created, go to my homepage (see my profile), and select the 'Lua' or 'Koneki' tag.
Re: The Selection cannot be launched, and there are no recent launches [message #1416342 is a reply to message #1416341] Fri, 24 February 2012 23:09 Go to previous messageGo to next message
Eclipse UserFriend
Thank you, Thijs! And thanks for the kind words on the Lua mailing list too :)
This is a very detailed blog post, which wil be helpful for all the people wanting to easily launch their scripts.
Hopefuly we should provide a launch configuration in the next few months.
Re: The Selection cannot be launched, and there are no recent launches [message #1416367 is a reply to message #1416338] Wed, 28 March 2012 17:50 Go to previous messageGo to next message
Dragan Vidanovic is currently offline Dragan VidanovicFriend
Messages: 4
Registered: March 2012
Junior Member
Thanks for posting this.
Is it possible to make pictures with little bit better resolution? These are barely visible.
Re: The Selection cannot be launched, and there are no recent launches [message #1416368 is a reply to message #1416367] Wed, 28 March 2012 18:00 Go to previous message
Thijs Schreijer is currently offline Thijs SchreijerFriend
Messages: 7
Registered: February 2012
Junior Member

just click on them :)
Previous Topic:Code assistance for 3rd party libs
Next Topic:Some questions of LDT on MacOSX
Goto Forum:
  


Current Time: Sat Oct 20 03:55:59 GMT 2018

Powered by FUDForum. Page generated in 0.02988 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top