Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Linux Tools Project » Gcov .c annotation failure(Gcov integration plugin will not create color codes for basic C)
Gcov .c annotation failure [message #1403023] Sun, 20 July 2014 05:53 Go to next message
Jeff Hopkins is currently offline Jeff HopkinsFriend
Messages: 5
Registered: July 2014
Junior Member
I just learned of the Linux Tools project. I downloaded the 64-bit Eclipse Luna 4.4.0 CDT version on a 64-bit Scientific Linux box. I added --coverage to the compile and link lines and was immediately able to generate and see the coverage report and line highlighting for the created-by-eclipse "hello world" C++ project.

When I tried the same procedure with the created-by-eclipse "hello world" C project, I could get the coverage report view, but when I click on the c-file from the report, I get an error:

Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
java.lang.ArrayIndexOutOfBoundsException: 3
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModel.createAnnotations(GcovAnnotationModel.java:216)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModel.updateAnnotations(GcovAnnotationModel.java:139)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModel.<init>(GcovAnnotationModel.java:83)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModel.attach(GcovAnnotationModel.java:106)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModelTracker.annotateCEditor(GcovAnnotationModelTracker.java:157)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModelTracker.access$1(GcovAnnotationModelTracker.java:149)
at org.eclipse.linuxtools.internal.gcov.view.annotatedsource.GcovAnnotationModelTracker$2.partOpened(GcovAnnotationModelTracker.java:76)
at org.eclipse.ui.internal.PartService$10.run(PartService.java:201)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.PartService.partOpened(PartService.java:198)
...etc.

I tried in a new workspace with the same results. Is it something I'm doing? Since this is an unadulterated new installation using the eclipse, new "hello world" C-project, I can't see what I might have introduced into the process. I'm left wondering if there is something missing on my Linux box, but it is working for the C++ project.

Any ideas?
Re: Gcov .c annotation failure [message #1403142 is a reply to message #1403023] Mon, 21 July 2014 16:51 Go to previous messageGo to next message
Roland Grunberg is currently offline Roland GrunbergFriend
Messages: 27
Registered: December 2009
Junior Member
Hi Jeff,

This is a bug in the Gcov Integration plugin that was fixed a little while ago and should be present in our nightly builds.
Could you try adding the Nightly Builds site (http://download.eclipse.org/linuxtools/updates-nightly) to your list of available software repositories, and then try updating just the Gcov Integration plugin. That should resolve the issue.
Re: Gcov .c annotation failure [message #1403309 is a reply to message #1403142] Tue, 22 July 2014 20:14 Go to previous message
Jeff Hopkins is currently offline Jeff HopkinsFriend
Messages: 5
Registered: July 2014
Junior Member
Thanks, Roland,

Whatever the team did fixed it. I was able to seamlessly update and it immediately worked.
Previous Topic:valgrind and PTP interaction
Next Topic:RPM package signing with Specfile Editor
Goto Forum:
  


Current Time: Thu Nov 15 00:32:21 GMT 2018

Powered by FUDForum. Page generated in 0.01758 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top