Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » Eclipse does not save passwords for remote systems
Eclipse does not save passwords for remote systems [message #1385998] Thu, 12 June 2014 19:53 Go to next message
Ben Johnson is currently offline Ben JohnsonFriend
Messages: 23
Registered: March 2012
Junior Member
I use SSH keys to authenticate to a number of different servers that I have created in Eclipse's Remote System Explorer (RSE) facility.

Historically, when I add a new server and connect to it via SSH, I am prompted to authenticate. I specify the appropriate username, leave the password field blank, and check the box to "Remember password". This has worked well for me, and I am never prompted to re-enter the password again (which I want left blank).

But recently -- sometime since upgrading to Kepler -- I have found that Eclipse no longer remembers the username and blank password that I specify for these systems.

I have confirmed that even when I authenticate successfully Eclipse will not remember the password, whether the password is blank or not.

I've scoured the Internet and I can't find any mention of this behavior. Might anyone have a suggestion with regard to debugging this problem? Perhaps something is corrupted and preventing me from using Eclipse's password storage mechanism.

Version info:

Eclipse Standard/SDK

Version: Kepler Service Release 2
Build id: 20140224-0627

[Updated on: Thu, 12 June 2014 19:54]

Report message to a moderator

Re: Eclipse does not save passwords for remote systems [message #1386833 is a reply to message #1385998] Sat, 21 June 2014 04:45 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 716
Registered: July 2009
Senior Member
On 06/12/2014 03:53 PM, Ben Johnson wrote:
> I use SSH keys to authenticate to a number of different servers that I
> have created in Eclipse's Remote System Explorer (RSE) facility.
>
> Historically, when I add a new server and connect to it via SSH, I am
> prompted to authenticate. I specify the appropriate username, leave
> the password field blank, and check the box to "Remember password".
> This has worked well for me, and I am never prompted to re-enter the
> password again (which I want left blank).
>
> But recently -- sometime since upgrading to Kepler -- I have found
> that Eclipse no longer remembers the username and blank password that
> I specify for these systems.
>
> I have confirmed that Eclipse will not remember the password whether
> it is blank or not.
>
This "works for me". Actually, I don't click to remember password, I
just leave it blank and don't check the box. The second time, I am not
prompted.
I do sometimes, when starting fresh on Windows, I forget to tell it
where to find my SSH keys and "known hosts" (since, it's not in the
assumed default location, but under 'cygwin', in my case).

If your SSH key location under preferences is correct, I'll suggest one
other thing ... if you say to "save password", it will create some
"secured storage" under your home directory, under a directory named
".eclipse". You might try removing that (i.e. renaming, in case you want
it back) and just not check "save password" -- perhaps Kepler was
"improved" to take you literally at your word, there? In the case where
you provide it, and you say it still "doesn't remember it" ... was it
the correct password, and you successfully logged in/connected? (Not
sure about RSE, but many such tools only "remember" something after
success). So, I'd be surprised if that didn't work, if you successfully
connected. I think the reason it doesn't prompt the second time is not
that a blank password was saved, but that it remembers "the last thing
that was successful" and tries that first.

If you exhaust all options and open a bug, but sure to say what
operating system you are on. (I've used it on Windows and Linux)

Hope this gives you "hope" that it does indeed work and some ideas of
things to try.

Good luck.
Re: Eclipse does not save passwords for remote systems [message #1386894 is a reply to message #1386833] Sun, 22 June 2014 16:16 Go to previous messageGo to next message
Ben Johnson is currently offline Ben JohnsonFriend
Messages: 23
Registered: March 2012
Junior Member
David, thanks for the reply! I really appreciate it.

The SSH key location is correct, as evidenced by the fact that when I click "OK" on the "Enter Password" dialog I am logged-in successfully.

With Eclipse closed, I renamed the ".eclipse" directory in my home directory. Next, I started Eclipse, then attempted to connect to a remote server in RSE. As usual, I left the password field blank (and "Save password" unchecked, per your advice, although I don't think it matters either way in this particular context). I was authenticated and connected successfully.

At this point, I looked in my home directory and somewhat surprisingly, the ".eclipse" directory still had not been recreated. (Maybe this is part of the problem?)

Next, I exited Eclipse and started it again, repeating the procedure. Not surprisingly, Eclipse is still prompting me for my credentials every time I connect to a remote server in RSE.

And the ".eclipse" directory still has not been recreated.

Any other ideas?

EDIT TO ADD:

I even created a new workspace and the same exact problem occurs.

And still no newly-created ".eclipse" directory in my Windows profile's home directory.

I'm about to completely re-download Eclipse and see if the same thing occurs. If it does, I'll open a bug report.

For what it's worth, the same thing happens on both my home and work computers; it's not unique to one installation.

I'll report back with the results.

EDIT TO ADD:

I decided to try one more thing before starting from scratch. In Eclipse's Preferences, I went to General -> Security -> Secure Storage. On the Contents tab, the "Storage location" is "C:\Users\Me\.eclipse\org.eclipse.equinox.security\secure_storage", which is "correct" in as much as that is my Windows profile's home directory. This is the same location in which I renamed the ".eclipse" directory, above.

I clicked the "Delete" button in this view and was asked if to restart Eclipse; I said "Yes". This step actually caused the ".eclipse" directory to be created anew -- but the hope was false. I tried connecting to a remote server over SSH via RSE and was prompted to login. I entered the correct username and hit "OK", and was authenticated and connected successfully. Then I restarted Eclipse only to have it prompt me to log in to access the SSH resource again. So frustrating.

For what it's worth, a) the "C:\Users\Me\.eclipse\org.eclipse.equinox.security\secure_storage" is completely empty, and b) when I click on each of the nodes in the General -> Security -> Secure Storage preferences dialog, the "Values associated with the selected node" area of the view is completely blank, which implies that Secure Storage is not working at all.

This is on Windows 8.1, in the event that it's relevant. Maybe there is something about Eclipse's Secure Storage implementation that is lacking or broken in 8.1.

Exasperated at this point. Sad

[Updated on: Sun, 22 June 2014 16:42]

Report message to a moderator

Re: Eclipse does not save passwords for remote systems [message #1386983 is a reply to message #1386894] Mon, 23 June 2014 11:58 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 716
Registered: July 2009
Senior Member
On 06/22/2014 12:16 PM, Ben Johnson wrote:

I do not have any other ideas, but will clear up a few questions you had
.... maybe that'll help you think of something else (or, help when
opening a bug).

> The SSH key location is correct, as evidenced by the fact that when I
> click "OK" on the "Enter Password" dialog I am logged-in successfully.
>

Probably, but best not to count on "behavior" as evidence of "correct
setting". I'm sure you literally checked though.


> With Eclipse closed, I renamed the ".eclipse" directory in my home
> directory. Next, I started Eclipse, then attempted to connect to a
> remote server in RSE. As usual, I left the password field blank (and
> "Save password" unchecked, per your advice, although I don't think it
> matters either way in this particular context). I was authenticated
> and connected successfully.
>

Authenticated without a password. The first time, but not subsequent
times? Strange indeed.

> At this point, I looked in my home directory and somewhat
> surprisingly, the ".eclipse" directory still had not been recreated.
> (Maybe this is part of the problem?)
No, unlikely this is a problem. The "secure storage area" is created
only if you store something in it (such as a password, blank or not) ...
otherwise there is no reason to create it.

> Next, I exited Eclipse and started it again, repeating the procedure.
> Not surprisingly, Eclipse is still prompting me for my credentials
> every time I connect to a remote server in RSE.
>
Prompts you, you enter nothing, click ok, and you login correctly?
Sounds like "RSE" is simply not remembering "last successful login
method". Not sure why it works for me, but not you. Perhaps related to
OS used? (don't think you ever said which you use). Don't recall if you
said, but if you haven't tried yet, you'll want to try with a completely
fresh install, and completely fresh workspace.

Not to mention, someone actually from the project may say if this was an
intentional change, or something. I'm "just a user" and don't have any
insight into the code.

Good luck.
Re: Eclipse does not save passwords for remote systems [message #1393289 is a reply to message #1386983] Thu, 03 July 2014 15:04 Go to previous messageGo to next message
Ben Johnson is currently offline Ben JohnsonFriend
Messages: 23
Registered: March 2012
Junior Member
David Williams wrote on Mon, 23 June 2014 07:58
On 06/22/2014 12:16 PM, Ben Johnson wrote:

I do not have any other ideas, but will clear up a few questions you had
.... maybe that'll help you think of something else (or, help when
opening a bug).

> The SSH key location is correct, as evidenced by the fact that when I
> click "OK" on the "Enter Password" dialog I am logged-in successfully.
>

Probably, but best not to count on "behavior" as evidence of "correct
setting". I'm sure you literally checked though.


These key files exist in only one location on my computer. If I'm able to log into the remote server via SSH without entering a password, then I simply must assume that these keys are accessible to and being checked by Eclipse.

But just to eliminate the possibility that I'm somehow logging into my secure, remote machines without the correct key and no password (or perhaps a saved yet for whatever reason "invisible" secure password manager entry), I did check the preferences dialog, and the "SSH2 home" directory is indeed correct.

David Williams wrote on Mon, 23 June 2014 07:58

> With Eclipse closed, I renamed the ".eclipse" directory in my home
> directory. Next, I started Eclipse, then attempted to connect to a
> remote server in RSE. As usual, I left the password field blank (and
> "Save password" unchecked, per your advice, although I don't think it
> matters either way in this particular context). I was authenticated
> and connected successfully.
>

Authenticated without a password. The first time, but not subsequent
times? Strange indeed.


To be clear, I never authenticate to the remote systems in question with a password. So when I say "I left the password field blank ... I was authenticated and connected successfully", I mean that I am leaving the password field blank so that Eclipse will check my SSH keys, which it does, without issue.

The problem here is that Eclipse will never remember that I want to authenticate with SSH, instead of a password, for any given host in RSE. This is annoying because I have to "hit OK" every time I attempt to connect to a remote host.

Again, I never had to do this before. Something changed recently, and it could very well have been the move from Windows 8 to 8.1. It's entirely possible that something in 8.1 breaks Eclipse's secure password storage facility.

But let's continue; reading ahead, it looks as though you come to the same conclusion.

David Williams wrote on Mon, 23 June 2014 07:58

> At this point, I looked in my home directory and somewhat
> surprisingly, the ".eclipse" directory still had not been recreated.
> (Maybe this is part of the problem?)
No, unlikely this is a problem. The "secure storage area" is created
only if you store something in it (such as a password, blank or not) ...
otherwise there is no reason to create it.


That is not my observation, as evidenced by this previous remark: "I clicked the "Delete" button in this view and was asked if to restart Eclipse; I said "Yes". This step actually caused the ".eclipse" directory to be created anew."

Perhaps academic, but worth noting nonetheless.

David Williams wrote on Mon, 23 June 2014 07:58

> Next, I exited Eclipse and started it again, repeating the procedure.
> Not surprisingly, Eclipse is still prompting me for my credentials
> every time I connect to a remote server in RSE.
>
Prompts you, you enter nothing, click ok, and you login correctly?


That's correct.

David Williams wrote on Mon, 23 June 2014 07:58

Sounds like "RSE" is simply not remembering "last successful login
method". Not sure why it works for me, but not you. Perhaps related to
OS used? (don't think you ever said which you use).


I did, at the end of my previous post. Smile

David Williams wrote on Mon, 23 June 2014 07:58

Don't recall if you
said, but if you haven't tried yet, you'll want to try with a completely
fresh install, and completely fresh workspace.


I have not tried that yet, but given that this started and continues to be happening on two separate computers, identically-configured, near or at the exact same time (both were migrated from Windows 8 to 8.1 within a couple of weeks of each other) I fear that will be a waste of time. But I'll have to do it all the same to rule-out the possibility before a bug report will be prudent.

David Williams wrote on Mon, 23 June 2014 07:58

Not to mention, someone actually from the project may say if this was an
intentional change, or something. I'm "just a user" and don't have any
insight into the code.

Good luck.


Thanks again for your insight. I'll post back once I've tried a completely fresh installation, and will post a link to the bug report once I've created it.
Re: Eclipse does not save passwords for remote systems [message #1398817 is a reply to message #1393289] Fri, 11 July 2014 16:39 Go to previous messageGo to next message
Ben Johnson is currently offline Ben JohnsonFriend
Messages: 23
Registered: March 2012
Junior Member
I deleted the .eclipse directory, installed Eclipse LUNA, and created a new workspace upon first launch. Now, secure password storage works as intended. Wahoo!

Who knows whether the problem was specific to Eclipse KEPLER or my old workspace, but in either case, I'm happy. Finding the root cause is academic at this point, and not worth the bother.

Thanks again for your help!

[Updated on: Fri, 11 July 2014 16:40]

Report message to a moderator

Re: Eclipse does not save passwords for remote systems [message #1402218 is a reply to message #1398817] Wed, 16 July 2014 17:55 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 716
Registered: July 2009
Senior Member
On 07/11/2014 12:39 PM, Ben Johnson wrote:
> I deleted the .eclipse directory, installed Eclipse LUNA, and created
> a new workspace upon first launch. Now, secure password storage works
> as intended. Wahoo!
Reading this just made my whole day better.
Glad you got it worked out.
Not sure it'd be work opening a bug, or not. (In TM ... though might end
up being the fault of some other piece of code that doesn't "migrate"
workspaces correctly ... or something.

But, thanks for documenting the good news.
Re: Eclipse does not save passwords for remote systems [message #1402842 is a reply to message #1402218] Thu, 17 July 2014 18:54 Go to previous message
Ben Johnson is currently offline Ben JohnsonFriend
Messages: 23
Registered: March 2012
Junior Member
Haha, glad that reading of my successes made your day better! Smile

It's not worth opening a bug, because Luna definitely fixes the issue. I've upgraded to Luna on two affected machines (both Windows 8.1, as I believe that is part of the problem) and secure password storage works flawlessly on both.

And on the second machine, I didn't start with a new workspace; I let Eclipse perform the workspace upgrade, and secure password storage was still fixed. So, upgrading to Luna had to have fixed the issue.

Thanks again for the follow-up! Cheers!
Previous Topic:Eclipse RSE SSH Private Key 'Auth Fail'
Next Topic:cannot run and debug remotely linux to linux with chroot
Goto Forum:
  


Current Time: Fri Mar 27 20:57:26 GMT 2015

Powered by FUDForum. Page generated in 0.01845 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software