Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Syntax Error Squiggly lines
Syntax Error Squiggly lines [message #236289] Wed, 22 July 2009 15:05 Go to next message
Mike Jackson is currently offline Mike JacksonFriend
Messages: 128
Registered: July 2009
Senior Member
Is there a setting to change the yellow syntax error squiggly line to a
highlight instead? The basic problem is that the squiggly line covers
up the bottom part of the test making it extremely difficult to
actually find the error. Like the difference between a period and a
comma. Maybe it just happens to be the font that I am using..

Mike Jackson
Re: Syntax Error Squiggly lines [message #236374 is a reply to message #236289] Thu, 23 July 2009 13:48 Go to previous messageGo to next message
Andrew Gvozdev is currently offline Andrew GvozdevFriend
Messages: 257
Registered: July 2009
Senior Member
Mike Jackson wrote:

> Is there a setting to change the yellow syntax error squiggly line to a
> highlight instead? The basic problem is that the squiggly line covers
> up the bottom part of the test making it extremely difficult to
> actually find the error. Like the difference between a period and a
> comma. Maybe it just happens to be the font that I am using..

If you asking about indexer annotations you can change them in preferences
General/Editors/Text Editors/Annotations. Or just type "annotations" in
preferences search box.

Andrew
Re: Syntax Error Squiggly lines [message #236394 is a reply to message #236374] Thu, 23 July 2009 17:07 Go to previous messageGo to next message
Mike Jackson is currently offline Mike JacksonFriend
Messages: 128
Registered: July 2009
Senior Member
On 2009-07-23 09:48:22 -0400, angvoz.dev@gmail.com (Andrew Gvozdev) said:

> Mike Jackson wrote:
>
>> Is there a setting to change the yellow syntax error squiggly line to a
>> highlight instead? The basic problem is that the squiggly line covers
>> up the bottom part of the test making it extremely difficult to
>> actually find the error. Like the difference between a period and a
>> comma. Maybe it just happens to be the font that I am using..
>
> If you asking about indexer annotations you can change them in
> preferences General/Editors/Text Editors/Annotations. Or just type
> "annotations" in preferences search box.
>
> Andrew

I think I am talking about if I type the following


int i

i = 0;

note the lack of a semi-colon at the end of the first line. CDT will
put a squiggly yellow line under that line. THAT is what I want to
change to a highlight.

Mike
Re: Syntax Error Squiggly lines [message #466492 is a reply to message #236394] Mon, 03 August 2009 00:50 Go to previous messageGo to next message
Andrew is currently offline AndrewFriend
Messages: 17
Registered: July 2009
Junior Member
I found where it is possible to disable the squiggly-line; but,
unfortunately, setting it to highlight instead does not seem possible. The
setting can found here:

window->preferences
|-General->Editors->Annotations

select "C/C++ Index Markers" from the "Annotation Types" listbox

Uncheck the "Text as: ..." checkbox to disable the squiggly-line.

.... but a slightly more preferable option may be to choose a different
color for the squiggle (I found a color to my satisfaction by reducing the
saturation value of the default color).

Not a solution, but I hope that helps.

Cheers,
~Andrew~
Re: Syntax Error Squiggly lines [message #468202 is a reply to message #466492] Tue, 04 August 2009 13:56 Go to previous message
Mike Jackson is currently offline Mike JacksonFriend
Messages: 128
Registered: July 2009
Senior Member
On 2009-08-02 20:50:03 -0400, andrew.spamme@gmail.com (Andrew ) said:

> I found where it is possible to disable the squiggly-line; but,
> unfortunately, setting it to highlight instead does not seem possible.
> The setting can found here:
>
> window->preferences
> |-General->Editors->Annotations
>
> select "C/C++ Index Markers" from the "Annotation Types" listbox
>
> Uncheck the "Text as: ..." checkbox to disable the squiggly-line.
>
> ... but a slightly more preferable option may be to choose a different
> color for the squiggle (I found a color to my satisfaction by reducing
> the saturation value of the default color).
>
> Not a solution, but I hope that helps.
>
> Cheers,
> ~Andrew~

While not the optimal solution this did help. Thanks for the hint.

mike
Previous Topic:Marking matching bracket in C File via background colour
Next Topic:How to create build make targets for subfolders?
Goto Forum:
  


Current Time: Sat Dec 14 06:37:32 GMT 2019

Powered by FUDForum. Page generated in 0.01316 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top