Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Announcing IAM 0.10.0
Announcing IAM 0.10.0 [message #21752] Wed, 08 July 2009 19:24 Go to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
We are glad to announce the public availability of IAM 0.10.0

Eclipse IAM has been updated to work with Galileo (Eclipse 3.5) and to
use some of the new projects on this eclipse release train.

P2 Update site is published at:
http://q4e.googlecode.com/svn/trunk/updatesite-iam/

Ganymede users (Eclipse 3.4) should make sure they have added all the
update sites listed in the installation instructions [1]. If P2
complains about missing dependencies, check the update sites again.

Adopters of the latest and greatest Eclipse Galileo can install from the
update site as usual [1].

If upgrading from Q4E 0.8.1 or earlier, some extra steps must be
followed [2].

The list of changes is available on the eclipse wiki [3].

Note that this is not an official Eclipse IAM release to allow our users
to enjoy the progress made until we complete the move to the foundation
and clear all the IP issues involving the maven embeder.

[1] http://code.google.com/p/q4e/wiki/Installation
[2] http://code.google.com/p/q4e/wiki/UpgradingToEclipseIAM
[3] http://wiki.eclipse.org/New_on_IAM_0.10.0
--
Abel Muiño
Re: Announcing IAM 0.10.0 [message #480362 is a reply to message #21752] Sun, 16 August 2009 08:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: ls-test1.hotmail.com

How to get a fresh install on eclipse 3.5 ?
I only saw http://q4e.googlecode.com/svn/trunk/updatesite-iam/
is it update or install ? It always complains (from eclipse install) as:

Cannot complete the install because one or more required items could not
be found.
Software being installed: Eclipse IAM Team Support
0.10.0.20090627114955616-179-311A1738225A66727
(org.eclipse.iam.feature.teamsupport.feature.group
0.10.0.20090627114955616-179-311A1738225A66727)
Missing requirement: Eclipse IAM Team Support
0.10.0.20090627114955616-179-311A1738225A66727
(org.eclipse.iam.feature.teamsupport.feature.group
0.10.0.20090627114955616-179-311A1738225A66727) requires
'org.eclipse.team.svn.ui [0.7.7,0.8.0)' but it could not be found



Another question, the url includes Maven 2.1 when I install it to eclipse,
How do I change it to other Maven version ?
Re: Announcing IAM 0.10.0 [message #480369 is a reply to message #480362] Sun, 16 August 2009 09:42 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hi L,

L wrote:
> How to get a fresh install on eclipse 3.5 ?
> I only saw http://q4e.googlecode.com/svn/trunk/updatesite-iam/
> is it update or install ? It always complains (from eclipse install) as:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Eclipse IAM Team Support
> 0.10.0.20090627114955616-179-311A1738225A66727
> (org.eclipse.iam.feature.teamsupport.feature.group
> 0.10.0.20090627114955616-179-311A1738225A66727)
> Missing requirement: Eclipse IAM Team Support
> 0.10.0.20090627114955616-179-311A1738225A66727
> (org.eclipse.iam.feature.teamsupport.feature.group
> 0.10.0.20090627114955616-179-311A1738225A66727) requires
> 'org.eclipse.team.svn.ui [0.7.7,0.8.0)' but it could not be found

You are trying to install IAM's support for subversive, but you do not
have a compatible version of subversive installed. Unckeck it.

> Another question, the url includes Maven 2.1 when I install it to
> eclipse, How do I change it to other Maven version ?

Is there any reason you would like to change it? I mean, any
incompatibilities with the provided version? IAM uses the maven embedder
to do its internal work, so it can not be changed.

You can launch the goals with special requirements using any maven
version you have installed from the eclipse External Tools, and rely on
the embedder only for your IDE work.

Yours,
--
Abel Muiño
Re: Announcing IAM 0.10.0 [message #570367 is a reply to message #21752] Sun, 16 August 2009 08:15 Go to previous message
Eclipse UserFriend
Originally posted by: ls-test1.hotmail.com

How to get a fresh install on eclipse 3.5 ?
I only saw http://q4e.googlecode.com/svn/trunk/updatesite-iam/
is it update or install ? It always complains (from eclipse install) as:

Cannot complete the install because one or more required items could not
be found.
Software being installed: Eclipse IAM Team Support
0.10.0.20090627114955616-179-311A1738225A66727
(org.eclipse.iam.feature.teamsupport.feature.group
0.10.0.20090627114955616-179-311A1738225A66727)
Missing requirement: Eclipse IAM Team Support
0.10.0.20090627114955616-179-311A1738225A66727
(org.eclipse.iam.feature.teamsupport.feature.group
0.10.0.20090627114955616-179-311A1738225A66727) requires
'org.eclipse.team.svn.ui [0.7.7,0.8.0)' but it could not be found



Another question, the url includes Maven 2.1 when I install it to eclipse,
How do I change it to other Maven version ?
Re: Announcing IAM 0.10.0 [message #570380 is a reply to message #480362] Sun, 16 August 2009 09:42 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hi L,

L wrote:
> How to get a fresh install on eclipse 3.5 ?
> I only saw http://q4e.googlecode.com/svn/trunk/updatesite-iam/
> is it update or install ? It always complains (from eclipse install) as:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Eclipse IAM Team Support
> 0.10.0.20090627114955616-179-311A1738225A66727
> (org.eclipse.iam.feature.teamsupport.feature.group
> 0.10.0.20090627114955616-179-311A1738225A66727)
> Missing requirement: Eclipse IAM Team Support
> 0.10.0.20090627114955616-179-311A1738225A66727
> (org.eclipse.iam.feature.teamsupport.feature.group
> 0.10.0.20090627114955616-179-311A1738225A66727) requires
> 'org.eclipse.team.svn.ui [0.7.7,0.8.0)' but it could not be found

You are trying to install IAM's support for subversive, but you do not
have a compatible version of subversive installed. Unckeck it.

> Another question, the url includes Maven 2.1 when I install it to
> eclipse, How do I change it to other Maven version ?

Is there any reason you would like to change it? I mean, any
incompatibilities with the provided version? IAM uses the maven embedder
to do its internal work, so it can not be changed.

You can launch the goals with special requirements using any maven
version you have installed from the eclipse External Tools, and rely on
the embedder only for your IDE work.

Yours,
--
Abel Muiño
Previous Topic:IAM Installed but not active on galileo?
Next Topic:can not create any sample Maven project
Goto Forum:
  


Current Time: Sun Sep 23 17:52:36 GMT 2018

Powered by FUDForum. Page generated in 0.02185 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top