Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install aptana studio3 plugin(When I try to run install plugin I get errors : aptana studio3 conflict of dependencies with studio 2)
icon11.gif  Unable to install aptana studio3 plugin [message #786115] Mon, 30 January 2012 02:01 Go to next message
Bernard TREMBLAY is currently offline Bernard TREMBLAYFriend
Messages: 18
Registered: January 2012
Location: Paris, FRANCE
Junior Member

Hi,

I am installing a development env with Eclipse.

When I try to run install I get errors : Aptana studio3 conflict of dependencies with studio 2

History

First I had installed Eclipse with plugin Aptana.
Somebody which whom I work somtimes told me, you don't need Eclipse, two complex and not useful possibility for you.
Then, as him, I had installed aptana studio3 standalone.

After working a little, I felt that I need to use mylyn, MantisBT, and fell well on another computer to begin to use Eclipse.
Too I thought that the project on which I was working was not so simple. I could need some complements that I could not use with aptana alone.

Then I decide to install the Aptana Studio3 plugin, on my current computer.
I uninstall first studio3 standalone.

Even Eclipse 3.7.0 at beginning proposes to install Studio3 plugin and I have followed (I quite know how to make "basic" installations from sites or archives) instruction.

I fail in installing studio3 plugin

But for the moment I failed : I get a lot of the following errors for which I am not able to find why they are and how to avoid them, no opened way to progress.
I found text saying that it is possible to use Aptana studio 2 and 3, but obviously avoid to open the same projects...
The conflict is between studio3 and studio2 plugins.

Do I need to uninstall studio 2 before installing studio3 are they not compatible? No.
It is not normal because it is the contrary of the explanations given for upgrade.
So I think that there is somewhere something else wrong, I missed something ? Where ?.



Here are the errors encountered :
Cannot complete the install because of a conflicting dependency.
  Software being installed: Aptana Studio 3 Plugin 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M (com.aptana.feature.studio.feature.group 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M)
  Software currently installed: Aptana Studio 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7 (com.aptana.ide.feature.studio.feature.group 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7)
  Only one of the following can be installed at once: 
    Aptana SecureFTP Library 2.0.2.1277398033-3-123884A9144 (com.aptana.ide.feature.libraries.subscription.feature.jar 2.0.2.1277398033-3-123884A9144)
    Aptana SecureFTP Library 2.0.2.1317770565-3-12428881676 (com.aptana.ide.feature.libraries.subscription.feature.jar 2.0.2.1317770565-3-12428881676)
  Cannot satisfy dependency:
    From: Aptana Studio 3 Core 3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5 (com.aptana.feature.feature.group 3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5)
    To: com.aptana.ide.feature.libraries.subscription.feature.group [2.0.2.1317770565-3-12428881676]
  Cannot satisfy dependency:
    From: Aptana Studio 3 Plugin 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M (com.aptana.feature.studio.feature.group 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M)
    To: com.aptana.feature.feature.group [3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5]
  Cannot satisfy dependency:
    From: Aptana SecureFTP Library 2.0.2.1277398033-3-123884A9144 (com.aptana.ide.feature.libraries.subscription.feature.group 2.0.2.1277398033-3-123884A9144)
    To: com.aptana.ide.feature.libraries.subscription.feature.jar [2.0.2.1277398033-3-123884A9144]
  Cannot satisfy dependency:
    From: Aptana SecureFTP Library 2.0.2.1317770565-3-12428881676 (com.aptana.ide.feature.libraries.subscription.feature.group 2.0.2.1317770565-3-12428881676)
    To: com.aptana.ide.feature.libraries.subscription.feature.jar [2.0.2.1317770565-3-12428881676]
  Cannot satisfy dependency:
    From: Aptana SecureFTP Support 2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2 (com.aptana.ide.feature.secureftp.feature.group 2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2)
    To: com.aptana.ide.feature.libraries.subscription.feature.group [2.0.2.1277398033-3-123884A9144]
  Cannot satisfy dependency:
    From: Aptana Studio 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7 (com.aptana.ide.feature.studio.feature.group 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7)
    To: com.aptana.ide.feature.secureftp.feature.group [2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2]


Thanks for your help

Best regards

Trebly


Trebly

[Updated on: Mon, 30 January 2012 02:05]

Report message to a moderator

Re: Unable to install aptana studio3 plugin [message #786156 is a reply to message #786115] Mon, 30 January 2012 03:34 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
On 01/29/2012 08:01 PM, Bernard TREMBLAY wrote:
> Hi,
>
> I am installing a development env with Eclipse.
>
> When I try to run install I get errors :studio3 conflict of dependencies
> with studio 2
>
> History
> First I had installed Eclipse with plugin Aptana.
> Somebody which whom I work somtimes told me, you don't need Eclipse, two
> complex and not useful possibility for you.
> Then, as him, I had installed aptana studio3 standalone.
>
> After working a little, I felt that I need to use mylyn, MantisBT, and
> fell well on another computer to begin to use Eclipse.
> Too I thought that the project on which I was working was not so simple.
> I could need some complements that I could not use with aptana alone.
>
> Then I decide to install the Aptana Studio3 plugin, on my current computer.
> I uninstall first studio3 standalone.
>
> Even Eclipse 3.7.0 at beginning propose to install Studio3 plugin and I
> follow (I quite know how to make "basic" installations from sites or
> archives) instruction.
> I fail in installing studio3 plugin
>
> But for the moment I failed : I get a lot of the following errors for
> which I am not able to find why they are and how to avoid them, no
> opened way to progress. I found text saying that it is possible to use
> Aptana studio 2 and 3, but obviously avoid to open the same projects...
> The conflict is between studio3 and studio2 plugins.
>
> Do I need to uninstall studio 2 before installing studio3 are they not
> compatible? No. It is not normal because it is the contrary of the
> explanations given for upgrade.
> So I think that there is somewhere something else wrong, I missed
> something ? Where ?.
>
>
>
> Here are the errors encountered :
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Aptana Studio 3 Plugin
> 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M
> (com.aptana.feature.studio.feature.group
> 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M)
> Software currently installed: Aptana Studio
> 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7
> (com.aptana.ide.feature.studio.feature.group
> 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7)
> Only one of the following can be installed at once: Aptana SecureFTP
> Library 2.0.2.1277398033-3-123884A9144
> (com.aptana.ide.feature.libraries.subscription.feature.jar
> 2.0.2.1277398033-3-123884A9144)
> Aptana SecureFTP Library 2.0.2.1317770565-3-12428881676
> (com.aptana.ide.feature.libraries.subscription.feature.jar
> 2.0.2.1317770565-3-12428881676)
> Cannot satisfy dependency:
> From: Aptana Studio 3 Core 3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5
> (com.aptana.feature.feature.group
> 3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5)
> To: com.aptana.ide.feature.libraries.subscription.feature.group
> [2.0.2.1317770565-3-12428881676]
> Cannot satisfy dependency:
> From: Aptana Studio 3 Plugin
> 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M
> (com.aptana.feature.studio.feature.group
> 3.0.7.201112281220-7E37K7HFGJHQUdGP8W_Iz0Jitq7M)
> To: com.aptana.feature.feature.group
> [3.0.7.1325099706-BJ7F8LBTDuY5meBG31DC34EVnIM5]
> Cannot satisfy dependency:
> From: Aptana SecureFTP Library 2.0.2.1277398033-3-123884A9144
> (com.aptana.ide.feature.libraries.subscription.feature.group
> 2.0.2.1277398033-3-123884A9144)
> To: com.aptana.ide.feature.libraries.subscription.feature.jar
> [2.0.2.1277398033-3-123884A9144]
> Cannot satisfy dependency:
> From: Aptana SecureFTP Library 2.0.2.1317770565-3-12428881676
> (com.aptana.ide.feature.libraries.subscription.feature.group
> 2.0.2.1317770565-3-12428881676)
> To: com.aptana.ide.feature.libraries.subscription.feature.jar
> [2.0.2.1317770565-3-12428881676]
> Cannot satisfy dependency:
> From: Aptana SecureFTP Support
> 2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2
> (com.aptana.ide.feature.secureftp.feature.group
> 2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2)
> To: com.aptana.ide.feature.libraries.subscription.feature.group
> [2.0.2.1277398033-3-123884A9144]
> Cannot satisfy dependency:
> From: Aptana Studio 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7
> (com.aptana.ide.feature.studio.feature.group
> 2.0.5.1278522500-5-7857HJ97CFF61HN1HZHtem5tN7)
> To: com.aptana.ide.feature.secureftp.feature.group
> [2.0.4.1278035782-77-7878BQS8KNJOC040234995BA2]
>
> Thanks for your help
>
> Best regards
>
> Trebly
You need to ask Aptana support for help with their product. These
forums are for Eclipse. They are not for third party tools support.
Previous Topic:Incompatible JavaHL library loaded. 1.7.x or later required
Next Topic:Source code for Set as Target Platform
Goto Forum:
  


Current Time: Sat Jun 19 07:31:48 GMT 2021

Powered by FUDForum. Page generated in 0.05876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top